Base Building DayZ 1.2 Released

Discussion in 'Script/Addon help' started by daimyo21, Mar 17, 2013.

  1. LexGaming

    LexGaming Member

    Well good news I got it working

    but when i make a fire place it give me two options
    smelt recipes
    smelt items

    can anyone tell me how this works

    Edit :when i smelt items it say "dayz_code\actions\player_smelt.sqf not found"
    and when i click smelt recipes nothing happens

    anyone with the same issue


    I got the smelting working with W4rGo's scripts
  2. 78043641

    78043641 Well-Known Member

    ok daimyo I fixed the server functions, but I cant get the build menu to pop up I have buildables and im running crawling nothing pops up, heres my server.pbo.

    Attached Files:

  3. Freaking Fred

    Freaking Fred OpenDayZ Rockstar!

    When you figure this out, please share the fix. I am still having the same issue and I have reinstalled it 3 times.
  4. 78043641

    78043641 Well-Known Member

    is it because im on reality?
  5. ALKINDA

    ALKINDA Valued Member!

    Hey Guys, I recently installed this mod onto my HFB server. This reality - bliss server stuff is really starting to bug the crap outa me. My server runs differently as it seems from reality-bliss servers, meaning the file locations and names are all specific to your hosting provider. Thus on Part 3 - dayz_server (Modified Default Bliss) folder I cannot find the SERVER_FUNCTIONS.SQF, which stores all the DATABASE stuff apparently.

    so i have been looking in all the files they have given me for the line check_publishobject = {
    "bunch of code inside"
    }; But cannot find this reference, either because it is in a diff code or named differently.

    another issue SERVER_PUBLISHOBJECT.SQF isnt a file.

    so I cant edit this line.

    Code (Text):
    if (!(_object isKindOf "Building")) exitWith {
    deleteVehicle _object;
    };
    TO:
    //if (!(_object isKindOf "Building")) exitWith {
    //deleteVehicle _object;
    //};

    Basically the whole section 3 isnt able to be done because its not reality. which severly limits your mod to just that.

    I will upload my DAYZ_CODE.PBO but ive tried to implement this the best way i could. still having issues and its confusing teh hell out of me. when i do get the script pasted into my files and i try to run i get create vehicle restriction. even tho i inserted your battle eye script CreateVehicle.txt to the battleeye folder.

    Thanks for all the help. this is a great idea, just mabe if the server companies USED A DAMN REGULATION for how the server files are set up, that be great so that this issue WONT happen and the creator is discouraged to do anything.


    Everything works, just doesnt save to database. ​

    Attached Files:

  6. zak

    zak Member

    got this working and loveing it only one thing when we build a pannel it goes bye bye it pops up saying it was built but know one can see it.
  7. Krixes

    Krixes Moderator Staff Member

    this is prolly your answer!
  8. dodge

    dodge New Member

    i have this installed on day.st server....chernarus...building works great ...so far..unable to save to database and somehow when we build a normal tent it dissapears as its being made...any ideas?
  9. zak

    zak Member

    ty also i have mocked up a web site for what you need to build each base bits. I will get around to making a list and smaller photos over the next week but this will do for now.

    Base Builder DayZ
  10. Stealth

    Stealth Member

    I got it working ok but I have 2 problems I cannot find a solution too. I am running a DayZ.ST server.

    1. the codes I get given when placing an item never work, they seem too long and not all characters fit into the keypad.

    2. after a server restart everything is deleted

    Any idea's please?
  11. king2k

    king2k New Member

    I get an error in the .rpt log at at server start:

    Code (Text):
    13:16:54 "OBJ: 723407240338252 - Fence_Ind"
    13:16:54 "SERVER: in allbuildables_class:Fence_Ind !"
    13:16:54 Error in expression <ct _i - _i + 2;
    };
    };
    _isDestructable = _requirements select 13;
    diag_log ("SERV>
    13:16:54  Error position: <_requirements select 13;
    diag_log ("SERV>
    13:16:54  Error Undefined variable in expression: _requirements
    13:16:54 File z\addons\dayz_server\system\server_monitor.sqf, line 131
    13:16:54 "OBJ: 72425723793777 - Fence_Ind"
    13:16:54 "SERVER: in allbuildables_class:Fence_Ind !"
    13:16:54 Error in expression <ct _i - _i + 2;
    };
    };
    _isDestructable = _requirements select 13;
    diag_log ("SERV>
    13:16:54  Error position: <_requirements select 13;
    diag_log ("SERV>
    13:16:54  Error Undefined variable in expression: _requirements
    13:16:54 File z\addons\dayz_server\system\server_monitor.sqf, line 131
    (only tested with deploying 2 fence pieces)


    Snippet from my server_monitor.sqf:
    Code (Text):

                    // Set whether or not buildable is destructable
            if (typeOf(_object) in allbuildables_class) then {
                diag_log ("SERVER: in allbuildables_class:" + typeOf(_object) + " !");
                for "_i" from 0 to ((count allbuildables) - 1) do
                {
                    _classname = (allbuildables select _i) select _i - _i + 1;
                    _result = [_classname,typeOf(_object)] call BIS_fnc_areEqual;
                    if (_result) then {
                        _requirements = (allbuildables select _i) select _i - _i + 2;
                    };
                };
                _isDestructable = _requirements select 13;
                diag_log ("SERVER: " + typeOf(_object) + " _isDestructable = " + str(_isDestructable));
    Not sure what I have done wrong. Any ideas?
  12. dodge

    dodge New Member

    im very happy to see the script mostly working and like to say thanks and great job but ..is there any idea why ..

    1.tents no longer deploy.they dissapear as soon as placed
    2.after restart buildings are gone.

    i followed the directions to the letter im pretty sure lol, im assuming i screwed up somewhere but no idea. I am able to build objects on first try after i followed the directions.
    any help on the matter be greatly appreciated.
    running on chernarus on a dayz.st server
  13. daimyo21

    daimyo21 New Member

    Email me files [email protected] and please give detailed description of what your doing in-game and what is not working else I wont even bother as I get about 10 emails a day, many not following the tutorial/updated tutorial.



    What server build are you using? Have you followed the updated tutorial? Look through it again, ive addressed this issue:
    For People Running Reality Server Build for 1.7.6.1:


    In YOUR "dayz_server\init\server_functions.sqf"
    Find this function:
    check_publishobject = {
    "bunch of code inside"
    };
    And Change this line:
    if ((typeOf _object) in _allowedObjects) then {
    to:
    if ((typeOf _object) in _allowedObjects || (typeOf _object) in allbuildables_class) then {
    This will insure that your buildables will write to database.

    Same as above guy


    https://github.com/Daimyo21/BaseBuilding-DayZ/commit/502189958ed23654a6f446e51ac9bcb563178ee2

    Let me know if this works:

    Basically change this:

    Code (Text):
            // Set whether or not buildable is destructable
            if (typeOf(_object) in allbuildables_class) then {
                diag_log ("SERVER: in allbuildables_class:" + typeOf(_object) + " !");
                for "_i" from 0 to ((count allbuildables) - 1) do
                {
                    _classname = (allbuildables select _i) select _i - _i + 1;
                    _result = [_classname,typeOf(_object)] call BIS_fnc_areEqual;
                    if (_result) then {
                        _requirements = (allbuildables select _i) select _i - _i + 2;
                    };
                };
                _isDestructable = _requirements select 13;
                diag_log ("SERVER: " + typeOf(_object) + " _isDestructable = " + str(_isDestructable));
                if (!_isDestructable) then {
                    diag_log("Spawned: " + typeOf(_object) + " Handle Damage False");
                    _object addEventHandler ["HandleDamage", {false}];
                };
                //gateKeypad = _object addaction ["Defuse", "\z\addons\dayz_server\compile\enterCode.sqf"];
            };
    to

    Code (Text):
            // Set whether or not buildable is destructable
            if (typeOf(_object) in allbuildables_class) then {
                diag_log ("SERVER: in allbuildables_class:" + typeOf(_object) + " !");
                for "_i" from 0 to ((count allbuildables) - 1) do
                {
                    _classname = (allbuildables select _i) select _i - _i + 1;
                    _result = [_classname,typeOf(_object)] call BIS_fnc_areEqual;
                    if (_result) then {
                        _requirements = (allbuildables select _i) select _i - _i + 2;
     
                        _isDestructable = _requirements select 13;
                        diag_log ("SERVER: " + typeOf(_object) + " _isDestructable = " + str(_isDestructable));
                        if (!_isDestructable) then {
                            diag_log("Spawned: " + typeOf(_object) + " Handle Damage False");
                            _object addEventHandler ["HandleDamage", {false}];
                        };
                    };
                };
                //gateKeypad = _object addaction ["Defuse", "\z\addons\dayz_server\compile\enterCode.sqf"];
            };
    in you server_monitor.sqf

    Thanks!
    78043641 likes this.
  14. Stealth

    Stealth Member

    What server build are you using? Have you followed the updated tutorial? Look through it again, ive addressed this issue:
    For People Running Reality Server Build for 1.7.6.1:


    In YOUR "dayz_server\init\server_functions.sqf"
    Find this function:
    check_publishobject = {
    "bunch of code inside"
    };
    And Change this line:
    if ((typeOf _object) in _allowedObjects) then {
    to:
    if ((typeOf _object) in _allowedObjects || (typeOf _object) in allbuildables_class) then {
    This will insure that your buildables will write to database.



    Same as above guy




    https://github.com/Daimyo21/BaseBuilding-DayZ/commit/502189958ed23654a6f446e51ac9bcb563178ee2

    Ok tried changing code as above but items still fail to save, again I am running a DayZ.ST server which I believe is bliss.
    Also the pass codes seem to be incorrect all the time, not all digits fit into keypad.
  15. king2k

    king2k New Member

    Code (Text):
    23:35:33 "OBJ: 723407240338252 - Fence_Ind"
    23:35:33 "SERVER: in allbuildables_class:Fence_Ind !"
    23:35:33 "SERVER: Fence_Ind _isDestructable = true"
    23:35:33 "OBJ: 72425723793777 - Fence_Ind"
    23:35:33 "SERVER: in allbuildables_class:Fence_Ind !"
    23:35:33 "SERVER: Fence_Ind _isDestructable = true"
    Destructable check seems ok now.
  16. Stealth

    Stealth Member

    Well I have read right through the forums and cannot seem to get it working correctly.

    Pin codes always come up as denied and items will not save, I have emptied my deployables table and re inserted the code twice now but still will not save.


    EDIT:
    Started from scratch an did everything required as ALL read me's state, only thing I can see now that is stopping this from working, ( Saving items to built and placed items), is the fact that 2 files are missing from the download

    1. "_selfActions 1.7.6.1 with Base Building 1.2" is not actually in the files, I had to get it from a mate.

    2. "BaseBuilding_Deployables" this file is based on Taviana and I am using Chernarus, Open it in word pad and at the top the first line reads "-- Query: SELECT * FROM dayz_tavi2.deployable" and at the bottom the optional code offered is also for Tavi, I dont believe however classnames would change as they are world classnames and it uploads into the database with no errors thrown.

    So my run down on this is either "It DOES NOT work on DayZ.ST servers", "I am going dumb and missing something every time" or " It DOES NOT like other mods like NPC's or piXils' Dogs Scripts."
  17. seaweeduk

    seaweeduk OpenDayZ Rockstar!

    Satchel charges appear to destroy player builables, but they show again on restart. Any way to stop them taking damage from the charges?
  18. dodge

    dodge New Member

    i have a dayz.st server and the buildables do not save either...i also run AI ...but im not sure if that could affect the database saving.i keep thinking i missed something in the tutorial/ i have uploaded my files via email to Daimyo21 in hopes he can find the error..if he can ill upload the chernarus files as reference here. i can verify that at least u can build things without getting kicked or whatnot.
    but at same time now our tents will not deploy...we can build a tent and as soon as its finished building it dissapears
  19. zak

    zak Member

    i have just got this working i havnt run all the test needed bit it saves after a restart. It was a little bit of a bitch to get working but it works good. Aslong as you read all the read me you should be good. For all yous DayZ.ST ppl trying to put it in make shu you folo the reality build and it should work as dayz.st uses a reality database well in a way its reality but its stall there own build. Good luck. And thank for this mod.
  20. djkristoph

    djkristoph New Member

    hmm have question, this script work if i have AntiHack script ? This base build work for only admins ?

Share This Page