kicked by BattlEye: Corrupted Data #5

Discussion in 'Anti Hack Tools and Discussions' started by Althasil, May 3, 2013.

  1. Althasil

    Althasil Well-Known Member

    Hi,

    I have noticed this appearing very recently. I googled this and found a forum post about radar hacking;

    Bearing in mind this was translated. Should I be banning people who attempt to connect and get this error? I have NEVER seen it before, but it has appeared 3 times today alone.
  2. zim1x

    zim1x New Member

    i'm getting this to on my server but it's battleye updating or something.. so i would not kick/ban any players.
  3. x00

    x00 Valued Member!

    Wrong.
    This is related to external cheats (ReadProcessMemory/WriteProcessMemory).
    Players will get this message if the BattlEye Service (BEService.exe) got terminated or if it didnt start at all.
    In 1.193 you could bypass this by starting the Service as a User without administrative permissions, now they patched it and the service won't start without administrative rights.
  4. I am getting kicked for this how do i fix it run as adminastor
  5. bLu3eYeZ

    bLu3eYeZ New Member

    Wrong. As a coder myself, understanding memory editing, what you said is complete BULLSHIT.
    This is just battleye being smartass and kicking anyone who doesn't run the battleye service as admin. For example, If on my computer I do not have admin privileges due the admin account being locked with a password, I would not be able to run that as admin account, not having the password. This method will most likeley kick all users as I have stated above that do not have access to admin account.
    Yes, some of them may be able to make the service run as normal not account when they do have the admin account&password, but not as you stated it being ALL USERS ALTERED PERMISSIONS.
    The guy above me is having this problem probably, not being able to use it as admin as I have stated.
    Please stop informing people wrong, thankyou. Sorry for making you read this huge wall of text.

    EDIT:
    To make more sense:
    - Some kicks are with a reason(user altered the permissions of the service)
    - Some kicks are without a reason(user might not be able to run as admin)
  6. x00

    x00 Valued Member!

    "Understanding memory editing". "As a coder myself."

    This is funny, calling yourself a coder when you don't even seem understand the basics, i.e (quotes from a different forum):

    "What do you mean an int of 2?"

    also this:
    Code (Text):
    int readstartpoint = startpoint;
    int plusfirstshit = readstartpoint + 0x13A8;
    int localPlayer = plusfirstshit + 0x4;
    As you said yourself: "I'm sorry for being stupid, I'm still learning."

    Greetings
    bLu3eYeZ likes this.
  7. selian_blade

    selian_blade New Member

    I've been adding things from this site to my server lately. I've notice (Not that I'm claiming to understand most of this code stuff) that I can't get on my server when I bypass the dayz_code.pbo. But when I remove that Bypass and play on an earlier file that I edited before (I keep records of working pbo's), that I do not get kicked. So I'm wondering if this MAY play a factor in it.
    My experience came from the server working fine, but then I tried to edit it so I could remove vehicle parts. When I use this edit, it stops me from being able to play and I get Corrupt Data #5. I assume (Again, no coding genius), that changing that pathway may be a cause.
  8. Althasil

    Althasil Well-Known Member

    I have remove vehicle parts on my server and it working fully. Even at maximum capacity right now.
  9. selian_blade

    selian_blade New Member

    Well then I'd really like to know how to get passed this issue.
  10. jasonpointer

    jasonpointer Valued Member!

    ive had this today too but fixed after updating the battleye .DLL file and so far no kick in the last 8 hours.

    this is where I got the update from and its a local issue not the server side.
    http://www.battleye.com/download.html

    hope it helps :)
    enjoy your game...

    ps someone help me with some scripts preety please lol
  11. bLu3eYeZ

    bLu3eYeZ New Member

    Never said I'm pro at it, the guys helped me learn, I managed to get a guy and explain how the multi-level pointers work properley. Still, your argument was invalid. Some kicks are deserved and some are not deserved, its just battleye being smart. Props to you for finding that tho :)
  12. x00

    x00 Valued Member!

    I was a quite active member there, for multiple years.
  13. bLu3eYeZ

    bLu3eYeZ New Member

    Nice to know.
    Going afk for a while, trying to get the antihack you published on a friend's server.
    See ya :)
  14. ptyyy

    ptyyy New Member

    Seems like you're quite active on multiplayer game hacking regarding DayZ scripting and other cheats.

    http://www.mpgh.net/forum/search.php?searchid=4016068
  15. dave_beastttt

    dave_beastttt Member

    Surprised no one who hosts multiple DayZ servers hasn't picked up on this sooner. Since the Batteleye updates, I can no longer "stream" my servers to populate them in the morning like previously:-

    Log on to the lobby of server 1, tab out and use DayZ Commander to join server 2 lobby, and so on until I was present in the lobby of my 3 DayZ servers.

    Now, since the BE update, when I try and join the 2nd server, both instances kick me out of the game with the corrupted #5 data kick.
  16. ptyyy

    ptyyy New Member

    I completely uninstalled the game, deleted the directories, etc. then re-installed everything. Worked for me but occasionally I get a memory address issue. Better than not playing at all I guess.
  17. dave_beastttt

    dave_beastttt Member

    All I was saying is there can be a legitimate reason for the error message, I would assume that re-installing BE would cure this if you're not "streaming" and just using 1 client at a time.
  18. ptyyy

    ptyyy New Member

    Reinstalling BE did not fix it for me, if by reinstalling you mean redownloading the .dll for client and server.
  19. Althasil

    Althasil Well-Known Member

    Well, it has now happened to me. It was even on my own server. It only happened once and when I closed the game and rejoined it was fine. I asked one of my regulars who had the issue if he did anything to resolve it his end and he said he 'verified the integrity of the game cache' through Steam. I'm not saying that this is a fix, but it seems too widespread to be calling foul play on anyone purely for 'corrupted data #5'.
  20. Coconuts

    Coconuts New Member

    Don't call yourself a coder if you don't even understand the basics. You're a pseudo-coder is what you are, a poor excuse for an amateur script kiddy.

Share This Page