ACRE and DayZ.st

Karmafied

Member
Greetings, gents.

I am running a very small private server for my family and I am desperately trying to get ACRE installed. I have installed on their computers: CBA, CBA_A2, CBA_OA, CBA_CO, JayArmA2Lib, and a few other like JSRS and BCVisuals.

I have FTP access to my server on DayZ.st and have tried everything I can think of to get the server to allow ACRE. I have even created a folder called Keys and uploaded every key I could find. I have uploaded the ACRE and JayArmA2Lib folders. Uploaded the CBA folders (all of them). Hell, I even turned off BattleEye! But still, every login brings the error that ACRE and/or JayArmA2Lib is not allowed on the server (keys are not accepted).

ANY help here is appreciated. I promise you that I have gone through every online resource I could find, YT Vids, old BI threads, everything. I know this is supposed to be a huge pain in the ass, but I have tried every reasonable thing I could think of.

Thanks!
 

Allanstrings

New Member
We need to install the keys on the server, your local ftp folder will not work.
Email them to us at admin@dayz.st
We already have a good chunk of the CBA keys in every server, but send us all of the ones you want to use just in case.

After you get confirmation from us that they are installed, you can add all the pbo's to your @bliss/addons folder in ftp, and edit your mission to add the pbo's to the allowed list.
 

Karmafied

Member
Update: It has been four days and I have not heard from Dayz.st since. I will update when this takes place and what the results are.
 
  • Like
Reactions: Pwn

Karmafied

Member
I received an email from the admin today that stated all keys I sent (CBA, CBA_OA, CBA_A2, etc.) were already installed, it was only the JayArmA2Lib.bikey that needed to be added. Once I restarted the server, it would take effect. And it did just that. I added the @ACRE;@JayArmA2Lib; to my DZC mod line and there were no errors.

I have setup TS3 and TS3Server, and I get the new PRC-343 in the game. Now to just figure out how to use the damn things! =)
 

Karmafied

Member
I AM SO DAMN CLOSE.

I have everything installed and linked up. TS3 recognizes ACRE and ACRE is showing up ingame. But for some reason, I CANNOT transmit. All the tutorials say that in TS3, you should be choosing DIRECT INPUT but that is not an option on mine. I've tried reinstalling, etc., but to no avail.

The hard part is over. I've figured everything else out, but this is the last issue to get this damn thing working. Anyone experienced this?
 

Spider

Well-Known Member
Are you using Push to Talk? Do you get the window in the lower right corner when transmiting? Can you configure your Radio? Do you get the squawk sound when pressing capslock? Is your Teamspeak Version Supported by ACRE? Do you use the right Version of the pluging (x86/x64)?
 

Karmafied

Member
Ive disabled the ingame ptt buttons. My ts3 recognizes that acre is connected. I get the box in dayz that says acre is on. I see the acre radios in game. When I ptt I don't see the box in lower right nor do I hear squelch. And x64 is correct plugin for me. Do u think im not getting direct input option because im using my webcam as my mic?
 

Karmafied

Member
Any of the Talk on X Channel buttons, I turned off (made no button connection). And I am not using any Anti-Hack.
 

Karmafied

Member
I have the latest version. I will try the version you suggested next and see what it gets me.

I am still thinking that my usb webcam acting as my mic is why im not getting the DIRECT INPUT option in ts3. Ive since plugged a mic into my pc so I'll see if that also has an effect and report back later today. Thanks, guys.
 

Karmafied

Member
Making progress. I went to version 3.0.1.2 of TS3 and the first thing I noticed was the Direct Input option. So now, when I hit my PTT key (L-Alt), I can transmit.

HOWEVER, after I added the @JayArma@Lib;@ACRE; tags back into my modline, and TS3 showed that Arma2 was connected, I expected everything to be ready. In game, I still have no squelch sound when trying to transmit, nor do I have any windows/boxes to display that I am transmitting. There IS a box that displays when I close TS3 while ingame (Teamspeak is not connected to Arma2!). The radios in game are the ACRE radios so I feel like I am almost there. Do I need to do anything besides set my PTT key in TS3? I've already disabled the PTT key in Dayz Controls; do I need to do anything in the userconfig files of ACRE?
 

Spider

Well-Known Member
You can change your ACRE Controlls in your acre_keys.hpp if you want.

PTT key (L-Alt), I can transmit.

You mean your Key that let's you speak in Teamspeak? If you want to transmit via radio ingame you need to press Capslock. Your PTT Key is just for talking ingame without using the radio.

You should get at least a pop up when transmitting and be able to change your radio channels. You only get the squawk sound when ACRE can reach another radio btw.
 

Karmafied

Member
Try pressing CTRL+SHIFT+X in game and tell me if it opens the radio gui or not.


No, my toon only crouches down when I press this combination. The radios I see in-game are the AN/PRC-343, but I get nothing when I press these buttons.
 
Top