Building bridges

Hello everyone. I am having a bit of a problem. My server is running the Napf map and I am having problems building a bride over water to an AI island I created. Does anyone have any tips for building over water?
 
Thank you so much Ltg for the link. At least I can go through the code and see if there's any correlation to building bridges there, and starting one on my server. Thanks again.
 
I have a better way of creating a bridge.

I just made this bridge.
1.1km long



bridge.sqf

Code:
//START//

if (isNil "oneTime") then {

oneTime = true;


fnc_bridgeA2 = {
private ["_start","_obj"];
_start = createVehicle [
_this select 2,
_this select 0,
[],
0, "
CAN_COLLIDE"
];
_start setVectorUp [0,0,1];
_start setDir (_this select 1);
_start setPosATL (_this select 0);
for "_i" from 1 to (_this select 3) do {
_obj = createVehicle [
_this select 2,
_this select 0,
[],
0,
"CAN_COLLIDE"
];
_obj attachTo [_start, [
_i*(_this select 4),
_i*(_this select 5),
_i*(_this select 6)
]];
};
};

//END//



//Placement of objects//
//[startingPosition, direction, objectClass, repeats, offsetX, offsetY, offsetZ]


[ [13287.128, 2786.3577, -0.3], 222.15, "Land_nav_pier_m_2", 27, 40, 0, 0 ] call fnc_bridgeA2;

};
Using KillzoneKid fnc_bridgeA2 script

Very simple and it doesnt screw up =)

Ingame image

 
Not sure =)

Code:
while {debugMonitor} do
{
    _pic = (gettext (configFile >> 'CfgVehicles' >> (typeof vehicle player) >> 'picture'));
        if (player == vehicle player) then
        {
            _pic = (gettext (configFile >> 'cfgWeapons' >> (currentWeapon player) >> 'picture'));
        }
            else
        {
            _pic = (gettext (configFile >> 'CfgVehicles' >> (typeof vehicle player) >> 'picture'));
        };
        hintSilent parseText format ["
    <t size='1.5' font='Bitstream' align='center' color='#EDE275'>%1</t><br/>
        <br/>
    <t size='1' font='Bitstream'align='center'>Face First</t>
        <t size='1' font='Bitstream'align='center'>Epoch Server</t><br/>
        <br/>
        <t color='#FDD017' size='0.95' font='Bitstream' align='left'>Zombies Killed: </t><t color='#FFFFFF' size='0.95' font='Bitstream' align='right'>%2</t><br/>
        <t color='#FDD017' size='0.95' font='Bitstream' align='left'>Survivors Killed: </t><t color='#FFFFFF' size='0.95' font='Bitstream' align='right'>%4</t><br/>
        <t color='#FDD017' size='0.95' font='Bitstream' align='left'>Bandits Killed: </t><t color='#FFFFFF' size='0.95' font='Bitstream' align='right'>%5</t><br/>
        <t color='#FDD017' size='0.95' font='Bitstream' align='left'>FPS: </t><t color='#FFFFFF' size='0.95' font='Bitstream' align='right'>%8</t><br/>
        <t color='#FDD017' size='0.95' font='Bitstream' align='left'>Humanity: </t><t color='#5CB3FF' size='0.95' font='Bitstream' align='right'>%7</t><br/>
        <t color='#FDD017' size='0.95' font='Bitstream' align='left'>Blood: </t><t color='#E41B17' size='0.95' font='Bitstream' align='right'>%6</t><br/>
        <br/>
    <t size='0.90' font='Bitstream'align='center'color='#FDD017'>Restart in %9 minutes!</t><br/>
    <t size='0.75' font='Bitstream' align='center' color='#FDD017'>Press INSERT to toggle</t>
        <br/>
    <img size='3' image='%10'/><br/>
    ",
        (name player),
        (player getVariable['zombieKills', 0]),
        (player getVariable['headShots', 0]),
        (player getVariable['humanKills', 0]),
        (player getVariable['banditKills', 0]),
        (player getVariable['USEC_BloodQty', r_player_blood]),
        (player getVariable['humanity', 0]),
        (round diag_fps),
        (180-(round(serverTime/60))),
        _pic];
    sleep 1;
};
 

LTGNick

Valued Member!
Code:
21:39:17 Error in expression <ns\__cur_mp.chernarus\debug.sqf"
while {debugMonitor} do
{
_pic = (gettext (conf>
21:39:17   Error position: <debugMonitor} do
{
_pic = (gettext (conf>
21:39:17   Error Undefined variable in expression: debugmonitor
21:39:17 File mpmissions\__cur_mp.chernarus\debug.sqf, line 1
Any ideas whats up with that :O?
 

DangerRuss

OpenDayZ Rockstar!
the excelsior bridge can be very buggy depending on the server. I can't use it on my vilayer server because it eventually starts rotating.
 
Fully, how're you calling the SQF? I can't seem to get it right?

I have a better way of creating a bridge.

I just made this bridge.
1.1km long



bridge.sqf

Code:
//START//

if (isNil "oneTime") then {

oneTime = true;


fnc_bridgeA2 = {
private ["_start","_obj"];
_start = createVehicle [
_this select 2,
_this select 0,
[],
0, "
CAN_COLLIDE"
];
_start setVectorUp [0,0,1];
_start setDir (_this select 1);
_start setPosATL (_this select 0);
for "_i" from 1 to (_this select 3) do {
_obj = createVehicle [
_this select 2,
_this select 0,
[],
0,
"CAN_COLLIDE"
];
_obj attachTo [_start, [
_i*(_this select 4),
_i*(_this select 5),
_i*(_this select 6)
]];
};
};

//END//



//Placement of objects//
//[startingPosition, direction, objectClass, repeats, offsetX, offsetY, offsetZ]


[ [13287.128, 2786.3577, -0.3], 222.15, "Land_nav_pier_m_2", 27, 40, 0, 0 ] call fnc_bridgeA2;

};
Using KillzoneKid fnc_bridgeA2 script

Very simple and it doesnt screw up =)

Ingame image

 
Fully, how're you calling the SQF? I can't seem to get it right?
depbo the dayz_server.pbo
add your bridge.sqf (or what ever you have named it) to your custom folder (I use mapaddons)
then open server_monitor.sqf in the system directory

then find // Custom Configs around line 14, and add (this is the file that I use)
call compile preProcessFileLineNumbers "\z\addons\dayz_server\mapaddons\Skalisty.sqf";

*just rename to what you have renamed your directory and file to* =)
 
Top