DZAI AIR Patrol never spawn


New Member
First : Thanks for this AI Mod. It's excellent work and they add challenge to low player servers. I complete the server with Sarge AI to add "survivors" too to so fire at will isn't humanity good (for those who bother...).

I already used DZAI with succes on our past Dayz server. Everything was fine and Ait patrol were THE challenge missing when peoples lack of challenges.

On our Overpoch server, I can't have the AI patrol spawn. I checked in RPT and foot patrols are present, I'm pretty sure vehicle patrol too but I never saw any heli patrol. I removed Sarge AI air patrol to be sure for any interference and now... nothing in the sky.

I can't see any error justifying this (but Sarge AI generate a lot of error... to I will try to remove it too. Anyway, The mod load as I can see in the logs. I tried to put fresh downloaded generic files over my config thinking it's may be a parameter issue but I still get not heli patrol.

... I didn't remember havin difficulty using this mod...

My server is Overpoch + DZAI (For aggressive Air patrol), WAI (for Missions), SARGE AI (To add confusion in AI by spawning "good" AI and military AND allow bot to steal vehicles).

Any suggestion to guide me to the light?




OpenDayZ Rockstar!
You need to enable the air patrols to have them active. Check the air vehicle section in dzai_config.sqf and see if you've missed any settings.

If you've made sure that you've properly enabled air patrols (check the DZAI_maxHeliPatrols and DZAI_heliList settings) and you still don't see any heli patrols, enable debug mode 1 in the config and look in your RPT line for a line that contains "DZAI Debug: Assembled helicopter list:". This line will list all helicopters that DZAI will be able to spawn


New Member
Yes, I already activated air patrol, defined them to 5 and the assembled helicopter list contain the list of the two default helicopter x 5 instance.

After removing Sarge AI, the helicopter patrol appeared (I saw one at distance so I suppose it's it as I removed Sarge. This should have something to do with Sarge AI, maybe a shared global parameter... I should have tried this before. I removed the heli spawn from Sarge but never tried to disable the mod.

I will default it and try again adding one parameter at the time to find the problem...

WAI si still there and no compatibility problem noticed.

Your MOD is Great! Thanks for it and your active support.