DZAI not loading, nothing in rpt log.


New Member

I started a dayz Epoch server about a week ago, and while being a major noob at the scripting, i managed to get at least some addons working, including DZAI.

However, i decided to set up a test environment on my desktop to get a bit more debug done on the server, as every time i had been trying to add something, and needed to test it, i would get players on and I'd fell like i couldn't take it down again and continue my work.

Eventually, i wanted to take my test environment and overwrite the server files with it, as the server wasn't running so well, but at least it was working. And then i would have peace to get everything working on my desktop.

When i got to adding DZAI (and WAI) however, i found that i could not get any AI to spawn from either addon on my desktop. After many frustrated hours, i decided to do the overwrite anyway on my server, believing that it was something on my desktop that was at fault. Turns out it wasn't.

I've gone through the installation guides of both addons multiple times, started over with a fresh dayz_server.pbo a couple of times and probably had too much coffee for most of January already.

The arma2oaserver.rpt log never gives any indication of either mod even being loaded, despite their activation is correctly being called in the server_monitor.sqf. I have tried replacing the callcompile with a execVM as mentioned somewhere else on the forum, but no luck.

I use PBOmanager 1.4, and have the following addons working on the server/desktop atm:
A plot for life + snap pro. -
Admintools -
debug monitor -
auto refuel -
custom loadout -

All addons downloaded (and redownloaded a few times) from github yesterday and today. So should be the newest versions possible.

Regarding configs. I first tried with a config i had been messing around in, but as i realized nothing worked, i replaced with default configs. Also tried taking the configs of my server that worked, but to no avail. I'm linking my rpt log, and my dayz_server.pbo - The server monitor have the activation call as execVM instead of the standard compile, it was the last thing i tried before starting to write this thread.

Oh and btw Buttface, in your "Need help? Before you ask, read this" thread, the link to your github is broken ;)

day_server.pbo :
arma2oaserver.rpt :

I hope someone can point out what went wrong, because i have no ideas left anymore :)


OpenDayZ Guru!
your server creates the wai and dzai on my test server, just like it does on your local test server. So I would have to say that you are not uploading the file in a manner to be used by the game server. You said you are making changes to the live server right along so I should assume you know what you are doing ... but I am not going to do that :D
Are you using Vilayer? Are you uploading the unpacked dayz_server folder into your vilayercustomcode folder? You should be. If you upload the packed pbo to your dayz_epoch_server folder it will be overwritten by the custom code folder every time.
Some other hosts use the same methods I am sure.
Since it works on your test server and my test server and no errors in the log, I am sure its some error in uploading to the wrong folder.


New Member
Hey there Shootingblanks.

The server is my own dedicated, custom built ^^

I don't use vilayer (what is that, nvm I'll Google later).

I use teamviewer to edit directly on the server just as had it been on my desktop, so there is no transfer process of any kind.

Since my post i decided to start again from scratch on my desktop, but without a plot for life, and this time it works. So could say that the thread is done, but I believe that it was that addon that overided the server_monitor in some way. But I'll be looking into that tomorrow.

As i said though, noob at programming so it's more likely that I made a mistake adding that addon.


OpenDayZ Guru!
the server monitor cant be "overridden" like the compiles, selfactions et al. from dayz_code.
so now that its working, make a backup and then install the crap4life script...

i a going to release my improved and simplified base building some day that makes all that stuff unneeded.
all i have to do is finish it ... but before that i have to actually start it LOL. but,its,all planned out in,my pea-brain


New Member
Had a few busy days so i didn't have time to work further on my server.
But decided to tackle the problem again, and now i finally notice that one of the very last steps of installing a plot for life asks you to redirect loading of server_monitor.sqf to it's own one, instead of the one inside the PBO.

One big derp for me, hopefully a few chuckles worth from you guys.


OpenDayZ Guru!
ah, so you pointed to an entirely different file... apparently I am corrected. No script should EVER tell you to use their version of a file.