Error happened when I put on Bandit Clothes

I don't know if this is Bandit_DZ specific because it was the first clothes i found. But when I wore it the broken bone icon came up and the zombies didn't chase me anymore. Like I was sided with them or something. And despite having a broken bone icon I could walk around like normal. I tried to put on the civilian clothing but it kept saying "needs to be in main inventory" or something, and it was. I tried putting it on the ground and picking it up again, didn't work.

I always have showscripterros on and I was seeing some code error constantly looping. I'll fraps it next time, this time I was kinda rushing since there were other players on. I couldn't abort either so I Alt+F4'd. When I joined back other players in the lobby said they couldn't get in. When I tried it would do that timed out thing "Something Went Wrong..." etc. I tried a couple times, no dice, so I reset the server via RCON.

When I logged in I didn't have the Bandit skin and everything was normal. It did save my location, but no Bandit skin.

EDIT: Looking at the server log another guy said "ive got a broken leg but i can still run.. :\" So once I put the Bandit clothes on it affected him to.
 
Red in the console this morning and nobody is on so I suspected it happened again. sure enough:

Code:
28.05.2013 06:03:20: Cheesecake (XXXXXXXXXXX) XXXXXXXXXXXXXXX - #0 "BanditSkin_DZ" 34:3846 [3,0,0]
Anyone know how to disable the BanditSkin_DZ clothes spawn. Should I edit the server_playerSync.sqf and make it delete BanditSkin_DZ or is there a better way?
 

Nonov Urbizniz

OpenDayZ Rockstar!
Staff member
Be patient, Seven will provide some support on how to get it working right.

Don't bother focusing on the bandit skin it's not that. DayZ Horror has had 2 60 slot servers jammed pack for the last 2 days and not one report of the same thing as far as I've heard.
 

Seven

Moderator
Staff member
From the sounds of this you are not using our server package, No Packages ie. Reality, Pwnzor, Stapo will not work with sahrani. We have made several changes to the server code to allow our changes to work. I will be writing up a server setup procedure tomorrow morning.
 
I'm using the one you guys just released -0.2.1 link in main post- it has to be one of my addons.
I added:
-Dogs
-Refuel Script
-Remove Parts
-Self Bloodbag

I'll just mess with it more, see if I can Fraps the error so I can pause it. I think you're right, it might be something else. I just wanted to eliminate and test but it would be a miracle to find the clothes again myself. ;)
 

Seven

Moderator
Staff member
you may want to get the server running first before adding addons, I can't help you fix the server, if its not my code causing the problem.
 
True. I think I found it. Possibly a custom selfActions script. I matched the original more closely and am testing it now.

EDIT: to be more specific. I replaced the code between the custom scripts in my fn_selfActions.sqf with your servers dayz_code fn_selfActions.sqf. They were very different.

I had a chance to Fraps the loop errors to see what was looping and custom/fn_selfActions.sqf line 31 was flashing back and forth with player_checkStealth.sqf line 109. So hopefully this fixes it.

Thanks. Sorry if you took it as me saying something is wrong w your code. Didn't intend to sound like that. :)
 
Top