Private Server setup

So I've gone through the motions of setting up a server based on what I read here and on the github page and from the last time I tried this ~3 years ago (and had much more success back then!). Right now, whenever I try to connect, I get into the lobby, can receive the mission, but then nothing happens.

Steps I've taken:
  • I tried to install ARMA 2 and ARMA2 OA from SteamCMD, but one of the app id's didn't work? I own both the games so I installed them and copied them from my steam client install.
  • Copied ARMA 2 OA, then the AddOns folder of ARMA 2.
    • This was from a thread I read. Should I copy ARMA 2 then over-copy ARMA 2 OA?
  • Copied the DayZ mod folder from Steam. Updated the steam_app.txt file to match the Steam DayZ app id. Prior to this, I was getting "Session lost."
  • Installed MySQL server, set up the user and the database, verified functionality, etc.
  • Set up the server.cfg and hiveext.ini files with the appropriate values.

As far as I can see, my server runs and I can join it. Like I stated above, I see the lobby after typing the server password, I can click into the server, and it starts receiving the mission. Once that happens, I get to the "DAYZ" loading screen and the progress bar freezes about 75% of the way in. The database contains NO data for player data or player login.

The server console(s) only ever show this:

21:31:23 Dedicated host created.
21:31:25 BattlEye Server: Initialized (v1.207)
21:31:25 Host identity created.
21:31:25 Game Port: 2302, Steam Query Port: 2303
21:33:23 Matthew uses modified data file
21:33:23 BattlEye Server: Player #0 Matthew (192.168.1.2:2304) connected
21:33:23 Player Matthew connecting.
21:33:23 Mission DayZMod read from directory.
21:33:24 BattlEye Server: Player #0 Matthew - GUID: XXXXX (unverified)
21:33:25 Player Matthew connected (id=XXXXX).
21:33:25 BattlEye Server: Verified GUID (XXXXX) of player #0 Matthew
21:33:25 BattlEye Server: Player #0 Matthew - Legacy GUID: XXXXXX
21:33:30 Roles assigned.
21:33:30 Reading mission ...
21:33:48 Mission read.
21:33:49 Game started.


Nothing else ever happens, and my game client just sits there. What might I have done wrong???
 
Last edited:
I am going through this now. I was not using DayZ Overwatch; is t

hat something I need? The only differences between the video and what I did was I merely copied the ARMA 2 add-ons folder to the Private Server folder. I am redoing that now from scratch: first copying ARMA 2 files, and then ARMA 2 OA files.

Once I have that, everything else is pretty much the same (barring the DayZ Overwatch versus the Pwnoz0r pack from github.) Also, I don't have a mysql package in the zip file contents, but I have MySql installed, the database created, the user setup and verified with access.

Here's some differences I see from when I connect versus what the video shows:
  • When a player connects, the BE Server window never pops up. I did follow the Pwnoz0r guide for downloading the BE Server dll file and placed that in the specified folder.
  • HiveExt window never pops up either.
I'm in the process of recopying everything so I'll try again.

So when I redid everything, my ArmA 2 A console shows the following and then it just stops.

22:41:28 Game Port: 2302, Steam Query Port: 2303
22:43:12 Matthew uses modified data file
22:43:12 BattlEye Server: Player #0 Matthew (X.x.x.x:2304) connected
22:43:12 Player Matthew connecting.
22:43:13 Mission DayZMod read from directory.
22:43:14 BattlEye Server: Player #0 Matthew - GUID: X (unverified)
22:43:14 Player Matthew connected (id=X).
22:43:14 BattlEye Server: Verified GUID (X) of player #0 Matthew
22:43:14 BattlEye Server: Player #0 Matthew - Legacy GUID: X
22:43:18 Roles assigned.
22:43:18 Reading mission ...
22:43:37 Mission read.
22:43:38 Game started.

Checking the RPT file, I see:

22:41:28 Initializing Steam server - Game Port: 2302, Steam Query Port: 2303
22:41:30 Connected to Steam servers
22:43:14 Server error: Player without identity Matthew (id X)
22:43:14 Server error: Player without identity Matthew (id X)
22:43:14 Server error: Player without identity Matthew (id X)
22:43:14 Server error: Player without identity Matthew (id X)
22:43:14 Server error: Player without identity Matthew (id X)
22:43:14 Server error: Player without identity Matthew (id X)
22:43:14 Server error: Player without identity Matthew (id X)
22:43:14 Server error: Player without identity Matthew (id X)
22:43:14 Server error: Player without identity Matthew (id X)
22:43:14 Server error: Player without identity Matthew (id X)
22:43:14 Server error: Player without identity Matthew (id X)
22:43:14 Server error: Player without identity Matthew (id X)
22:43:14 Server error: Player without identity Matthew (id X)
22:43:14 Server error: Player without identity Matthew (id X)
22:43:14 Server error: Player without identity Matthew (id X)
22:43:20 Unrecognized CfgNonAIVehicles simulation thing in bin\config.bin/CfgNonAIVehicles/Land_lampa_sidl/
22:43:20 Unrecognized CfgNonAIVehicles simulation thing in bin\config.bin/CfgNonAIVehicles/Land_PowLines_WoodL/
22:43:21 Unrecognized CfgNonAIVehicles simulation thing in bin\config.bin/CfgNonAIVehicles/Land_lampa_ind/
22:43:22 Unrecognized CfgNonAIVehicles simulation thing in bin\config.bin/CfgNonAIVehicles/Land_PowLines_ConcL/
22:43:24 Unrecognized CfgNonAIVehicles simulation thing in bin\config.bin/CfgNonAIVehicles/Land_lampa_ind_zebr/
22:43:24 Unrecognized CfgNonAIVehicles simulation thing in bin\config.bin/CfgNonAIVehicles/Land_lampa_sidl_2/
22:43:27 Unrecognized CfgNonAIVehicles simulation thing in bin\config.bin/CfgNonAIVehicles/Land_lampa_sidl_3/
22:43:37 "PRELOAD_ Functions\init [[<No group>:0 (FunctionsManager)],any]"
22:43:37 "MPframework inited"
22:43:37 "dayz_preloadFinished reset"
22:43:40 "Res3tting B!S effects..."
22:43:40 "HIVE: Starting"
22:43:40 "z\addons\dayz_code\system\REsec.sqf:Monitoring Remote Exe..."
22:43:40 Error in expression <ray = call compile format ["%1",_data];
_resultArray
};

onPlayerDisconnected "[>
22:43:40 Error position: <_resultArray
};

onPlayerDisconnected "[>
22:43:40 Error Undefined variable in expression: _resultarray
22:43:40 File z\addons\dayz_server\init\server_functions.sqf, line 119
22:43:40 Error in expression <ray = call compile format ["%1",_data];
_resultArray
};

onPlayerDisconnected "[>
22:43:40 Error position: <_resultArray
};

onPlayerDisconnected "[>
22:43:40 Error Undefined variable in expression: _resultarray
22:43:40 File z\addons\dayz_server\init\server_functions.sqf, line 119
22:43:40 "HIVE: Request sent"
22:43:40 Error in expression <y call server_hiveReadWrite;
_outcome = _result select 0;
if (_outcome == "PASS">
22:43:40 Error position: <_result select 0;
if (_outcome == "PASS">
22:43:40 Error Undefined variable in expression: _result
22:43:40 File z\addons\dayz_server\system\server_monitor.sqf, line 19
22:43:40 "DEBUG FPS : 16.9671"
22:43:41 "INFO - Player: Matthew(UID:76561197969752374/CID:any) Status: LOGGED IN"
22:43:41 "B 1-1-A:1 (Matthew) REMOTE, dayzSetDate, [B 1-1-A:1 (Matthew) REMOTE], 3"
22:43:41 "CRASHSPAWNER: Starting crash site spawner. Frequency: 25±20 min. Spawn chance: 0.75"
22:43:41 "CLEANUP: INITIALIZING CLEANUP SCRIPT"
22:43:42 "Spawning an infected camp (Camp2_Small) at [3271.3,11616.9,0]"
22:43:42 Error in expression <ray = call compile format ["%1",_data];
_resultArray
};

onPlayerDisconnected "[>
22:43:42 Error position: <_resultArray
};

onPlayerDisconnected "[>
22:43:42 Error Undefined variable in expression: _resultarray
22:43:42 File z\addons\dayz_server\init\server_functions.sqf, line 119
22:43:42 Error in expression <" call server_hiveReadWrite;
_outcome = _result select 0;
if(_outcome == "PASS")>
22:43:42 Error position: <_result select 0;
if(_outcome == "PASS")>
22:43:42 Error Undefined variable in expression: _result
22:43:42 File z\addons\dayz_server\system\scheduler\sched_sync.sqf, line 7
22:43:42 "CRASHSPAWNER: Spawning crash site (CrashSite_RU) at [5555.65,9129.93,0] with 6 items."
22:43:45 "DEBUG: Spawning a care package (Misc_cargo_cont_net3) at [4361.72,8599.68,0] with 7 items."
22:43:47 "Spawning an infected camp (Camp2_Small) at [8573.1,3100.19,0]"
22:43:48 "DEBUG: Spawning a care package (Misc_cargo_cont_net1) at [3412.64,5536.36,0] with 3 items."
22:43:50 "DEBUG: Spawning a care package (Misc_cargo_cont_net3) at [9337.51,11245.7,0] with 9 items."
22:43:52 "Spawning an infected camp (Camp1_Small) at [1099.46,8048.22,0]"
22:43:54 "DEBUG: Spawning a care package (Misc_cargo_cont_net1) at [3280.51,4526.69,0] with 6 items."
22:43:56 "DEBUG: Spawning a care package (Misc_cargo_cont_net3) at [10098.8,8334.69,0] with 8 items."
22:43:57 "DEBUG: Spawning a care package (Misc_cargo_cont_net1) at [13005.3,10717,0] with 4 items."
22:44:05 No owner
22:44:18 ["sched_lootpiles_5mn: reset lootpiles check, total visited:",86,"listed:",0]

Nothing ever happens on the game client and I end back up in the lobby. There are no database tries and the HiveExt window never shows up or logs anything. (I used to run servers back a few years ago and remember that showing up, at least.)
 
Last edited:
You not installed [Visual C++ Redistributable 2015 (x86 version)]. You MUST install all previous Visual C++ Redistributables (x86 versions) [found on this page]. it the first step in the readme file.. skipping this results in it not being able to read the mysql database resulting in the issues your having.
So I went back to that list and verified all of the Visual C++ redistributables (2015 and earlier) were installed. I noticed the footnote that installing the Visual Studio 2015 Community Edition would install all of that stuff and more. I ran that, and viola, I've made at least a little progress.,
 
Okay, so after installing the Visual Studio 2015 Community Edition (After verifying all of the listed redistributables were installed) seems to have fixed the problem. I am not sure if I missed one all of the times that I tried, or of something else was missing, but my server is now up and running. :)

Thanks for the help :)
 
Top