Remove Parts From Vehicles (Simplified)

Discussion in 'Script/Addon help' started by unkinhead, Apr 12, 2013.

  1. unkinhead

    unkinhead Member

    Joined:
    Mar 7, 2013
    Messages:
    79
    Likes Received:
    18
    Hm seems like a glitch, try logging out then back in. Also. Are you using rmod for that vehicle and skin?
     
  2. Fr1nk

    Fr1nk Well-Known Member

    Joined:
    Mar 12, 2013
    Messages:
    279
    Likes Received:
    24
    It's the DayZ 2017 mod, not running rmod or anything else. Tried logging out/in, restarting server, getting in the car and shifting seats, etc. Have also tried it with a different vehicle and experienced the same issue. Was also reading through another thread: http://opendayz.net/threads/strip-vehicles-for-parts.7986/

    Seems like some folks are encountering the same problem but no common fix has been identified.
     
  3. Morox

    Morox Well-Known Member

    Joined:
    Mar 17, 2013
    Messages:
    256
    Likes Received:
    15
    Dunno if this is related, if that is the SKODA car mod the Dayz 2017 readme states

    "Skoda Cars and Datsun Civil Pickup require damage rvmats so the tyres can be shot out / destroyed."

    So it's possible the model with tire removed is not complete yet.
     
  4. Fr1nk

    Fr1nk Well-Known Member

    Joined:
    Mar 12, 2013
    Messages:
    279
    Likes Received:
    24
    Well that's interesting...gonna spawn some other vehicles this weekend and try the script again to see if anything changes. Thanks for the find :)
     
  5. Manatee Hunter

    Manatee Hunter Valued Member!

    Joined:
    Dec 24, 2012
    Messages:
    620
    Likes Received:
    90
    Is this just a cleaner write up of what exists in the other thread? If so, I assume the exploit of constantly removing a part hasn't been fixed?
     
  6. omnipsycho

    omnipsycho New Member

    Joined:
    Mar 3, 2013
    Messages:
    5
    Likes Received:
    0
    thanks a lot man. got this working very easily
     
  7. SteveMac555

    SteveMac555 New Member

    Joined:
    Apr 8, 2013
    Messages:
    17
    Likes Received:
    0
    Id also like to know if this is fixed, if so it's a +1 from me and going straight on the server :)
     
  8. Fr1nk

    Fr1nk Well-Known Member

    Joined:
    Mar 12, 2013
    Messages:
    279
    Likes Received:
    24
    Well, I tried removing different parts and the option to remove those specific parts was always removed from the menu. Is that what you're talking about?
     
  9. Morox

    Morox Well-Known Member

    Joined:
    Mar 17, 2013
    Messages:
    256
    Likes Received:
    15
    The solution Manatee/Steve to the issue you are talking about was to only allow green parts to be removed from vehicles, as such there is no way to remove a red or yellow part and re-add it as green?

    Is this is exploit you are talking about?
     
  10. Fr1nk

    Fr1nk Well-Known Member

    Joined:
    Mar 12, 2013
    Messages:
    279
    Likes Received:
    24
    Just tested this with a 2017 bus and the tire was removed correctly. Repairing also added back the tire correctly. So, it seems like the problem lies with the Datsun and Skoda vehicles.

    [​IMG]
     
  11. dedubya

    dedubya Member

    Joined:
    Mar 24, 2013
    Messages:
    53
    Likes Received:
    5
    Ok still new to this where can i find compiles.sqf from "dayz_code\init", and fn_selfAction.sqf in "dayz_code\compile"
     
  12. colddemon

    colddemon New Member

    Joined:
    Mar 6, 2013
    Messages:
    13
    Likes Received:
    0
    Go to your ArmA2OA install folder, from there into @dayz/addons and you will find the dayz_code.pbo there. Unpack that with the pbo manager and you have those files.
     
  13. dedubya

    dedubya Member

    Joined:
    Mar 24, 2013
    Messages:
    53
    Likes Received:
    5
    thanks alot
     
  14. dedubya

    dedubya Member

    Joined:
    Mar 24, 2013
    Messages:
    53
    Likes Received:
    5
    can you take a look at my mission pbo i get no error but it's not working either?
     

    Attached Files:

    SparxOne likes this.
  15. dedubya

    dedubya Member

    Joined:
    Mar 24, 2013
    Messages:
    53
    Likes Received:
    5
    getting error= Script z\addons\dayz_code\compile\player_spawnlootCheck.sqf not found, any idea how to fix this?
     
  16. SteveMac555

    SteveMac555 New Member

    Joined:
    Apr 8, 2013
    Messages:
    17
    Likes Received:
    0
    Working perfectly for me, thanks for the awesome script :)
     
  17. JMocks

    JMocks New Member

    Joined:
    Apr 7, 2013
    Messages:
    26
    Likes Received:
    2
    I get the error:

    script dayz_code\init\variables.sqf was not found

    Though, that file is in the init folder in the dayz_code.pbo file. So I don't know what the deal is. Any help with this would be appreciated.
     
  18. Althasil

    Althasil Well-Known Member

    Joined:
    Nov 7, 2012
    Messages:
    105
    Likes Received:
    5
    I'm getting the same error. Should I be taking the fn_selfactions and compiles sqfs from @Taviana/addons/dayz_code.pbo or from @dayz/addons/dayz_code.pbo ? I currently have set it up using the files from @dayz.
     
  19. SparxOne

    SparxOne Member

    Joined:
    Apr 11, 2013
    Messages:
    59
    Likes Received:
    5
    Ok it seems like i am having the same problem as "dedubya" because i have no erros on startup but i have no options ingame to remove the parts, the vehicle was full green.

    Has anyone also got that ?
    Is there a solution please ?
     
  20. zombieshack

    zombieshack Member

    Joined:
    Feb 27, 2013
    Messages:
    83
    Likes Received:
    4
    hey for some resion when i add this script to my server i cant seem to harvest wood and it also causes my server to lag kind of bad as well. any ideas ? if you need me to i will give you my files for you to take a look at.
     

Share This Page