Zombies don't attack players- Overwatch

Discussion in 'Support' started by DangerRuss, Aug 27, 2015.

  1. DangerRuss

    DangerRuss OpenDayZ Rockstar!

    Joined:
    Jul 10, 2013
    Messages:
    1,220
    Likes Received:
    67
    Using the latest server files with Overwatch and for whatever reason zombies don't attack players. They will aggro on the player, but when they get close they basically hop around near you and never attack. I've been told the military zombies do attack but not the civilians, however I can't confirm this.
    Any ideas?
     
  2. Zeehond23

    Zeehond23 Valued Member!

    Joined:
    Mar 7, 2013
    Messages:
    574
    Likes Received:
    50
    Just brainstorming here but maybe sides are screwed?
     
  3. DangerRuss

    DangerRuss OpenDayZ Rockstar!

    Joined:
    Jul 10, 2013
    Messages:
    1,220
    Likes Received:
    67
    I fixed it with using the default overwatch server pack but Im still getting this crazy error that has been plaguing me since I moved servers... players, especially after a restart, attempt to join in and receive "player already dead. please rejoin" and are put back in lobby.
     
  4. DangerRuss

    DangerRuss OpenDayZ Rockstar!

    Joined:
    Jul 10, 2013
    Messages:
    1,220
    Likes Received:
    67
    Ok soooo I moved off the of the old overwatch schema because it ran like crap and I was still having the same issues with the weird player died bug.

    So now that Im back on pwnzors private pack the zombies are once against useless.
    You mentioned something about sides but where do I even check for that?
     
  5. ShootingBlanks

    ShootingBlanks OpenDayZ Guru!

    Joined:
    Mar 31, 2013
    Messages:
    2,414
    Likes Received:
    336
    search the files for spawning zombies .. createagent is the code. But if you never changed those files the zombies themselves are not going to be on wrong side, maybe the players are.
    Put this code into the bottom of your init.sqf

    if (!isserver) then
    {
    [] spawn {
    while {true} do {
    hintsilent format["You are on side %1", side player];
    sleep 5;
    };
    };
    };

    that should update your hint box every 5 seconds with the players side which should always be WEST unless he is a bandit in which case it should be ENEMY. You will be able to see if and when the players side changes.

    As for the spawning dead .. yup, seen that before too .. will take a bit until I remember what the issue is. Are they maybe getting killed by infistar or the overwatch anti-hack because of ESS ? Some type of teleport restriction ..

    What does the log say when they spawn in? Dont see anything in the server log, check the client log.
     
  6. DangerRuss

    DangerRuss OpenDayZ Rockstar!

    Joined:
    Jul 10, 2013
    Messages:
    1,220
    Likes Received:
    67
    I'll take a look. It's definitely something strange because sometimes the zombies attack, sometimes they don't.

    Im not seeing anything in the log client or RPT when it happens. I'll have to wait until it happens again to find out.
     
    Last edited: Sep 21, 2015
  7. ElDubya

    ElDubya Well-Known Member

    Joined:
    Nov 1, 2014
    Messages:
    125
    Likes Received:
    6
    Did you get this sorted Russ?
     
  8. DangerRuss

    DangerRuss OpenDayZ Rockstar!

    Joined:
    Jul 10, 2013
    Messages:
    1,220
    Likes Received:
    67
    Nope. I have no idea why they don't do it. It might be specific skins I have players spawning in, but I know when I used a different database schema I never had the problem. I just kinda gave up. My server is basically the furthest thing from dayz you can get, without being a different game, anyway.
     

Share This Page