lite pack 1.7.6 vehicles not fixing and refuel not working

I believe I have a similar issue with chernarus 1.7.6, it has taken 6 wheels to fix two tires on a car, applied engine and fuel parts and it says applied successful but still shows needing repairs (red)
 
No, no custom scripts... just a vanilla install as per the github install guide... myself and the people testing my server have managed to repair vehicles by attempting to repair, then if it fails, log out, log back in, try again... this basically means repairing 1 wheel on a car can sometimes take 2-3 wheels to get one to actually go on.
 
Yeah the DB is on the same machine, all local... I've tested this on two different servers... both of them have the same issue with vehicle repairs...

one of the servers is a dual xeon dell blade... 16 cores @ 2.4GHZ with 32GB of ram...

The other is an i5 3.5GHZ quad core with 8GB of ram...

Neither of them are coming anywhere near to maxing out their resources... so if it were DB lag... I wonder what could be causing it.
 

DSH-Nibbler

Well-Known Member
Also buddy i have 5 servers running on 1 machine 2.4Ghz and 8gbram Dayz isnot recourse intensive a tip for database side stuff tho

If you have it on the same machine always ALWAYS try and use "localhost" or 172.0.0.1 over your actual ip address saves a whole loop-back and prevents most lagg if you are running ur database on a networked machine stick with ur local network addresses rather then ur WAN ip addy if u have any other issues feel free to ask i learnt the hard way with little to no help trial and error
 
I may have spoken too soon... some vehicles still eat materials and produce no repair and some vehicles are refusing to fuel up... digging through logs and nothing looks out of the ordinary... and the DB really is running fine as far as I can see... head scratching commence... I notice there's a thread over in the reality dayz pack forums of people complaining of similar issues... wondering if this is something that has happened as a result of a DayZ update.
 

DSH-Nibbler

Well-Known Member
i had the same issue on on of my servers about a week ago hear is the weird bit tho the servers are all on the same machine and all report to one sql server on the same machine the only thing i have changed since then is my Missions pbo files and i went through the database getting rid of erroneous entities one thing i have found when i spawn in vehicles with pMain it sometimes does not write the inv code and sets it to null when it needs to be [] remember though you are running a very badly optimized mod so even the slightest typo in any code can mess with stuff another thing i checked when i had DB lag was all the admin tools which read from the database sometimes they can be looking for Fields and whole tables that dont exist also if u have remote access to ur database u can guarantee there will be spam bots on the web sending query after query it may be worth setting up an IP filter specifically for ur databases i had to do that myself some Muppet actually tried to DDos the database itself lol causing lad to cheat in-game. OH! and that lol could be a hacker! check incoming bandwidth usage of players
sorry about the block text ill stick in some bullet points nextime lol
 
All good, I appreciate your help...

We can rule out hackers as the DB isn't open to the web, localhost only, and the server isn't public yet, I just have a few close friends testing, so we can rule out hackers/script kids too...

Other than this repair/refuel thing, the server is running great. >_<

I'll look at the DB entries today and if anything is missing.
 

DSH-Nibbler

Well-Known Member
i had another spate of database lag earlier with the helis on my servers very annoying till i figured out one of my admins had been setting up an event and not filled in the Null fields causing the console to loop read im gone till after weekend now if u havent fixed it let me know and il help u out with it
 
How is this a database issue? I was under the impression that it would only be a database issue if the vehicles would revert back to their old state after a server restart. If you can't repair a vehicle during a session, it's most likely a issue with the dayz code itself right?
 
I'm beginning to think it's the DayZ code too... my DB is running fine, I've been monitoring it while playing even, the DB is running sweet... no issues.

But still the repair and refuel issue remains... it's sporadic though, sometimes it's fine for ages, then randomly you go to refuel or repair and boom, it eats the part and doesn't repair.
 

DSH-Nibbler

Well-Known Member
super he originally described Db lag which has the same symptoms and anyway back to Mockesky i had this again yesterday i was trying to fix an atv with bits from another i could remove a infinite amount of wheels and not aplly them to the new atv lol i was looking ad the Instance data for the vehicles the order they are read from the database it seems if you have a vehicle at the top ie number 1 this one is always fine but when ur server has alot and ur say at item number 1000 on the list it sometimes messes up the custom scripts i have only had this issue with the Scavenge& repair script what refuel code are u using? and im looking into submitting a pull for a fix on the code to force update vehciles
 
Top