Taviana server help

Audio Rejectz

Well-Known Member
Hi, we finally thought we made progress with this server. As we are putting up a taviana.eu server, to go with the .com one we have hosted. But after getting it all installed we have hit a wall

At present, where stuck on loading. Error logs are showing this (Click link for pastebin)

http://pastebin.com/75vksg9z

We have ran
Code:
perl db_utility.pl setworld tavi
and we get
D:\myfiles\+++++\DayZ-Private-master>perl db_utility.pl setworld tavi --pass
+++++
INFO: Connecting to localhost:dayz as user dayz
INFO: Set world to tavi for instance 1

Still no luck though

Can anyone help please
 

Audio Rejectz

Well-Known Member
The guy who is trying to install it now thinks it is something wrong with the database, as he tried it with cherno and he gets the same error message Error fetching created character for playerId

any ideas?
 

beers

New Member
I think its a bad idea to try to run both versions off the same install, you're likely to run into all sorts of issues if you do...are you running p-schneider's fork? besides that...have you run multiple instances before? Are you using the same database for both?

Based on what you've posted and the fact it doesn't work on Chernarus either...I would ask, did you specify the world instances correctly when you ran build.pl and db_utility.pl?

If you are running off the same install you will need to specify perl build.pl --world tavi --instance 1 and perl build.pl --world eu.tavi --instance 2 if those are the only instances you are running, and then run db_utility setworld <world> --instance <instance> for each instance.
 

Audio Rejectz

Well-Known Member
It's not on the same install, the .com server is hosted by a company and this on is on our very own box that gameing delux provides us bandwidth for.

our exact build and utility settings we use when building our

perl build.pl --world eu.tavi --instance 10 --with-carepkgs --with-killmsgs --with-messaging --with-buildings --with-wrecks --with-invcust

perl db_migrate.pl --pass
perl db_migrate.pl --pass --schema BlissMessaging --version 0.01
perl db_migrate.pl --pass --schema BlissBuildings --version 0.01
perl db_migrate.pl pass --schema BlissInvCust --version 0.02

perl db_utility.pl --instance 10 --pass

And we have tried

perl db_utility.pl setworld tavi
 

beers

New Member
ok well I'm basing that off your build.pl command...make sure the world names match...I don't know which version of Bliss you are using...the only one that I know that works with the EU tavi is p-schneider's.

also your initial post shows the world being set to instance one by default so I'm inclined to believe that in the course of the install and switching worlds etc. you've created character data that no longer matches your defined world instances at the very least. If no one at all can connect to the server than the problem is a bit deeper than just the records.

I'm not going to claim to be an expert here but the errors you are getting are similar to the ones I got when I messed up on my instances.

There is a difference between world numbers and instance numbers as well which may add to the confusion here...I know it did for me when I first installed.
 

Audio Rejectz

Well-Known Member
Yeah man, just tried again and the same. When you look in the hiveExt log you see this

HiveExt: [Error] Error fetching created character for playerId
 

zedar

Moderator
Staff member
can you resume your setup:

1. url to the repo used
2. database name
3. clean your log, client and server rpt and hive log, start the server and then upload the logs
 

Audio Rejectz

Well-Known Member
I have added the rpt in the zip, i have just been going through it and noticed a lot of weird things. Seems to be a lot of things missing and what is weird is, it is giving Faz a totaly different player id from what he's actually is.

Server error: Player without identity =|[UX*Faz]|= (id 532967573)
11:18:21 Server error: Player without identity =|[UX*Faz]|= (id 532967573)
11:18:21 Server error: Player without identity =|[UX*Faz]|= (id 532967573)
11:18:21 Server error: Player without identity =|[UX*Faz]|= (id 532967573)
11:18:21 Server error: Player without identity =|[UX*Faz]|= (id 532967573)
11:18:21 Server error: Player without identity =|[UX*Faz]|= (id 532967573)

In regards to the missing, if you search for missing in the file you will see what i mean
 

zedar

Moderator
Staff member
seems you have a problem with players tables and loadout, maybe you change the initial load out?

or, maybe exists data inconsistency, how do you build the files? post both db_migrate.pl and build.pl lines exact as you used to create the server

i suspect the issue can came from:
1. hivesetup problem
2. grong loadout
3. instance number grong
 

zedar

Moderator
Staff member
I have added the rpt in the zip, i have just been going through it and noticed a lot of weird things. Seems to be a lot of things missing and what is weird is, it is giving Faz a totaly different player id from what he's actually is.

Server error: Player without identity =|[UX*Faz]|= (id 532967573)
11:18:21 Server error: Player without identity =|[UX*Faz]|= (id 532967573)
11:18:21 Server error: Player without identity =|[UX*Faz]|= (id 532967573)
11:18:21 Server error: Player without identity =|[UX*Faz]|= (id 532967573)
11:18:21 Server error: Player without identity =|[UX*Faz]|= (id 532967573)
11:18:21 Server error: Player without identity =|[UX*Faz]|= (id 532967573)

In regards to the missing, if you search for missing in the file you will see what i mean
that's normal
 

Audio Rejectz

Well-Known Member
perl build.pl --world eu.tavi --instance 10 --with-carepkgs --with-killmsgs --with-messaging --with-buildings --with-wrecks --with-invcust

perl db_migrate.pl --host localhost --user root --pass
perl db_migrate.pl --host localhost --user root --pass --schema BlissMessaging --version 0.01
perl db_migrate.pl --host localhost --user root --pass --schema BlissBuildings --version 0.01
perl db_migrate.pl --host localhost --user root --pass --schema BlissInvCust --version 0.02

perl db_utility.pl setworld tavi ( it states use tavi here https://github.com/p-schneider/DayZ-Private/wiki/Things-you-should-know-when-running-Taviana )
 

zedar

Moderator
Staff member
let's try build without the extras messag, build, and invcust, so drop the databse, create it again with utf8 encoding to avoid shit and build only with

a) perl db_migrate.pl --host localhost --user root --pass
b) perl build.pl --world eu.tavi --instance 1
 
Top