100% Custom Loot tables - v1.7.7

Well i cant confirm it works... as i get stuck on auth when i use this script. but... in the 1.7.7.1 files the changes are

open variables.sqf

Here is the Crash Site area... for 1.7.7.1
Find:
Code:
if(isServer) then {
    dayz_players = [];
    dead_bodyCleanup = [];
    needUpdate_objects = [];
    Server_InfectedCamps = [];
};
and replace it with:
Code:
if(isServer) then {
dayz_players = [];
dead_bodyCleanup = [];
needUpdate_objects = [];
Server_InfectedCamps = [];
dayz_spawnCrashSite_clutterCutter=0; // helicrash spawn... 0: loot hidden in grass, 1: loot lifted, 2: no grass
};
I deleted the other changes because there are too many. The script need to be redone for 1.7.7.1

So many differences between these and the update.
 
Those changes unfortuanatly did not fix my problem still no loot on my heli crashes. I've been reading everything and I can't figure out what it is. I got no errors in my RPT file. They crash with the right LootTable according to the RPT file but there is just no loot.
 
Yeah it looks like you have all of the 1.7.7 and not the 1.7.7.1 i dont think it will work until all the files are changed. there are rewrites to some of the code and new code that is not in your files.
 
I know this is noob a noob question...

But for LootSpawn Delay, what does that mean these values?

dayz_spawnDelay = 300;
dayz_spawnWait = -300;

And how do I improve loot spawn ratios? I mean more chance to find loot?
 

Johnkok

Well-Known Member
I don't understand. I have modified CfgBuildingLoot.hpp and CfgLoot.hpp and nothing changes. As a test I removed all loot from the Hospital except for an M16. When I restart the server and go to the Hospital there is plenty of Epi pens, trash and shit but no M16. Removed all reference to cards and nails. Bloody cards and nails all over the place!

I originally modified the PBO files. When that wasn't working I followed the guide here. My description file and init file are definitely pointing to the right place but still no change in the type of loot.

Is there something I am missing here? Is there a main file that overrides all the loot? I am pulling my hair out with this 1.7.7.1 update, it is the bane of my existence at the moment. :(
 
I don't understand. I have modified CfgBuildingLoot.hpp and CfgLoot.hpp and nothing changes. As a test I removed all loot from the Hospital except for an M16. When I restart the server and go to the Hospital there is plenty of Epi pens, trash and shit but no M16. Removed all reference to cards and nails. Bloody cards and nails all over the place!

I originally modified the PBO files. When that wasn't working I followed the guide here. My description file and init file are definitely pointing to the right place but still no change in the type of loot.

Is there something I am missing here? Is there a main file that overrides all the loot? I am pulling my hair out with this 1.7.7.1 update, it is the bane of my existence at the moment. :(
Did you clothed the new .sqf files from the 1.7.7.1 dayz_code.pbo folder, and replaced the old ones?
 

Johnkok

Well-Known Member
Did you clothed the new .sqf files from the 1.7.7.1 dayz_code.pbo folder, and replaced the old ones?
I have a completely new, fresh install of 1.7.7.1. I extracted the files from the PBO, changed them, repacked them then uploaded the PBO to the server.
 
I have a completely new, fresh install of 1.7.7.1. I extracted the files from the PBO, changed them, repacked them then uploaded the PBO to the server.
I manage it to work, sorry about my bad english I'll tray to explain what I did to make it work.
First I used all the files from custom folder "But I replaced them with the new 1.7.7.1 files" and that didn't work.
What I did was to only use the variables.sqf and compiles.sqf from the original new 1.7.7.1 files, and edited both with the critical lines from the old "custom\compiles and variables.sqf files"
The rest of files, I just used the old ones from the "custom folder from this thread" and its working because in my server the hospital loot was crap... for real... now I set 0.9 for medbox and there are almost always medbox from now on as well as industrial loot impreved a lot.
 

Johnkok

Well-Known Member
I manage it to work, sorry about my bad english I'll tray to explain what I did to make it work.
First I used all the files from custom folder "But I replaced them with the new 1.7.7.1 files" and that didn't work.
What I did was to only use the variables.sqf and compiles.sqf from the original new 1.7.7.1 files, and edited both with the critical lines from the old "custom\compiles and variables.sqf files"
The rest of files, I just used the old ones from the "custom folder from this thread" and its working because in my server the hospital loot was crap... for real... now I set 0.9 for medbox and there are almost always medbox from now on as well as industrial loot impreved a lot.
I will give it a shot tomorrow and see if it works. Thanks for the info Kano
 
The problem with that is your missing a bunch of 1.7.7.1 changes in all the files from this custom folder. They are all 1.7.7 so in a way you are running a mix of 1.7.7 and 1.7.7.1 on your server.

They have rewritten and added code that are not in the 1.7.7 so some of the updates that were made pertaining those files are no longer on your server.
 
The problem with that is your missing a bunch of 1.7.7.1 changes in all the files from this custom folder. They are all 1.7.7 so in a way you are running a mix of 1.7.7 and 1.7.7.1 on your server.

They have rewritten and added code that are not in the 1.7.7 so some of the updates that were made pertaining those files are no longer on your server.
So what should I do then? I believe if I use the 1.7.7.1 files this won't work...
I'm noob enough to not be able to cloth the rest of .sqf files in custom folder... I know I'm going to miss something...
Do you haave the 1.7.7.1 .sqf files already clothed for this to work? I will love if you if you do and if you would share them with me =(
 
I managed it to work. All I had to do was to cloth the lines pointing the custom folder in the 1.7.7.1 compiles.sqf and edit EVERY 1.7.7.1 .sqf file and replace all the lines "ConfigFile" by "missionConfigFile".

EDIT: NVM It works the loot works but I think it will cause your server to roll back after every restart... arghhhghh
 
Top