[How-To] Customize the Starting Gear/Loadout (no custom dayz_code req.)

DangerRuss

OpenDayZ Rockstar!
Shinkicker:
Sorry was this a response to me or the person above me? Id like to add that the vilayer custom loadout tool with the drop down still functions correctly... i am just limited in choices. Im trying to find where this writes to so that i can tweak it more to my liking.
 

DangerRuss

OpenDayZ Rockstar!
Im not sure if anyone is paying attention to this thread, but I have since found out that my server provider was indeed wrong. When they said "instance_deployable" table, they meant the instance table. I have since changed the custom starting gear on my server, and it is functionally correctly. Here is a copy.
Code:
[["M16A2","M9SD","Binocular","NVGoggles","ItemCompass","ItemGPS","ItemHatchet","ItemKnife","ItemMatchbox","ItemFlashlight"],["ItemMorphine","ItemAntibiotic","ItemWaterBottle","FoodCanBakedBeans","30Rnd_556x45_Stanag","30Rnd_556x45_Stanag","30Rnd_556x45_Stanag","15Rnd_9x19_M9SD","15Rnd_9x19_M9SD","15Rnd_9x19_M9SD","ItemBandage","ItemBandage","ItemBandage"]]
the back pack is in a separate column and looks like
["DZ_ALICE_Pack_EP1",[[],[]],[[],[]]]

the ID is 8178... that's where Im a bit lost, where did they get this number from and how does it group everyone under one ID?
 
Thanks works for me editing @hive/dayz_server.pbo (Unpack it with pbo manager)
Then go to dayz_server/compile/server_playerLogin.sqf

and replace //variables inside server_playerlogin.sqf with:

Code:
//Variables
_inventory =[["DMR","Binocular","ItemGPS","ItemToolbox","ItemWatch"],["20Rnd_762x51_DMR","ItemBandage"]];
_backpack = ["DZ_Backpack_EP1",[[],[]],[["FoodCanSardines","ItemPainkiller","20Rnd_762x51_DMR","20Rnd_762x51_DMR","ItemSodaCoke"],[1,1,1]]];
_items =        [];
_magazines = [];
_weapons = [];
_medicalStats =    [];
_survival =        [0,0,0];
_tent =            [];
_state =        [];
_direction =    0;
_model =        "";
_newUnit =        objNull;
_botActive = false;
save changes.
Right click on the dayz_server folder and pack that up.

thanks to the help on this forum for getting me there.
 
Hi everyone! Just tested this method and on server running on my localhost it's working good, but when i upload pbo to server - after dying player can not login - stuck at loading screen. then it's necessary to close game and next login attempt results in totally empty loadout. Any ideas?
 
hello guys if i want to add a m9 and some mags to start players what wold my code line in the file look like cant seem to find m9 itemid and mag item id wold be glade if anyone can help me with thad
regards buliwyf
 
Hey guys,
Having a little issue with editing ANYTHING in the "dayz_server" file. For some unknown reason, even if I just unpack and repack the pbo file, when I try and log in, my game will get stuck on, "Wating for server to start authentication". I have absolutely no idea why this is happening but it happens regardless of whether or not the files were edited correctly or not and even if I remove the edits and return the file to normal. Any help would be very much appreciated. Due to this, "bug", I can't add any custom loadout even though I have looked at all the examples people have posted and fixed, my server just will not allow the game to work.
Any help would be appreciated,
Thanks.
 
Hey guys,
Having a little issue with editing ANYTHING in the "dayz_server" file. For some unknown reason, even if I just unpack and repack the pbo file, when I try and log in, my game will get stuck on, "Wating for server to start authentication". I have absolutely no idea why this is happening but it happens regardless of whether or not the files were edited correctly or not and even if I remove the edits and return the file to normal. Any help would be very much appreciated. Due to this, "bug", I can't add any custom loadout even though I have looked at all the examples people have posted and fixed, my server just will not allow the game to work.
Any help would be appreciated,
Thanks.
i had same problem your code sculd look like thes [["M9"],["15Rnd_9x19_M9","15Rnd_9x19_M9","15Rnd_9x19_M9"]];
when i put ; in it workede
 
i had same problem your code sculd look like thes [["M9"],["15Rnd_9x19_M9","15Rnd_9x19_M9","15Rnd_9x19_M9"]];
when i put ; in it workede
My code looks like this,

//Variables
_inventory = [["ItemFlashlight","ItemHatchet","ItemKnife","ItemCompass","ItemToolbox","ItemMatchbox","ItemMap"],["FoodCanBakedBeans","ItemSodaPepsi","ItemBandage","ItemPainkiller"]];
_backpack = ["DZ_Patrol_Pack_EP1",[[],[]],[["FoodCanPasta","ItemAntibiotic","ItemSodaCoke"],[1,1,1]]];
_items = [];
_magazines = [];
_weapons = [];
_medicalStats = [];
_survival = [0,0,0];
_tent = [];
_state = [];
_direction = 0;
_model = "";
_newUnit = objNull;
_botActive = false;
According to examples in this thread, the code is correct 0_O
Any help would be appreciated!
 
My code looks like this,



According to examples in this thread, the code is correct 0_O
Any help would be appreciated!
thes one _inventory = [["ItemFlashlight","ItemHatchet","ItemKnife","ItemCompass","ItemToolbox","ItemMatchbox","ItemMap"],
sculd look like thes _inventory = [["ItemFlashlight","ItemHatchet","ItemKnife","ItemCompass","ItemToolbox","ItemMatchbox","ItemMap"]];
 
thes one _inventory = [["ItemFlashlight","ItemHatchet","ItemKnife","ItemCompass","ItemToolbox","ItemMatchbox","ItemMap"],
sculd look like thes _inventory = [["ItemFlashlight","ItemHatchet","ItemKnife","ItemCompass","ItemToolbox","ItemMatchbox","ItemMap"]];
The code that I quoted is on two lines because it was too long to quote on one line. It did have a second square bracket closing the code. After, "ItemMap" came this, ' ,["FoodCanBakedBeans","ItemSodaPepsi","ItemBandage","ItemPainkiller"]]; '. Have a look at the code I quoted again, it is easier to understand than my explanation.
 
_inventory = [["ItemFlashlight","ItemHatchet","ItemKnife","ItemCompass","ItemToolbox","ItemMatchbox","ItemMap","FoodCanBakedBeans","ItemSodaPepsi","ItemBandage","ItemPainkiller"]];
like thes then
 
I tried that, in fact that is what the code looks like. Nothing I do seems to work and it is getting quite frustrating. Apparently it is caused through improper modifications made in the "dayz_server" however, even code that works for others, does not work on my server and I have absolutely no idea why :/
 

DangerRuss

OpenDayZ Rockstar!
I tried that, in fact that is what the code looks like. Nothing I do seems to work and it is getting quite frustrating. Apparently it is caused through improper modifications made in the "dayz_server" however, even code that works for others, does not work on my server and I have absolutely no idea why :/
not sure if you figured this out or not but it sounds to me like your PBO tool is deleting your prefix when your dayz_server.pbo. You can probably verify this by looking in your RPT and seeing if you get any errors related to any of the files found within the server PBO. Follow the steps in the link Ive provided and profit.
http://opendayz.net/threads/dayz_server-pbo.18325/#post-92080
 

McKeighan

Well-Known Member
You're mixing "weapons" and "magazines" in your inventory call.

You may have to seperate those. Most, if not all tools, are "weapons" according to the code. They need to be added to your _weapons = []; area.
the rest of your gear, the bandages and what not, should be in _magazines = [];

the _inventory is SUPPOSED to split them up into the correct groups, but I'm not 100% that it works right all the time.
 

DangerRuss

OpenDayZ Rockstar!
My server starting loadout.
server_playerLogin.sqf
Code:
//Variables
_inventory =    [["NVGoggles","ItemCompass","ItemGPS","ItemToolbox","ItemKnife","ItemMatchbox","ItemFlashlight","ItemWatch","ItemHatchet","Colt1911","Binocular","LeeEnfield"],["FishCookedTuna","ItemSodaRabbit","ItemAntibiotic","ItemMorphine","ItemPainkiller","10x_303","10x_303","10x_303","ItemAntibacterialWipe","ItemBandage","ItemBandage","7Rnd_45ACP_1911","7Rnd_45ACP_1911","7Rnd_45ACP_1911"],"MeleeBaseBallBatNails"];
_backpack =     ["DZ_TK_Assault_Pack_EP1",[[],[]],[[],[]]];
Copy + Paste = Profit
 

Chris Atkins

Valued Member!
My server starting loadout.
server_playerLogin.sqf
Code:
//Variables
_inventory =    [["NVGoggles","ItemCompass","ItemGPS","ItemToolbox","ItemKnife","ItemMatchbox","ItemFlashlight","ItemWatch","ItemHatchet","Colt1911","Binocular","LeeEnfield"],["FishCookedTuna","ItemSodaRabbit","ItemAntibiotic","ItemMorphine","ItemPainkiller","10x_303","10x_303","10x_303","ItemAntibacterialWipe","ItemBandage","ItemBandage","7Rnd_45ACP_1911","7Rnd_45ACP_1911","7Rnd_45ACP_1911"],"MeleeBaseBallBatNails"];
_backpack =     ["DZ_TK_Assault_Pack_EP1",[[],[]],[[],[]]];
Copy + Paste = Profit
Damn boooiiii....starting with NVGs!?!?!?!?!
 
Top