OW 025 Time changing issue

Well guys i don't know if u have the same problem but...
I run server OW 025.. and i have problem each 10 min it changes date and time... i found part where it sets to full night... commented this out.. didn't help... what can be the problem ?
 
I seem to be having the same problem every 10minutes time change.
Running always day atm but like to have a night cycle and help would be gr8 thanx.
 
hello again ive been loking at the server_cleanup.fsm ive compaired 0.2.4 to 0.2.5 and have spotted a difference in some lines can this be the problem? Ill add both lines from both files bellow starting with 0.2.4.

0.2.4

Code:
item7[] = {"time_sync",4,218,-200.000000,-50.000000,-100.000000,0.000000,0.000000,"time" \n "sync"};
item8[] = {"sync_the_time",2,250,-275.000000,50.000000,-175.000000,100.000000,0.000000,"sync" \n "the time"};
0.2.5

Code:
item7[] = {"time_sync",4,218,-225.000000,0.000000,-125.000000,50.000000,1.000000,"time" \n "sync"};
item8[] = {"sync_the_time",2,250,-225.000000,175.000000,-125.000000,225.000000,0.000000,"sync" \n "the time"};
i want to just change the lines but im affrair i mess it up and do some damage unrepairable
 

Player2

Valued Member!
hello again ive been loking at the server_cleanup.fsm ive compaired 0.2.4 to 0.2.5 and have spotted a difference in some lines can this be the problem? Ill add both lines from both files bellow starting with 0.2.4.

0.2.4

Code:
item7[] = {"time_sync",4,218,-200.000000,-50.000000,-100.000000,0.000000,0.000000,"time" \n "sync"};
item8[] = {"sync_the_time",2,250,-275.000000,50.000000,-175.000000,100.000000,0.000000,"sync" \n "the time"};
0.2.5

Code:
item7[] = {"time_sync",4,218,-225.000000,0.000000,-125.000000,50.000000,1.000000,"time" \n "sync"};
item8[] = {"sync_the_time",2,250,-225.000000,175.000000,-125.000000,225.000000,0.000000,"sync" \n "the time"};
i want to just change the lines but im affrair i mess it up and do some damage unrepairable
You shouldn't be using the server_cleanup.fsm, they left it running in OW as a mistake. You should only be using ow_cleanup. So unfortunately your fairly accurate research isn't the right answer this time.
 
Thanx for the reply Player2 i cant seem to find the ow_cleanup.sqf can you point me in the right direction plz. And if you know a fix for the time change can you plz let me know it thanx in advance and thanx for the epic scripts you have shared and the rest of your team .
 

Chris Atkins

Valued Member!
Thanx for the reply Player2 i cant seem to find the ow_cleanup.sqf can you point me in the right direction plz. And if you know a fix for the time change can you plz let me know it thanx in advance and thanx for the epic scripts you have shared and the rest of your team .
Open your server PBO. navigate to: dayz_server\system, then open server_monitor.sqf. Scroll to line 318. You'll need to comment out lines 318, 319, and 320....

if (isDedicated) then {
_id = [] execFSM "\z\addons\dayz_server\system\server_cleanup.fsm";
};
Like so....

//if (isDedicated) then {
//_id = [] execFSM "\z\addons\dayz_server\system\server_cleanup.fsm";
//};
In theory, this should solve the problem.

Don't forget to repack your PBO and upload to server.
 
Open your server PBO. navigate to: dayz_server\system, then open server_monitor.sqf. Scroll to line 318. You'll need to comment out lines 318, 319, and 320....



Like so....



In theory, this should solve the problem.

Don't forget to repack your PBO and upload to server.
seems to have worked thanx alot m8 ill update once ive run it a few days thanx again ;)
 

Halvhjearne

Valued Member!
Open your server PBO. navigate to: dayz_server\system, then open server_monitor.sqf. Scroll to line 318. You'll need to comment out lines 318, 319, and 320....

you will have two cleanup scripts running this way, you should comment out the owcleanup script then

what i did was i just set date in server_monitor.sqf and same in hiveext.ini ... i still got sometimes when i alt tab or when i just logged in it might look like its switching, but other than that it seems fine this way
 
Another bug that i've noticed....when players die, they can't log back in. They have to completely quit the game, then reload DayZ. It's quite a pain.
 
you will have two cleanup scripts running this way, you should comment out the owcleanup script then

what i did was i just set date in server_monitor.sqf and same in hiveext.ini ... i still got sometimes when i alt tab or when i just logged in it might look like its switching, but other than that it seems fine this way
What two cleanup files? If sever_cleanup isn't running....then beside owcleanup, what is the second cleanup file?
 
Another thought is that since I am unhappy with the current owcleanup and the server_cleanup (even though it's disabled) i could replace both with the ones from 2.4 (I actually used both together in 2.4 with ZERO problems). Although I'm not sure what, if any, the consequences would be. Guess I'll test it this weekend.

Or if someone else has already tested, let me know your results.
 
Another thought is that since I am unhappy with the current owcleanup and the server_cleanup (even though it's disabled) i could replace both with the ones from 2.4 (I actually used both together in 2.4 with ZERO problems). Although I'm not sure what, if any, the consequences would be. Guess I'll test it this weekend.

Or if someone else has already tested, let me know your results.
hey chris ive made no other changes other than comment out what you said and when we die we can log back in no problem . Everything seems to be working with your advice :) giving blood is a little buggy but i can live with it . thanx again
 
@mr mischief -- good to know. I've was confident that would solve the issue due to some hints that I picked up on in a couple other older threads from 2.3 and 2.4 Overwatch. Player2 happened to beat me to the punch when she mentioned server_cleanup shouldn't be used.
 
Ive got a problem somewhat like this just mine doesn't have the time change ingame but if you log out and back in your time gets reset to whatever the servers start time was. Anyone know a fix?
 
Ive got a problem somewhat like this just mine doesn't have the time change ingame but if you log out and back in your time gets reset to whatever the servers start time was. Anyone know a fix?
Im currently testing the server_cleanup.fsm and owcleanup from my 2.4 packages. These I am using together, as I did for 2.4 an never had any problems. I'll update this thread once I have some clear results on the stability.
 
Im currently testing the server_cleanup.fsm and owcleanup from my 2.4 packages. These I am using together, as I did for 2.4 an never had any problems. I'll update this thread once I have some clear results on the stability.
I figured itout it wasn't a problem at all o_O it was just the time sync in server_cleanup.fsm it takes a little while to sync the time so after about 5 minutes your time gets set to your the server time. Weird.
 
I figured itout it wasn't a problem at all o_O it was just the time sync in server_cleanup.fsm it takes a little while to sync the time so after about 5 minutes your time gets set to your the server time. Weird.
Even so, the 2.5 update wasn't properly tested before release. It is buggy. I'm going to do a personal 2.5 fix this weekend with both server and mission PBOs. I've had reports of self bloodbag not working, auto refuel not working, DMR has a slower rate of fire compared to 2.4...and other small things. So this weekend I will be creating a raw 2.5 update that ensures all the normal Overwatch stuff works right.
 
Even so, the 2.5 update wasn't properly tested before release. It is buggy. I'm going to do a personal 2.5 fix this weekend with both server and mission PBOs. I've had reports of self bloodbag not working, auto refuel not working, DMR has a slower rate of fire compared to 2.4...and other small things. So this weekend I will be creating a raw 2.5 update that ensures all the normal Overwatch stuff works right.
ive also noticed there is no sting ,gause ,duct tape or the other crafting items spawning on my server ive added them to the dzai inventory list so i can get them but if there is some way you can add this while you are in there it would be great m8 . thanx again
 
Top