Reality and 1.7.5.1

thevisad

Moderator
Staff member
Reality supports 1.7.5.1; however, not all maps have been updated to the latest code. Attempting to run anything other then Chernarus or Utes will most likely fail. Failing to follow this guide and you will most likely end up with a server that is non functional.

  1. Download the latest DayZ files from here. You only need the @Server-1.7.5.1-Full.rar file.
  2. Get the latest Reality build from GitHub here.
  3. Extract all files from @Server-1.7.5.1-Full.rar into temporary folder.
  4. Copy the @Dayz to your servers root directory.
  5. Copy the Keys to your server root directory.
  6. Do not copy anything else, you do not need the hive files or the database files.
  7. Follow the steps on the github to build the latest version of Reality
  8. Build the latest version of Reality and copy all of the files from the deploy folder into your servers root directory.
 

Xyberviri

Valued Member!
yes, the code was changed to have helis spawn as the server is up and running. this change was made by the day z community dev team and is not specific to reality
 

wriley

Member
They no longer spawn at the start of the mission but randomly over time. You should see a message in the logs when a heli crash is spawned. I've seen them but haven't yet gone to the locations to verify they were actually in game.
 

Wannab007

Member
when migrating from bliss to reality it says to do this:

db_migrate.pl --host 192.168.12.175 --user redbone --pass hound --name chernarus --port 3306 --schema RealityMigrate --version 0.01

and this is what i get:

Can't locate DBIx/Migration/Directories.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.10.1 /usr/local/share/perl/5.10.1 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl .) at db_migrate.pl line 7.
BEGIN failed--compilation aborted at db_migrate.pl line 7.
 

thevisad

Moderator
Staff member
Also, make sure you change that to your information (server ip, username and password) those are listed as an example only.
 

Wannab007

Member
yeh i know it was an example i wasnt about to put my info up there,

it was that i didnt run setup_perl.sh, i thought i had before i uploaded all my server files a few days ago, guess i forgot to
 

-Daemon-

New Member
They no longer spawn at the start of the mission but randomly over time. You should see a message in the logs when a heli crash is spawned. I've seen them but haven't yet gone to the locations to verify they were actually in game.

According to the DayZMod.com forums, many people from different hosts are not having heli crashes spawn at all.
 

wriley

Member
According to the DayZMod.com forums, many people from different hosts are not having heli crashes spawn at all.

I see them spawning in my RPT and will try to confirm them in game later tonight.

Code:
 6:01:58 "CRASHSPAWNER: Starting spawn logic for Crash Spawner"
 6:01:58 "CRASHSPAWNER: 75% chance to spawn 'UH-60 Wreck' with loot table 'Military' at 3885"
 7:07:17 "CRASHSPAWNER: 75% chance to spawn 'Crashed UH-1Y' with loot table 'HeliCrash' at 7461.07"
 8:07:06 "CRASHSPAWNER: Spawning 'Crashed UH-1Y' with loot table 'HeliCrash' NOW! (7464.57) at: [7279.54,7596.53]"
 8:07:06 "CRASHSPAWNER: Loot spawn at 'Crashed UH-1Y' with loot table 'HeliCrash'"
 8:07:06 "CRASHSPAWNER: Loot spawn at 'Crashed UH-1Y' with loot table 'HeliCrash'"
 8:07:06 "CRASHSPAWNER: Loot spawn at 'Crashed UH-1Y' with loot table 'HeliCrash'"
 8:07:06 "CRASHSPAWNER: Loot spawn at 'Crashed UH-1Y' with loot table 'HeliCrash'"
 8:07:06 "CRASHSPAWNER: Loot spawn at 'Crashed UH-1Y' with loot table 'HeliCrash'"
 8:07:06 "CRASHSPAWNER: 75% chance to spawn 'UH-60 Wreck' with loot table 'HeliCrash' at 11328.6"
 

-Daemon-

New Member
What host do you run with, wriley? Or do you host your own?

Our guy Ersan (DayZ.ST) said it was an error in the buildings table. I'll post here with what he fixes and/or changes.
 

Falcon911

Well-Known Member
OK ran above and ran build.pl with no updates.(Wrecks etc.. Completely wiped my DB. Getting crashes every time it gets to the starting of the Hive.log. Verified that all deployed items were moved. However since I am running Tavi. Were the Dll (Tbb, tbbmalloc etc) matter?
 

thevisad

Moderator
Staff member
OK ran above and ran build.pl with no updates.(Wrecks etc.. Completely wiped my DB. Getting crashes every time it gets to the starting of the Hive.log. Verified that all deployed items were moved. However since I am running Tavi. Were the Dll (Tbb, tbbmalloc etc) matter?

Tavi is not supported, run it at your own risk. It uses its own version of DayZ code that is not compatible at this moment.
 

Falcon911

Well-Known Member
Sorry I did not give you the full picture. I redid my Cherno DB with Reality and basically started from scratch. I do run another DB with Tavi which is running the Bliss until Tavi gets updated to Reality. But my question are/is the Bliss dll's compatible with Reality?
 

gdscei

Valued Member!
What host do you run with, wriley? Or do you host your own?

Our guy Ersan (DayZ.ST) said it was an error in the buildings table. I'll post here with what he fixes and/or changes.
an error in the buildings table would not have anything to do with heli crashes. Your host probably hasn't updated the server files properly yet. I've been hearing many issues from dayz.st, personally kinda getting annoyed by all the people posting issues in this forum while it's them not setting up stuff properly.
 

nman321

New Member
i followed all the instructions to install the server pack but at instruction #8 it said to configure file in C:\Users\MyName\Desktop\DayZ Server\dayz_1.chernarus

that is named config_deadbeef.cfg i understand that the deadbeef part will be diffrent for me, but there is nothing exept User, battleeye folders and HiveEXT, config.cfg, and basic.cfg

when ever i join the server i get a
"error 1146 dayz.message dosnt exist in mysql"
in the server console

Im guessing this is because of this missing deadbeef file not being config with my MySQL password

please help me
 

gdscei

Valued Member!
i followed all the instructions to install the server pack but at instruction #8 it said to configure file in C:\Users\MyName\Desktop\DayZ Server\dayz_1.chernarus

that is named config_deadbeef.cfg i understand that the deadbeef part will be diffrent for me, but there is nothing exept User, battleeye folders and HiveEXT, config.cfg, and basic.cfg

when ever i join the server i get a
"error 1146 dayz.message dosnt exist in mysql"
in the server console

Im guessing this is because of this missing deadbeef file not being config with my MySQL password

please help me
Config.cfg IS the deadbeef file. Also, MySQL details aren't set-up there, they're in hiveext.ini
 

Viba

Member
i followed all the instructions to install the server pack but at instruction #8 it said to configure file in C:\Users\MyName\Desktop\DayZ Server\dayz_1.chernarus

that is named config_deadbeef.cfg i understand that the deadbeef part will be diffrent for me, but there is nothing exept User, battleeye folders and HiveEXT, config.cfg, and basic.cfg

when ever i join the server i get a
"error 1146 dayz.message dosnt exist in mysql"
in the server console

Im guessing this is because of this missing deadbeef file not being config with my MySQL password

please help me
The config file you're searching for is the config.cfg.
Have you built the server with --with messages? Don't know for sure but it would appear you don't have the message table in your database.
 

nman321

New Member
yes I loaded everything into build.pl is it possible that when i migrated everything to the MySQL it missed the files needed
 
Top