SARGE AI Framework - Public Release

Status
Not open for further replies.
Hiyas Sarge,
I was using TK_INS_Warlord_EP1 (leader), TK_INS_Soldier_Sniper_EP1 (self explanatory), TK_INS_Soldier_2_EP1 and soldier 3. Would love to give you snippet of log but i delete them after done but i can say that there was nothing showing up in them indicating an issue. It all runs smoothly and they were just eyecandy anyway so no big deal, I went back to the skins you had originally and they all spawn with their weapon loadouts.

Still havin a Hoot, Blut
 

Sarge

OpenDayZ Guru!
Staff member
Hiyas Sarge,
I was using TK_INS_Warlord_EP1 (leader), TK_INS_Soldier_Sniper_EP1 (self explanatory), TK_INS_Soldier_2_EP1 and soldier 3. Would love to give you snippet of log but i delete them after done but i can say that there was nothing showing up in them indicating an issue. It all runs smoothly and they were just eyecandy anyway so no big deal, I went back to the skins you had originally and they all spawn with their weapon loadouts.

Still havin a Hoot, Blut
Oki :) seems with some skins we see problems. Better to stick to the original Dayz ones then.

cheers mate,

Sarge
 
Love the AI script, works great only one gripe and I cant seem to find/figure out where to change this.

Where is the parameter for the time units taken for the AI corpse's to despawn? Having real issues getting to the bodies in time to loot them would like to increase it to something around the 5-10 minute mark, seems to only be 60 or 120 seconds currently.
 

Sarge

OpenDayZ Guru!
Staff member
Hi Meuk,

The markers that you see are there because you have your server configured to do so - I would recommend you can leave that on for testing, but for a live server, switch them off (ARMA2OAProfile).

I tried that on my environment - military AI are shown as green, regardless if i shoot them or not. My color switched from blue to orange after i shot one of them.

so any green unit marker you see are friendly AI units (military and survivors), and red ones are hostile AI units. The markers ARE showing their side. Blue = West, Green = resistance, orange = enemy and red = east = bandits.

Given that bandits CAN wear survivor skins, you might confuse bandit groups with survivor groups. Set the bandit skins to only contain bandit skins, and check ingame who shoots you.

cheers, Sarge
Yes, I think that was the problem. The green shooting on sight was probably just allies shooting at bandits. I just need to balance the spawns to avoid getting killed too easily. Also, will chaning the search radius for vehicles to 0 make them stop taking vehicles?

EDIT: How do I make them enter the car if i am in it, but not if its empty?
 
If you have dynamic spawns OFF, you should not see any AI spawning in near players. What you might see is static groups respawning though.

Medic =

a) you need to have positive humanity
b) you need to have a bloodbag on you
c) talk to the group leader

d) profit :)
When we use the bloodbag interaction, the leader goes through the motions and the bloodbag is removed from inventory, but no players gain any health.
Thoughts?
 

Sarge

OpenDayZ Guru!
Staff member
When we use the bloodbag interaction, the leader goes through the motions and the bloodbag is removed from inventory, but no players gain any health.
Thoughts?
Only the player that started the conversation and gets the bloodbag removed should gain health. I can recheck, but i think i tested that and ok'ed it.
 
Sarge can you help me add some stationary ai?
in map config folder edit sar_cfg_grps_schernarus or whatever map you use.

Copy paste one of the markers like this
//ZUB CASTLE
_this = createMarker ["SAR_marker_ZUBcastle",[6244.87,5205.74]];
_this setMarkerShape "RECTANGLE";
_this setMarkeralpha 1;
_this setMarkerType "Flag";
_this setMarkerBrush "Solid";
_this setMarkerSize [1000, 1000];
SAR_marker_ZUB = _this;

Put the CREATE MARKER line to use the lower left corner of the box you want the units to stay in.
then use the setmarkersize to make now far east and north the units will go.

Then below add this line.
[SAR_marker_ZUB,3,0,2,"patrol",true] call SAR_AI;

make sure your SAR_marker_ name is unique and matches the defined area you created above.
the numbers are unit TYPE, SNIPERS,RIFLEMEN. the leader is also added. The TRUE/FALSE means whether they respawn when killed.


Now the bloodbag problem. Yes, I have initiated the conversation, the leader does the animation, my bloodbag is removed from my inventory but I gain no health. Others on my server say same thing and have wasted countless bloodbags. I compared the code with the medic code and it seems to be the same but there is some problem with either my server or this block:

if (_finished) then {
_actingPlayer setVariable["LastTransfusion",time,true];
_actingPlayer setVariable["USEC_lowBlood",false,true];
_actingPlayer removeMagazine "ItemBloodbag";
["usecTransfuse",[_actingPlayer,_targetAI]] call broadcastRpcCallAll;

} else {
r_interrupt = false;
doMedicAnim = [_targetAI,"Stop"];
publicVariable "doMedicAnim";
};


Can anyone else confirm that this works or doesn't work on their server?
Thanks.
 
Love the AI script, works great only one gripe and I cant seem to find/figure out where to change this.

Where is the parameter for the time units taken for the AI corpse's to despawn? Having real issues getting to the bodies in time to loot them would like to increase it to something around the 5-10 minute mark, seems to only be 60 or 120 seconds currently.
Edit SAR_config.sqf

look for line:

// time after which dead AI bodies are deleted
SAR_DELETE_TIMEOUT = 600; // 10 minutes

I have mine set to 10 minutes as shown
 
I've only played at night time in the server, but I only see Heli's flying around. I haven't seen any on foot. I've increased the numbers in places and the probability to 100. Idea's on the problem?
 

Sarge

OpenDayZ Guru!
Staff member
in map config folder edit sar_cfg_grps_schernarus or whatever map you use.

Copy paste one of the markers like this
//ZUB CASTLE
_this = createMarker ["SAR_marker_ZUBcastle",[6244.87,5205.74]];
_this setMarkerShape "RECTANGLE";
_this setMarkeralpha 1;
_this setMarkerType "Flag";
_this setMarkerBrush "Solid";
_this setMarkerSize [1000, 1000];
SAR_marker_ZUB = _this;

Put the CREATE MARKER line to use the lower left corner of the box you want the units to stay in.
then use the setmarkersize to make now far east and north the units will go.
Thx for helping out, but the above is not correct. The coordinates in CREATEMARKER are the CENTER of the defined area.

MARKERSIZE describes the distance from the center to the border for x and y. So if you want a 100x100 area, these need to be set to 50,50!


Then below add this line.
[SAR_marker_ZUB,3,0,2,"patrol",true] call SAR_AI;

make sure your SAR_marker_ name is unique and matches the defined area you created above.
the numbers are unit TYPE, SNIPERS,RIFLEMEN. the leader is also added. The TRUE/FALSE means whether they respawn when killed.


Now the bloodbag problem. Yes, I have initiated the conversation, the leader does the animation, my bloodbag is removed from my inventory but I gain no health. Others on my server say same thing and have wasted countless bloodbags. I compared the code with the medic code and it seems to be the same but there is some problem with either my server or this block:

if (_finished) then {
_actingPlayer setVariable["LastTransfusion",time,true];
_actingPlayer setVariable["USEC_lowBlood",false,true];
_actingPlayer removeMagazine "ItemBloodbag";
["usecTransfuse",[_actingPlayer,_targetAI]] call broadcastRpcCallAll;

} else {
r_interrupt = false;
doMedicAnim = [_targetAI,"Stop"];
publicVariable "doMedicAnim";
};


Can anyone else confirm that this works or doesn't work on their server?
Thanks.
Did you change that code ? _actingplayer and _targetAI have two underscores in some places, should have one and have one here.

Sarge
 
I've spent awhile looking through those threads, and found nothing. To be honest, I'm not sure I have a problem, But I just wanted clarification.
I have NPC's flying Helicopters around, though they aren't attacking me. It is night time so I assumed that had something to do with it. But I see no NPC's on foot. I'm pretty certain that they both run on the same files I installed, considering I have NO other modifications to my server. So I'm just wondering what the problem could be if one exist. I put the probability of the spawn area's I'm around at 100.
 
Status
Not open for further replies.
Top