Base Building DayZ 1.2 Released

Yup you will see that bug more frequently when not using the default object_build. I believe this bug is the reason the dayzmod team added all these constraints to where you can place a tent in the first place. You will definitely see it if you move a tents worldspace because you haven't update its uid to go with the new worldspace.

The objectUID from the database is calculated based on the position of an object. It is nothing more than a different representation of worldspace coordinates. It's used for all the keycodes in basebuilding 1.2. This is the unique identifier used by a client to update a tents inventory etc. The clients cannot read the database they pass the uid based on the objects position, if that uid doesnt match the uid that was originally inserted into the database (because something has caused its position to shift, like another object being close to it) then no database updates are possible. Even if you pack it it will respawn after a restart afaik.

I suggest staying on the default object_build and deleting all tents an stashes that have not been updated recently in the database if you are having problems. In basebuilding 1.3 rosska stores and reads the uid for BB objects differently so it cannot change over time, this wouldn't be possible for tents without a lot of work changing more dayzmod files though. You will see this bug on any dayzmod server but obviously basebuilding makes it more likely an objects position can shift slightly after it was originally built.

That all makes total sense! So I had not seen a release for Rosska's v1.3 of Base Building posted in the Release section. Is it released somewhere? If so, is there a migration guide for anyone already up on v1.2, or would it be a wipe of the PBOs and database and everyone would have to start over?
 

seaweeduk

OpenDayZ Rockstar!
That all makes total sense! So I had not seen a release for Rosska's v1.3 of Base Building posted in the Release section. Is it released somewhere? If so, is there a migration guide for anyone already up on v1.2, or would it be a wipe of the PBOs and database and everyone would have to start over?

We still have some tidying up to do to finish it all up but it'll be posted in the release section soon, there will be instructions for upgrading from 1.2 available. We wrote a few SQL queries to make sure you can keep your old buildables under the new system after updating. If you want to get hold if it now you can message daimyo. Rosska has brought some really great updates and bugfixes to the code though, its more like version 1.4 or 1.5 now... So I would just wait a little longer for the proper release.
 
We still have some tidying up to do to finish it all up but it'll be posted in the release section soon, there will be instructions for upgrading from 1.2 available. We wrote a few SQL queries to make sure you can keep your old buildables under the new system after updating. If you want to get hold if it now you can message daimyo. Rosska has brought some really great updates and bugfixes to the code though, its more like version 1.4 or 1.5 now... So I would just wait a little longer for the proper release.

I would rather wait and have all the bells and whistles ... Things are stable right now for me and I would rather have a clean upgrade path. Thanks for the info and to you and Rosska and everyone else supporting and improving this great addon!
 

$toney

Well-Known Member
I thought they were included in the git-package.

edit: Ah, stupid me. Use the 1.3 version. It´s much better. And the BE filters are included.
The BE filters included are not the current format. I thought the BE filters were updated and can no longer be written in the old format? I'm referring to the Be Filter Changes.txt file now and it doesn't look as though they were updated for the new format?
 
There are only one or two filter settings that needed escaping and those are perfectly provided in the correct syntax. Works for me. Got BB 1.3 running perfectly on my servers.
 
Last edited:
Has anyone got this to work on DayzSt? I'm running Epoch Chernarus and after taking a glance at the database there is no deployable table to even insert the SQL entries into? If you have to create one could use some help on that.
 
Hmm... there are people building bases... the infiniStar issue still exist. Non-admins cannot build flags. A quick fix is letting admins build the flags and transfer the rights to the player.

Still there is another problem... people cannot log in and are stuck at "Server requests auth..."
 
I am trying to get this script to work with a pre-existing Epoch Admin Tools v1.7 but it seems like some of the classes were used by both scripts, so I commented out each section that it gave errors about and the server launched successfully.

The problem is now the Base Building Recipe Book menu GUI is partially cutoff. Any idea how I can adjust it so I can see the whole menu?? I saw someone else posted with this problem in this thread but there was no solution posted.



DayZ Base Building 1.3 Discussion

Plz Halp

I apologize in advance if the issue was solved but I did search this thread as well as the forum without luck
 
I am trying to get this script to work with a pre-existing Epoch Admin Tools v1.7 but it seems like some of the classes were used by both scripts, so I commented out each section that it gave errors about and the server launched successfully.

The problem is now the Base Building Recipe Book menu GUI is partially cutoff. Any idea how I can adjust it so I can see the whole menu?? I saw someone else posted with this problem in this thread but there was no solution posted.



DayZ Base Building 1.3 Discussion

Plz Halp

I apologize in advance if the issue was solved but I did search this thread as well as the forum without luck
1.2 is outdated upgrade to 1.3 as it has a Epoch specific version
 
I installed 1.3 fresh, that image is just from asiankid's post, I'm having the same problem on 1.3


EDIT: Sorry, I only replied in this thread because I noticed the same problem was posted earlier, I would have posted in 1.3 if I noticed that I wasn't.

I sent asiankid a message but I've yet to hear back, no idea if he ever got it working with Epoch Admin Tools
 
Last edited:
quick question on how you get the base building to work completely.

I can create the objects ( gate for example ) but when i try to use the options to "move up" "push" or "rotate" for example... nothing happens to the object... it just sits there staring at me and asking "what... you gonna place me or what"

?
 
Top