DayZ 1.7.5.1

I have also an issue with damaged vehicles.

For example: i found a car with 3 wheels. but i see only the option to repair 1 glass ...


edit: and if i repair the car with 1 glass its complete green.
 

Torndeco

Valued Member!
Panthera + Taviana haven't been updated yet to use the new server cleanup fsm...
This is basicly apply to all maps / mods based off pre dayz code 1.7.5,

Might not apply to tavi.eu, as they appeared to have some dev dayz code 1.7.5 in there last release...


U should mission fix the variables.sqf, add the following lines to the top of the file
Code:
AllPlayers = ["Soldier_Crew_PMC","Sniper1_DZ","Camo1_DZ","Soldier1_DZ","Rocket_DZ"];
AllPlayersVehicles = ["Soldier_Crew_PMC","Sniper1_DZ","Camo1_DZ","Soldier1_DZ","Rocket_DZ","AllVehicles"];
Or u could just edit the file and change all occurances of
Code:
AllPlayer
to
Code:
["Soldier_Crew_PMC","Sniper1_DZ","Camo1_DZ","Soldier1_DZ","Rocket_DZ"]
in the server cleanup fsm




-----------------
-----------------

Plus there will be more likely more problems by updating your dayz server code for maps.
That haven't had chance to get updated yet
 
I'm getting same problems with both Panthera and Taviana. Stuck at loading until something went wrong.
I also saw the 'script "z\addons\dayz_code\compile\player_onpause.sqf not found' error.
Rpt logs keep spamming this with both maps:

Code:
 0:49:40 Error in expression <lse];
_nearby = count (_x nearEntities [AllPlayers, 100]);
if ( (!_keep) && (_ne>
0:49:40  Error position: <AllPlayers, 100]);
if ( (!_keep) && (_ne>
0:49:40  Error Undefined variable in expression: allplayers
0:49:40 Error in expression <lse];
_nearby = count (_x nearEntities [AllPlayers, 100]);
if ( (!_keep) && (_ne>
0:49:40  Error position: <AllPlayers, 100]);
if ( (!_keep) && (_ne>
0:49:40  Error Undefined variable in expression: allplayers
0:49:40 Error in expression <lse];
_nearby = count (_x nearEntities [AllPlayers, 100]);
if ( (!_keep) && (_ne>
0:49:40  Error position: <AllPlayers, 100]);
if ( (!_keep) && (_ne>
I have problem also!

Exactly the same!
 

axeman

OpenDayZ Rockstar!
I'm getting same problems with both Panthera and Taviana. Stuck at loading until something went wrong.
I also saw the 'script "z\addons\dayz_code\compile\player_onpause.sqf not found' error.
Rpt logs keep spamming this with both maps:

Code:
 0:49:40 Error in expression <lse];
_nearby = count (_x nearEntities [AllPlayers, 100]);
if ( (!_keep) && (_ne>
0:49:40  Error position: <AllPlayers, 100]);
if ( (!_keep) && (_ne>
0:49:40  Error Undefined variable in expression: allplayers
0:49:40 Error in expression <lse];
_nearby = count (_x nearEntities [AllPlayers, 100]);
if ( (!_keep) && (_ne>
0:49:40  Error position: <AllPlayers, 100]);
if ( (!_keep) && (_ne>
0:49:40  Error Undefined variable in expression: allplayers
0:49:40 Error in expression <lse];
_nearby = count (_x nearEntities [AllPlayers, 100]);
if ( (!_keep) && (_ne>
0:49:40  Error position: <AllPlayers, 100]);
if ( (!_keep) && (_ne>

I have just updated my server with dayz commander, downloaded the latest Reality build and run the .cmd for chernarus (starting with a clean install), granted I had to fix the #44 / BE script problem. Server is up and running. Is Chernarus, not Taviana.

Your missing player_onpause.sqf seems like a problem with version mismatch or your build ? I may be wrong, I am learning this stuff too :) I have seen that file in the new dayZ mission files..
 
I have just updated my server with dayz commander, downloaded the latest Reality build and run the .cmd for chernarus (starting with a clean install), granted I had to fix the #44 / BE script problem. Server is up and running. Is Chernarus, not Taviana.

Your missing player_onpause.sqf seems like a problem with version mismatch or your build ? I may be wrong, I am learning this stuff too :) I have seen that file in the new dayZ mission files..
Yeah Chernarus is running fine, thought the other maps would work since they don't use the 1.7.5.1 DayZ mod per se. I'm going to test changing the cleanup script tomorrow in the way Torndeco explained, if that doesn't fix it I'm going to make separate dayz/server dll files for the other maps to use.
 

Graz

Well-Known Member
Had a few issues, but got it working after 5 minutes of fiddling around.

The rought idea of what I did:
  1. Deleted all dayz & reality files from my ARMA2 file on the server.
  2. put a fresh client side Dayz in (V1.7.5.1)
  3. Fresh rebuild of Reality (no packages currently)
Worked fine after that. Just make sure you use the reality .dll files, not the Dayz mod ones, as they are for the community hive.
 

Graz

Well-Known Member
Yeah Chernarus is running fine, thought the other maps would work since they don't use the 1.7.5.1 DayZ mod per se. I'm going to test changing the cleanup script tomorrow in the way Torndeco explained, if that doesn't fix it I'm going to make separate dayz/server dll files for the other maps to use.
There will be a mad scramble with the other mods throughout the week, trying to get them all updated.

It might take a little bit to catch up unless map modders are using the reality build as the foundation for their update
 
Has anyone managed to find out where to edit the heli crash site data? We'd like to spawn multiple ones at once, and edit the loot on them. We run a non-As50 server, and would like to keep it that way.
 

Graz

Well-Known Member
There's a function in called fn_spawncrashes from memory.

It selects arrays at the very top of the copy (it randomly chooses milatary, barracks and helicrash tables now)

If you just define an array above it and slot it into that code you should get your own loot tables. It might be easier this way them previously.

As for defining the time part, zero idea yet. If anyone figures out please do share :)
 
Graz, I'm looking at that .sqf with my buddy, and for the life of me I cannot see -what- tables are being referenced. Are they in the DayZ_Code regular?
 

Graz

Well-Known Member
It's in the Dayz_server.pbo

I've just grabbed the sever file and looked it's:
Dayz_Server >>> Compile >>> server_spawnCrashSite.sqf
 

thevisad

Moderator
Staff member
Guys, I will be removing the other missions that are not supported in 1.7.5.1 until they are updated to the latest. Currently, only Chernarus and Utes are 1.7.5.1 compliant.
 
It's in the Dayz_server.pbo

I've just grabbed the sever file and looked it's:
Dayz_Server >>> Compile >>> server_spawnCrashSite.sqf
Yeah, we see it there. The changed so much from the last PBO. I will update here with our success, or failure.
 
For some reason after the client side update I can't connect to my server I get The number #44 battle eye error. As far as updating the server to 1.7.5.1 how will it effect my Bliss Hive? I am pretty ignorant to all this (really new) so I am ignorant of the process of how to update the server and how it will effect my hive
 
We've spoken to our host (DayZ.ST) and Ersan said that he wasn't seeing anything in the RPT logs about heli crashes even spawning. So either they do not log there, or nothing is working on our end.

Anyone else having issues with them spawning at all?
 

Graz

Well-Known Member
Found one in my .rpt this morning. Not sure if it's working though.

Code:
2013/02/05,  3:08:19 "READ/WRITE: "["PASS",[2013,2,4,22,8]]""
2013/02/05,  3:08:19 "CLEANUP: DELETED 109 LOOT BAGS"
2013/02/05,  3:08:41 "CRASHSPAWNER: Spawning 'Crashed UH-1Y' with loot table 'HeliCrash' NOW! (3322.92) at: [8525.88,11004.6]"
2013/02/05,  3:08:41 UH1Wreck_DZ: MainTurret - unknown animation source MainTurret
2013/02/05,  3:08:41 UH1Wreck_DZ: MainGun - unknown animation source mainGun
2013/02/05,  3:08:41 UH1Wreck_DZ: Gatling - unknown animation source Gatling
2013/02/05,  3:08:41 "CRASHSPAWNER: Loot spawn at 'Crashed UH-1Y' with loot table 'HeliCrash'"
2013/02/05,  3:08:41 "CRASHSPAWNER: Loot spawn at 'Crashed UH-1Y' with loot table 'HeliCrash'"
2013/02/05,  3:08:41 "CRASHSPAWNER: Loot spawn at 'Crashed UH-1Y' with loot table 'HeliCrash'"
2013/02/05,  3:08:41 "CRASHSPAWNER: Loot spawn at 'Crashed UH-1Y' with loot table 'HeliCrash'"
2013/02/05,  3:08:41 Error in expression <s select _index;
_itemType = _itemTypes select _index;
[_itemType select 0, _ite>
2013/02/05,  3:08:41   Error position: <select _index;
[_itemType select 0, _ite>
2013/02/05,  3:08:41   Error Zero divisor
2013/02/05,  3:08:41 File z\addons\dayz_server\compile\server_spawnCrashSite.sqf, line 95
2013/02/05,  3:08:42 "CRASHSPAWNER: Loot spawn at 'Crashed UH-1Y' with loot table 'HeliCrash'"
2013/02/05,  3:08:42 "CRASHSPAWNER: 75% chance to spawn 'Crashed UH-1Y' with loot table 'HeliCrash' at 6183.98"
2013/02/05,  3:10:38 "DEBUG FPS  : 49.8442"
 

thevisad

Moderator
Staff member
Found one in my .rpt this morning. Not sure if it's working though.

Code:
2013/02/05,  3:08:19 "READ/WRITE: "["PASS",[2013,2,4,22,8]]""
2013/02/05,  3:08:19 "CLEANUP: DELETED 109 LOOT BAGS"
2013/02/05,  3:08:41 "CRASHSPAWNER: Spawning 'Crashed UH-1Y' with loot table 'HeliCrash' NOW! (3322.92) at: [8525.88,11004.6]"
2013/02/05,  3:08:41 UH1Wreck_DZ: MainTurret - unknown animation source MainTurret
2013/02/05,  3:08:41 UH1Wreck_DZ: MainGun - unknown animation source mainGun
2013/02/05,  3:08:41 UH1Wreck_DZ: Gatling - unknown animation source Gatling
2013/02/05,  3:08:41 "CRASHSPAWNER: Loot spawn at 'Crashed UH-1Y' with loot table 'HeliCrash'"
2013/02/05,  3:08:41 "CRASHSPAWNER: Loot spawn at 'Crashed UH-1Y' with loot table 'HeliCrash'"
2013/02/05,  3:08:41 "CRASHSPAWNER: Loot spawn at 'Crashed UH-1Y' with loot table 'HeliCrash'"
2013/02/05,  3:08:41 "CRASHSPAWNER: Loot spawn at 'Crashed UH-1Y' with loot table 'HeliCrash'"
2013/02/05,  3:08:41 Error in expression <s select _index;
_itemType = _itemTypes select _index;
[_itemType select 0, _ite>
2013/02/05,  3:08:41  Error position: <select _index;
[_itemType select 0, _ite>
2013/02/05,  3:08:41  Error Zero divisor
2013/02/05,  3:08:41 File z\addons\dayz_server\compile\server_spawnCrashSite.sqf, line 95
2013/02/05,  3:08:42 "CRASHSPAWNER: Loot spawn at 'Crashed UH-1Y' with loot table 'HeliCrash'"
2013/02/05,  3:08:42 "CRASHSPAWNER: 75% chance to spawn 'Crashed UH-1Y' with loot table 'HeliCrash' at 6183.98"
2013/02/05,  3:10:38 "DEBUG FPS  : 49.8442"

These are wrecks, not heli's, I have been spending more time coding then playing so I have yet to notice a heli, I will look into it further.
 

thevisad

Moderator
Staff member
For some reason after the client side update I can't connect to my server I get The number #44 battle eye error. As far as updating the server to 1.7.5.1 how will it effect my Bliss Hive? I am pretty ignorant to all this (really new) so I am ignorant of the process of how to update the server and how it will effect my hive

There is a database schema update that will convert you from the Bliss to the Reality hive. This will allow you to push any updates I make to the system in the future. Other then that? Nothing changes for you other then running more up to date code.
 

Graz

Well-Known Member
I don't have wrecks enabled on my server, is there wrecks in default dayz now?

I need to look at the change log >_<
 
Top