DayZ Epoch Taviana 2.0 - How?

it shouldnt. you should have instance variables .. 11 for chernarus and 17? for taviana .. delete the one accordingly. maybe you should create a new taviana database .. that might fix it ..
start the mysql, open mysqlworkbench, create db and then execute the db.mysql files for epoch.

I will be home this afternoon until 5pm EST if you want to use the teamviewer.
 

AtomikMulch

Well-Known Member
A session of teamviewer might be in order.

I tried to create a new database using workbench and I was getting a bunch of epoch.sql not found errors and other similar error indicating of misplaced or missing files, which I found interesting.

Anyhow, chat with you later.
 

AtomikMulch

Well-Known Member
BTW, if I click on the wrong tab in the database via workbench and loadup an sql file and execute, will it overwrite anything already created???
 

AtomikMulch

Well-Known Member
Hey SB,

Last night I joined my Tavi server that you helped me setup. I was able to run around, check out the new map, kill those pesky zombies.
Today, I tried joining again to simply test something and I am able to join but I can't see the screen, it is stuck on the DayZ Epoch black splashscreen. I can hear the game going, birds chirping, my player running around making noise, but I can't see it. I closed down the client side and server and relaunched it and I am getting the same issue.

What may be the issue??
 
thats an epoch bug .. very common .. amazingly enough its not well known or promulgated.

The 'fix' is to edit your init.sqf and and place endloadingscreen somewhere down here. .. check mine and place it where my line is

There is another fix somewhere but this one seems to work.
Code:
/*   
    For DayZ Epoch
    Addons Credits: Jetski Yanahui by Kol9yN, Zakat, Gerasimow9, YuraPetrov, zGuba, A.Karagod, IceBreakr, Sahbazz
*/
startLoadingScreen ["","RscDisplayLoadCustom"];
cutText ["","BLACK OUT"];
enableSaving [false, false];

//REALLY IMPORTANT VALUES
dayZ_instance =    11;                    //The instance
dayzHiveRequest = [];
initialized = false;
dayz_previousID = 0;

DZE_ForceNameTagsOff = true;
DZE_APlotforLife = true;
DZE_modularBuild = true;
DZE_ConfigTrader = true;
DrinkWater = true;


//disable greeting menu 
player setVariable ["BIS_noCoreConversations", true];
//disable radio messages to be heard and shown in the left lower corner of the screen
enableRadio false;
// May prevent "how are you civillian?" messages from NPC
enableSentences true;

// DayZ Epoch config
spawnShoremode = 0; // Default = 1 (on shore)
spawnArea= 1500; // Default = 1500

MaxVehicleLimit = 200; // Default = 50
MaxDynamicDebris = 100; // Default = 100
dayz_MapArea = 14000; // Default = 10000
dayz_maxLocalZombies = 60; // Default = 30 
DZE_R3F_WEIGHT = true;
dayz_paraSpawn = true;

ns_blowout = true; // true / false
ns_blowout_dayz = true;// true / false
ns_blow_delaymod = 0.74; //blowout delay
ns_blow_itemapsi = "NVGoggles"; //ItemAPSI replacement
ns_blow_playerdamage = 3000; // damage players without ns_blow_itemapsi can get per blowout
ns_blow_emp = false; //Namalsk Only
ns_blow_prep = false;

dayz_minpos = -1; 
dayz_maxpos = 16000;

dayz_sellDistance_vehicle = 10;
dayz_sellDistance_boat = 30;
dayz_sellDistance_air = 40;

dayz_maxAnimals = 8; // Default: 8
dayz_tameDogs = true;
DynamicVehicleDamageLow = 20; // Default: 0
DynamicVehicleDamageHigh = 80; // Default: 100
DynamicVehicleFuelLow = 20;
DynamicVehicleFuelHigh = 85;
MaxMineVeins = 0;
DZE_vehicleAmmo = 1; //Default = 0, 1 to disable, 0 to enable.
DefaultMagazines = ["ItemBandage","ItemMorphine","17Rnd_9x19_glock17","17Rnd_9x19_glock17"]; 
DefaultWeapons = ["glock17_EP1","ItemFlashlight","ItemHatchet"]; 
DefaultBackpack = ""; 
DefaultBackpackWeapon = "";

DZE_BuildOnRoads = false; // Default: False

EpochEvents = [
["any","any","any","any",0,"crash_spawner"],
["any","any","any","any",20,"crash_spawner"],
["any","any","any","any",40,"crash_spawner"],
["any","any","any","any",50,"supply_drop"]];
dayz_fullMoonNights = true;

//Load in compiled functions
call compile preprocessFileLineNumbers "dayz_code\init\variables.sqf";                //Initilize the Variables (IMPORTANT: Must happen very early)
progressLoadingScreen 0.1;
call compile preprocessFileLineNumbers "dayz_code\init\publicEH.sqf";                //Initilize the publicVariable event handlers
progressLoadingScreen 0.2;
call compile preprocessFileLineNumbers "dayz_code\medical\setup_functions_med.sqf";    //Functions used by CLIENT for medical
progressLoadingScreen 0.4;
call compile preprocessFileLineNumbers "dayz_code\init\compiles.sqf";                //Compile regular functions
/*ZSC*/   
call compile preprocessFileLineNumbers "CfgServerTrader\gold\ZSCinit.sqf";
/*ZSC*/   
progressLoadingScreen 0.5;
call compile preprocessFileLineNumbers "server_traders_cherno_11.sqf";   
//call compile preprocessFileLineNumbers "server_traders.sqf";                //Compile trader configs
progressLoadingScreen 1.0;

"filmic" setToneMappingParams [0.153, 0.357, 0.231, 0.1573, 0.011, 3.750, 6, 4]; setToneMapping "Filmic";

if (isServer) then {
    call compile preprocessFileLineNumbers "\z\addons\dayz_server\missions\DayZ_Epoch_11.Chernarus\dynamic_vehicle.sqf";
    //Compile vehicle configs
   

    // Add trader citys
    _nil = [] execVM "\z\addons\dayz_server\missions\DayZ_Epoch_11.Chernarus\mission.sqf";
    _serverMonitor =     [] execVM "dayz_code\system\server_monitor.sqf";

};


endLoadingScreen; // Work around for loadscreen freeze
 

AtomikMulch

Well-Known Member
Ok, thanks to Shootingblanks, Tavi works.

So my new question is:

When changing the map used in the epoch server, let's say from Chernarus to Tavia to Lingor etc, what do I need to watch for (files, variables, hpp, etc) to ensure that the players and traders will spawn in the correct places on the map and not use the default Chernarus spawn points?
 
Last edited:
well , in the mission you have to edot the map name,in the mission.sqm addons array and the spawn locations as we learned. best to just take the mission.sqm,from the map you want as,they arent amny edits in tjat file,usually.

and if,running epoch you need to use the correct trader file and tradercity file. dzai automatically configimures itself,for cities so it works on any map.

and of course you need to change the name of the mission to match.

what else?


and we,didnt get to the custom sqf files,the other day, i happened to make a short video for someone else today but its what you need to know

 
i think chernarus always feels like home. knowing it well is good. the towns are all well detailed.

takistan is another professional map. it is NOT all sand as people think. ALL buildings are enterable and therfore have loot, but 80% of the buildings are residential or farm, industrial areas are rare. oil fields are nice. and its not an additional dowload. zargabad is,the same,but much smaller .. one city and outlying areas

lingor. well done map. tropical island. i created a custom mod using lingor and loved it

panthera. i really like the variation. it has desert, cities, mountains, volcano ..
but for some reason the ccities have no soul. it looks like nobody EVER lived in panthera. if you could add in more details to the map it would be great.

taviana is good. its large .. too large. the road system,is great and the buildings look more lived in than panthera. nuke power plant, racetracks .. better for a more 'alive' server .. it doesnt look post apocalyptic to me.

thats it. napf, saurland, etc all are large but they lack the details tat make them look like real places .

if it were more popular with players i would have only takistan. i feel,that map is complete and,gives a realistic feel. it seems to lack any points of interest though. have to add in some old foreign legion forts or ancient ruins to increase the interest.
2nd is chernarus
3rd is lingor
4th is,panthera
5th is,taviana
 

AtomikMulch

Well-Known Member
Ok, good to know.

I am trying to get the Epoch Lingor server going and I am once again, getting that Wait for Host error. I am checking all folders, assignment, hiveext.ini/config files etc. But so far no luck. I will post the RPT and log files shortly.
 

AtomikMulch

Well-Known Member
Ok, here is the RPT file for the Tavi server you helped me with. I realize too that the new Tavi map you gave me (the one with the corrected spawn locations) never worked for me.

https://www.dropbox.com/s/cdt9hwet0nfzx07/arma2oaserver.RPT?dl=0

So the last line of the RPT says:

Missing addons detected:
15:07:27 kh_dayztaviana
15:07:27 Warning Message: You cannot play/edit this mission; it is dependent on downloadable content that has been deleted.kh_dayztaviana


So I assume that the fix is to delete the "kh_dayztaviana" call within the addOns[] and addOnsAuto[] arrays found in the mission.sqm file.
 
Last edited:

AtomikMulch

Well-Known Member
Now, regarding the Overpoch.Lingor server I am trying to get going, the last lines of the RPT file are the following:

Missing addons detected:
15:16:40 brg_africa
15:16:40 ibr_plants
15:16:40 ibr_hangars
15:16:40 ibr_airports
15:16:40 ibr_lingor
15:16:40 ibr_lcivilian_patch
15:16:40 chn_crocodile
15:16:40 Warning Message: You cannot play/edit this mission; it is dependent on downloadable content that has been deleted.brg_africa, ibr_plants, ibr_hangars, ibr_airports, ibr_lingor, ibr_lcivilian_patch, chn_crocodile

WOW, many missing content... why is that???

Here is the RPT file

https://www.dropbox.com/s/ty42tw5auj9b2zm/arma2oaserver.RPT?dl=0


Is it fair to say that the maps that I am using are incorrect? I am taking the maps and missions from the Epoch server pack within the MPMissions folders....... is this the incorrect source?

So to correct this issue, do I need to delete the above calls/reference (ie: ibr_africa etc) from the mission.sqm file???
 
Last edited:
Those are the pbo's included in lingor island. You have not the @lingor in your client arma install. Or you do not have the correct path in your start.bat -mod line for @lingor ..
 
Code:
=====================================================================
== C:\Private_server\arma2oaserver.exe
== .\arma2oaserver.exe  -mod=Expansion\beta;Expansion\beta\expansion;ca;@dayz_overwatch;@dayz_epoch;@dayz_epoch_server -name=AtomikMulch -config=config\overpoch\overpoch.cfg -cfg=config\overpoch\basic.cfg -profiles=config\overpoch
=====================================================================
where did you add @lingor to your -mod parameter? And you have it on your client and added into the expansions right?
 

AtomikMulch

Well-Known Member
where did you add @lingor to your -mod parameter? And you have it on your client and added into the expansions right?
Ok, I don't have @Lingor.... that is the issue...... I thought it was just a simple map to add to the MPMission folder. That is why the =mod doesn't include the link. Now I understand that each map comes with an @<name of new map> folder (ie: @Tavi, @Lingor, @Pantera etc) that must be placed within the server folder and the client arma2:0a folder. Something new I just learned.

Ok, let me find and download the @Lingor client and server packs. So this is the same process as the @Taviana map.
 
Last edited:
BTW .. if you want to test out all these maps, download them and put each one into your client in its own folder
@lingor
@tavi
@celle
whatever the name is.
then start Arma2, and at the main screen press Control E to enter the 3d Editor.
Place a SIDE, GROUP, then UNIT. Now you can press PREVIEW to see the map, go back to 2D and drag your guy to somewhere else. Its the basic maps themselves, no addons or AI or Zombies but you can explore the map and see what you like and what you dont like. Best practice is to also create a helicopter at your location and then you can get in, fly around and see what needs closer expploration.
 
Top