How to install BEC on VDS server

Hello, I recently started renting a VDS server (windows 2008 R2) for arma 2 dayz overpoch. I finally got it installed and moved my game files over from the current host. With very little problems, afew scripts had to be reinstalled.

I am trying to get BEC setup to do the messages and restarts. I have spent the last two days trying and cant get it to work. I have followed this http://ibattle.org/install-and-configure/ but it's vague as crap to me. I tried my best to follow it, and it did not work (no messages ingame would popup). I then tried this
I do not understand the language but I followed it as best I could. I still do not get messages popping up and do not even know if it's running. The error log shows this

00:12:31 : Error with encoding in queued data list!
00:12:31 : Error in writing to BeLog file
00:17:31 : Error with encoding in queued data list!
00:17:31 : Error in writing to BeLog file
00:17:31 : Error with encoding in queued data list!

I am not sure what all that means.

If anyone could please help me that would be awesome
Thanks mike
 
if you have error messages, then its running, i would think. when you start, it should have a command prompt window open on your desktop.

why dont you post your files to pastebin and let us see
the config file, the scheduler.xml and your log files.
 
Ok since the work week has been long, I have not gotten around to messing with this until today.

Today I followed this video https://www.youtube.com/watch?v=ZiltElp19ho

I did as it said and still did not work. I replied there the maker of the video helped me but I still could not get it working. He gave me a extra step, and I did that. Since it did not work he says it's not going to work since bec was shut down months ago. So i'm here hoping for a work around that maybe he does not know of.

During the install it ask's for a hive password I do not use one but entered one any how.
I have a overpoch server, so I went ahead with the install. I copied the Battleye folder from the instance_11_chernarus into my instance_1_Overpoch folder. I also edited my config to point to the overpoch instance, along with edited the restart.bat and start.bat.

Since that did not work he said To fix this you simply need to go to your windows hosts files and redirect that outgoing connection to your local host. 127.0.0.1. I did that here is how that looks

127.0.0.1 ibattle.org
127.0.0.1 www.ibattle.org By the way both of those sites say unable to load if I go into the browser and type www.ibattle.org or ibattle.org

After doing that redirect, this happens

I run the start.bat the console opens and then bec.exe opens, it shows
Checking for new Bec version
connecting to Battleye server 71.164.205.46:2302
No valid response. trying to reconnect
Could not check for Bec update (in red)
no vaild response. trying to reconect.
no valid response. trying to reconnect.
Then Bec.exe close's the start.bat closes somewhere in there as well. I know its not working due to messages not popping up.


Under instance_1_Overpoch\Battleye\Bec\Log\Config\Error folder is empty. So I can't give anything from there.
The BeLog folder in that path has this

19:12:21 : No Valid response. Trying to reconnect.!
19:12:25 : No Valid response. Trying to reconnect.!
19:12:29 : No Valid response. Trying to reconnect.!
19:12:33 : Lost Connection!
19:12:33 : Closing socket & exiting!
19:35:52 : No Valid response. Trying to reconnect.!
19:35:56 : No Valid response. Trying to reconnect.!
19:36:00 : No Valid response. Trying to reconnect.!
19:36:04 : Lost Connection!
19:36:04 : Closing socket & exiting!

My config.cfg in \instance_1_Overpoch\BattlEye\Bec\Config looks like this

Bec]
IP = 71.164.205.46
Port = 2302
BePath = L:\Cadian epoch server\instance_1_Overpoch\BattlEye\
Admins = Admins.xml
Commands = Commands.xml
[Misc]
Ban = 3
ConsoleHeight = 30
ConsoleWidth = 60
Scheduler = Scheduler.xml
KickLobbyIdlers = 500
ChatChannelFiles = True
Timeout = 60
[Reporter]
#User = alfred
#Password = 123456

Here is the scheduler.xml I had to cut part of it out due to 100 character limit
<?xml version='1.0' encoding='UTF-8' standalone='yes' ?>
<Scheduler>
<job id='0'>
<day>1,2,3,4,5,6,7</day>
<start>000300</start>
<runtime>000300</runtime>
<loop>-1</loop>
<cmd>say -1 Admins: Mike and Slider</cmd>
</job>

<job id='1'>
<day>1,2,3,4,5,6,7</day>
<start>000300</start>
<runtime>000400</runtime>
<loop>-1</loop>
<cmd>say -1 PvE only Killing players is not allowed</cmd>
</job>

<!-- 06:00 AM restart -->
<job id='2'>
<day>1,2,3,4,5,6,7</day>
<start>05:45:00</start>
<runtime>000000</runtime>
<loop>0</loop>
<cmd>say -1 This server will restart in 15 minutes</cmd>
</job>

<job id='3'>
<day>1,2,3,4,5,6,7</day>
<start>05:55:00</start>
<runtime>000000</runtime>
<loop>0</loop>
<cmd>say -1 This server will restart in 5 minute, log out now to prevent item loss!</cmd>
</job>

<job id='4'>
<day>1,2,3,4,5,6,7</day>
<start>05:59:00</start>
<runtime>000000</runtime>
<loop>0</loop>
<cmd>say -1 This server will restart in 1 minute, Log out now!</cmd>
</job>

<job id='5'>
<day>1,2,3,4,5,6,7</day>
<start>06:00:00</start>
<runtime>000000</runtime>
<loop>0</loop>
<cmd>#shutdown</cmd>
</job>
</Scheduler>

Here is the start.bat

@ echo off
pushd %~dp0
cd /d %CD%
start /b "Dayz Epoch Server" /min "DayZ_Overpoch_instance_1_Chernarus.bat"
timeout 30
cd "L:\Cadian epoch server\instance_1_Overpoch\BattlEye\Bec"
start "UEP BattlEye Extended Control" /min "BEC.exe" -f "Config.cfg"
taskkill /f /im cmd.exe
cls
@exit

The restart.bat

@ echo off
pushd %~dp0
cd /d %CD%
timeout 7
taskkill /f /im bec.exe
timeout 15
start /b "Dayz Epoch Server" /min "DayZ_Overpoch_instance_1_Chernarus.bat"
timeout 15
cd "L:\Cadian epoch server\instance_1_Overpoch\BattlEye\Bec"
start "UEP BattlEye Extended Control" /min "BEC.exe" -f "Config.cfg"
taskkill /f /im cmd.exe
cls
@exit

I hope someone will know a work around to get this working or no another way to have auto messages posted ingame and auto restarts.
 
First of all, is Battleye running? In the game can you open a chat and type
#login rconpassword
and you are told you are now logged in as admin.

I run the start.bat the console opens and then bec.exe opens, it shows
Checking for new Bec version
connecting to Battleye server 71.164.205.46:2302
No valid response. trying to reconnect
Could not check for Bec update (in red)
no vaild response. trying to reconect.
no valid response. trying to reconnect.
Sounds like your beserver.cfg file doesnt have your rcon password configured.

127.0.0.1 ibattle.org
127.0.0.1 www.ibattle.org By the way both of those sites say unable to load if I go into the browser and typewww.ibattle.org or ibattle.org
Apparently the ibattle site is back working again so that part shouldnt be needed. BEC would look to a server for updates and if it found no server it failed. So doing that code we made your computer think that ibattle.or was ITSELF. Since ibattle exists again .. uneeded.

So my suggestion:
Go to this folder
Code:
BePath = L:\Cadian epoch server\instance_1_Overpoch\BattlEye\
and see if there is a beserver.cfg file there. It needs your rcon password set so BEC can communicate with your server. Create a text file and put this in it, of course replacing 'password' with your servers rcon password.
Code:
RConPassword password
MaxPing 250
My start.bat for Dayz looks like this: notice the -profiles=config/dayz at the end
Code:
start .\arma2oaserver.exe -mod=Expansion\beta;Expansion\beta\expansion;ca;@hive;@dayz -name=infected -config=config\dayz\dayz.cfg -cfg=config\dayz\basic.cfg -profiles=config\dayz
and that is where my active battleye folder must exist and contain beserver.cfg .... yours is apparently instance_1_overpoch\battleye. make sure that is where your beserver.cfg file is located. And SOMETIMES you need a bans.txt file which has to be added, again create an empty txt file if needed.
 
I hope someone will know a work around to get this working or no another way to have auto messages posted ingame and auto restarts.[/QUOTE]


you can run restart.bat from your task scheduler
https://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=3&cad=rja&uact=8&ved=0CCcQFjACahUKEwjc38WY4OfIAhUIMyYKHZ-QAkg&url=http://www.thewindowsclub.com/how-to-schedule-batch-file-run-automatically-windows-7&usg=AFQjCNHoHdDqizD68aaJqWiqF78wQOXpcg

Automatic messages script I posted this here a short time ago ... which was another thread with your exact same issues. BEC is a bitch sometimes.
http://opendayz.net/threads/help-server-messages.21993/#post-120870
 
Thanks for the help ShootingBlanks. Everything I have done so far was on my test bed which resides on my win 7 desktop. My real server runs on windows server 2008 R2. After trying what you said I still had no luck.

So I pulled my server offline for some time today, and tried it on that(the win server 08). I did everything the same and edited the files to point in the right direction. Once I run the start.bat (changed the timeout to 30 second), the console start's along with Bec.exe. Now here is where the difference is, Bec.exe now stay's open the entire time. Here is part of it, it also show's the ingame chat(not pictured).

http://prntscr.com/8wyjzu

When I type this and press enter #login rconpassword nothing happens (I replace password with my password) #login rcon0000, I have also tried #login 0000. 0000 is not my password BTW. Also I do not have myself listed in the admins.xml

The Beserver.cfg file is there, as seen bellow

http://prntscr.com/8wyl16

My DayZ_Overpoch.bat looks like this, which is where the START.bat grabs from

@Echo off
start "arma2" /min "arma2oaserver.exe" -port=2302 "-config=instance_1_Overpoch\config.cfg" "-cfg=instance_1_Overpoch\basic.cfg" "-profiles=instance_1_Overpoch" -name=instance_1_Overpoch "-mod=@DayZOverwatch;@DayZ_Epoch;@DayZ_Overwatch_Server;"

I'm not sure why your start.bat has the extra stuff, and if that could be the reason.

So it seems to be working, but still no messages show up. The windows 2008 server does (from previous attempts) has the redirect in the hosts file. Not sure if that needs to be deleted.

I will checkout the other links you posted in the morning. Wanted to get this posted hours ago, but we had a power transformer blow up and before that the website was down lol.

Thanks for the help.

PS how do you add pics from the computer without the link here?
 
Last edited:
PS how do you add pics from the computer without the link here?
On the toolbar, click on the IMAGE icon and a box will open up, paste your image link into that box. If you mean actually uploading images, you cant ... you have to use off-site hosted links. I dont know how easy lightshot is but I use ShareX and it captures and automatically uploads to imgur, google drive, dropbox or any of 30 other hosts and puts the link in your clipboard. So uploading a screenshot takes all of .. zero seconds. I have used a bunch of tools and this is by FAR the best (never used lightshot though), and I use it for forum posts many times a day.
<end advertisement>

my start.bat doesnt have anything 'extra', just different. just wanted to point out the -profiles option to go along with the image showing the location of my besever.cfg

The redirecting the hosts wont affect whether it works or not. So your BEC is actually working but the scheduler is not working. This is a problem sometimes because different versions of BEC use different formats in scheduler.xml and there isnt much documentation about it.

I looked at the scheduler.xml you posted and see you are using the fixed time format. remove those and see if your server messages work. I think the online documentation is wrong and you can not use seconds. I think the correct format is hours:minutes (05:45). Test BEC with just a single message set to repeat every 30 seconds after server start .. then you will immediately know if its working or not.
Code:
<!-- 06:00 AM restart -->
<job id='2'>
<day>1,2,3,4,5,6,7</day>
<start>05:45:00</start>
<runtime>000000</runtime>
<loop>0</loop>
<cmd>say -1 This server will restart in 15 minutes</cmd>
</job>
the problem with fixed restart times is what if you restart your server at 5 for some reason. Now an hour later it will restart again automatically. I always thought it was best to let the server run for X hours before restart rather than fixed times. But thats besides the point ... use are using
<cmd>#shutdown</cmd>
... instead run the external bat file that restarts BEC and Arma
<cmd>c:\arma\_restart.bat</cmd>
If the Arma server is off too long, BEC will timeout and will stop so you need to have BOTH stopped and then restarted and the Arma server ALWAYS has to be up and running before starting BEC so in my restart.bat file there is a delay before starting BEC to make sure Arma is up.
restart.bat
Code:
@echo off
echo.
echo KILL arma2oaserver.exe
set serverkill="C:\arma"
cd /d %serverkill%
taskkill /im arma2oaserver.exe
echo.
echo Kill Bec.exe
set beckill="C:\arma\BEC"
cd /d %beckill%
taskkill /im bec.exe

timeout 10

echo.
echo Starting Dayz Server
:: start the server..
set dayzpath="C:\arma\"
cd /d %dayzpath%
start /min _start_overpoch.bat
echo.
echo Starting Bec
timeout 10
:: start bec
set becpath="C:\arma\BEC"
cd /d %becpath%
start /min bec.exe -f Config.cfg
echo.
echo Server Started 100%

cls
@exit
Here is a download link for an entire working BEC that I put away when the news came out that BEC was discontinued and the website was down. I dont think you need it, since yours IS working but if you want a reference, it has the restart script and the hosts file ...
https://drive.google.com/file/d/0B4RTx5O3wZvERnJBN1NsWGsxNlU/view?usp=sharing
 
Last edited:
I tried what you said with the scheduler.xml. I renamed the old one and made a new one. This is everything that is in Scheduler now, and it did not work.

<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>

<Scheduler>

<job id='0'>
<day>1,2,3,4,5,6,7</day>
<start>000700</start>
<runtime>000000</runtime>
<loop>-1</loop>
<cmd>say -1 If you see this the message's are working</cmd>
</job>

</Scheduler>
 
Your runtime is zero. So in this configuration this message will print 7 minutes after the server starts and will not loop again. Your Loop is set to infinate (-1), but the time between loops is zero (<runtime>000000</runtime>).
So change the start time to 000100 and the runtime to 000030 so it starts one minute after startup and then every 30 seconds.

I am going to startup a server locally and get a BEC all configured and running .... I will post the entire package shortly with some video ... I have already done it, just waiting for video to upload to youtube. BEC is difficult and seems to fail for no obviouls reason sometimes ...
 
Thanks for posting that. I just replace my Bec folder with yours and now the messages appear on the server.

Question on how to make the server restart. For the server to restart would the scheduler.xml have to look like this? Should there be a task above this to kill the current session?

<job id='2'>
<day>1,2,3,4,5,6,7</day>
<start>060000</start>
<runtime>000000</runtime>
<loop>5</loop>
<cmd>C:\Users\n612ua\Desktop\Miike's overpoch server\Restart.bat</cmd>
</job>

Thanks for all the time and effort you have put in to help me get this working.
 
Last edited:
yes. The BEC can issue the command #shutdown but that just stops the server. I included that Restart.bat and that is the command you use (as you pointed out above) .. although that job doesnt look right, there is no loop becaus it starts 6 hours after server start and then BEC will be restarted so the timer restarts at zero.
Anyway, the restart searches for your BEC executable and the Arma2 server executable and kills those processes. Then it starts the Arma2 server and it waits 10 secodns for the server to be fully running before starting BEC. I suppose you COULD keep BEC running but it might shutdown when it cant contact your server. Best to just restart them both.
 
Thanks for all of the help. It is working perfectly now. Had a bit of confusion in the batch file but its sorted and I am on day 3 or 4 of successful restarts.
 
Top