Private Server Kicking players or Session Lost

Ok guys, this is racking my brain. Ill set a few things first
This is not my first rodeo.
I have privately hosted servers long before Epoch.
Then i got bored.
Currently im hosting an Epoch with Overwatch server (Overpoch)
Here is my current Server launch bat: (working)
start arma2oaserver.exe -port=2302 "-config=instance_11_Chernarus\config.cfg" "-cfg=instance_11_Chernarus\basic.cfg" "-profiles=instance_11_Chernarus" -name=instance_11_Chernarus "-mod=@DayzOverwatch;@DayZ_Epoch1051;@DayZ_Epoch_Server"
Here is my client launch params in steam: (working)
-window -nosplash -mod=C:\@ArmaMODS\@DayzOverwatch;C:\@ArmaMODS\@Dayz_Epoch1051
You will notice in the Server and Client params that i am not referencing the Arma 2 directory OR the Expansion directory. The Addons (from Arma2) folder is copied into the Arma OA directory on both the Server and the Client.
The Server and Client are on 2 diff machines.
This current configuration works perfectly with NO issues. Lets get that straight.
Now with this said, Ive had friends join with out issues using this same client method.
What ive noticed is people trying to join thru out the day and getting kick almost immediately OR sitting in debug (used spectate to watch).
Yes, verify sigs are enabled.
This got me wondering why? Had another friend try joining and they used DayzLauncher. He would log in, then get sent to debug right after the lobby.
if he switched back to my method, joins right in with no issues.
Ok, so i tried joining with DayzLauncher, same thing, i get stuck in debug.
Ok this got me thinking how DZL is loading, its referencing the Arma 2 directory and the Expansion folder such as:
"-mod=C:\Program Files (x86)\Steam\steamapps\common\Arma 2;Expansion"
ok, so maybe thats my problem on my server. so I attempt to use this param on the server:
start arma2oaserver.exe -port=2302 "-config=instance_11_Chernarus\config.cfg" "-cfg=instance_11_Chernarus\basic.cfg" "-profiles=instance_11_Chernarus" -name=instance_11_Chernarus "-mod=C:\Program Files (x86)\Steam\steamapps\common\Arma 2;Expansion;@DayzOverwatch;@DayZ_Epoch1051;@DayZ_Epoch_Server"
And this one on the Client thru steam:
-window -nosplash -mod=C:\Program Files (x86)\Steam\steamapps\common\Arma 2;Expansion;C:\@ArmaMODS\@DayzOverwatch;C:\@ArmaMODS\@Dayz_Epoch1051
no dice, Session Lost.
Ok, Lets try DZL, nope, same thing, Session Lost.
Ok, lets try DZL and connect to someone else's Overpoch server,
SAME THING. Ask my buddy to try, Same result.
Reinstall EVERYTHING fresh.
SAME THING. only a hand full of servers are able to be joined with DZL, and I tried almost EVERY Overpoch server i could find in DZL.
Now, back to my method, I am able to join EVERY overpoch server i can find in the Server browser with out issue.
So im asking all the server owners and gamers to fill me in on the secrete here?
People say the whole copy the Addons folder no longer works, but it seems to be the ONLY method that works for me in any configuration. Clients shouldn't have to do anything special to connect to my server, so how are all the Servers on DZL getting people to connect with out issues?
Any help would be appreciated, though ive probably tried it. If you comment, ill respond with results.
This is one of the things that helped kill Dayz .. you have to jump through hoops to get it working sometimes. "Professionals" here (Delpi and Dangerrus) have had major issues getting servers running .. and you seem knowledgable yourself .. Dayz is just a mess.
If they can actually JOIN the server using the Dayz Launcher then its not a @mod issue because the verifysignaturecheck would not allow them to join. The Expansion folder is dead and gone, dont use it.

Maybe DayzLauncher is just broken now? I dont know how it would affect the ability to join the server and then get tossed into debug, but that seems to be the case. If you can join by launching arma2 in steam then connecting to your ip (or using the server browser) then I would say its something beyond your control.

What do the client and server RPT logs say?
nothing. shows they join, then shows them disconnect. and on client side, no log at all. i didnt think it would have anything to do with sigs. pretty sure it has something to do with the way the SteamID sees the server. but not sure. it seemed to get more complicated after the whole merged with Steam stuff happened. And i think the Debug part has to do with the playermonitor. BUT, i did try one last thing that seems to be working. I launched my server like i normally do with a bat file and only calling the mods, have the Addons copied into the folder and NO Expansion. on the client side, i removed the Addons, redirected DZL to the correct Arma 2 and Arma 2 OA paths along with my mod paths. Still doesnt see my server in the list, but i can now join other servers, and if i back out to the server browser, i can join mine. so thats something. it probably IS because i had the Addons folder in my OA dir AND DZL was also trying to load it and the redirected one from the Arma 2 folder. So I registered it on Gametracker. guess we will see if people are able to spawn in. I would watch them all day join and get disconnected but never make it into the DB. thats why I suspected the playermonitor. Thanks for the insight though. You seem to know your stuff pretty well too. Ive just been out of the mod game for a couple years.

EDIT: oh, and DZL seems to always use the Expansions folder, its not an option to disable it. FWI. Ive never really used launchers. but for the normal joe to connect, it seems that is the only simple way for n00bs.
I am have the same problem. I am using Pwnoz0r privet server. It work fine BUT if i change the
START .\Expansion\beta\arma2oaserver.exe -mod=Expansion\beta;Expansion\beta\expansion;ca;@hive;@dayz -name=cfgdayz -config=cfgdayz\server.cfg -cfg=cfgdayz\basic.cfg -profiles=cfgdayz -enableHT


start arma2oaserver.exe -mod=@dayz;@hive -name=cfgdayz -config=cfgdayz\server.cfg -cfg=cfgdayz\basic.cfg -profiles=cfgdayz -enableHT -maxMem=2024
then boom session lost.

I am about to pull my hair out over this.
If I don't do that the server run but it will not show up on any server bowser but DayZ Launcher and when i use that it will only show the ping with no list or count of players. But if i do change that it tells me that the steam ports connect but it wont let me join due to the session lost. I had other players try to connect and they get the same kick message. I really want to get this server working so if some one can help that be epic. Thanks in advance.