[Release] AVendettaForYou's Custom Buildings

AVendettaForYou

Well-Known Member
I have all the abandoned camps in one mission file, I could however make a new one with just that camp.

I added Elektro but loot and zombie not spawn!!!
Have you checked your RPT log to see if there are any errors showing up?

for some reason i keep getting a server authentication timeout when players try to connect to my server after installing this addon. I had it working in every other version of DayZ previous to 1.8.0.2. When I upgraded to 1.8.0.2 for some reason it wont work anymore. can anyone help? or is anyone else having a problem with this in 1.8.0.2? so frustrating!
Check your RPT logs and see what errors they are giving.
 

AVendettaForYou

Well-Known Member
From what I see, there are issues in your init.sqf in the mission.pbo, are you trying to call the buildings from the mission or the server pbo?

Look at line 140 in the init.sqf and see what it is and figure out what you did wrong in there.
 
from your instructions i put them in the server pbo. When I run the default server pbo everything is fine. Only when i add the code you have in the instructions to server_functions.sqf is when i run into the server authentication problem
 

AVendettaForYou

Well-Known Member
From your provided RPT the error is in your mission.pbo as you can see below "Error in expression <issions\__cur_mp.chernarus\init.sqf" which is your init.sqf in the mission pbo, that is what is failing the server to load properly.

Code:
7:58:21 "PRELOAD_ Functions\init [[<No group>:0 (FunctionsManager)],any]"
7:58:21 "MPframework inited"
7:58:21 Error in expression <issions\__cur_mp.chernarus\init.sqf"
};
};
[] execVM "buildings\excbridge.sqf";
>
7:58:21  Error position: <};
[] execVM "buildings\excbridge.sqf";
>
7:58:21  Error Missing {
7:58:21 File mpmissions\__cur_mp.chernarus\init.sqf, line 140
7:58:21 Error in expression <issions\__cur_mp.chernarus\init.sqf"
};
};
[] execVM "buildings\excbridge.sqf";
>
7:58:21  Error position: <};
[] execVM "buildings\excbridge.sqf";
>
7:58:21  Error Missing {
7:58:21 File mpmissions\__cur_mp.chernarus\init.sqf, line 140
7:58:21 Warning Message: Script z\addons\dayz_server\init\server_functions.sqf not found
7:58:21 "Res3tting B!S effects..."
7:58:21 Warning Message: Script z\addons\dayz_server\system\server_monitor.sqf not found
 
I fixed line 140 but that was not causing the issue now my RPT Log is showing this

Code:
16:16:46 "PRELOAD_ Functions\init [[<No group>:0 (FunctionsManager)],any]"
16:16:46 "MPframework inited"
16:16:46 Warning Message: Script z\addons\dayz_server\init\server_functions.sqf not found
16:16:46 "Res3tting B!S effects..."
16:16:47 Warning Message: Script z\addons\dayz_server\system\server_monitor.sqf not found 16:18:26 Client: Remote object 4:7 not found
16:18:26 Client: Object 4:10 (type Type_149) not found.
16:18:26 Client: Object 8:2 (type Type_149) not found.
16:18:40 Client: Remote object 2:20 not found
16:18:40 Client: Object 10:2 (type Type_149) not found.
16:18:40 Client: Object 4:13 (type Type_149) not found.
16:18:40 Client: Object 8:3 (type Type_149) not found.
16:18:55 Client: Remote object 2:7 not found
16:18:55 Client: Object 4:14 (type Type_149) not found.
16:18:55 Client: Object 8:4 (type Type_149) not found.
16:19:05 Client: Remote object 4:1 not found
16:19:05 Client: Object 4:15 (type Type_149) not found.
16:19:20 Client: Remote object 2:8 not found
16:19:26 Client: Remote object 10:0 not found
16:19:26 Client: Remote object 4:12 not found
16:19:43 Client: Remote object 4:9 not found
16:20:09 Client: Remote object 4:3 not found
16:21:07 Client: Remote object 12:0 not found
16:21:07 Client: Object 15:2 (type Type_149) not found.
but they are in my server pbo so I dont know how they aren't finding them
 
thanks for all your help but I have solved the problem this afternoon....finally. The problem was that for some reason my PBO manager (cPBO i believe) wasn't packing the file correctly. I downloaded PBOview and checked the file and it told me it was not a valid PBO (that cPBO packed). So then I repacked the Server PBO with PBOView and BAM it works flawlessly! Thank you thank you, thank you for your help!

what was weird was that cPBO would pack my mission file just fine but not the server PBO.

I freaking love your addon! keep up the good work :) 2 thumbs up from me!
 
Hello,
looks a little bit unrealistic, try to add some concreat below massiv buildings and remove the hangers from the grass. Thats hundrets of tons.... they will never build on grassland. How can a heavy plan exit the hanger when its rainning? They cant.
Same for the fire station in balota... on the airfield itself? Thats blocking the airfield and if a plane crash on landing it will destroy the firestation... so how can the firefigther erase the fire.

You build massiv permanetn stone barracks into a temporary military camp? Thats nonsens and will never happend in the real world.

You forgott to add detail too. Your bases look too clean and empty thats why they dont have any kind of atmosphere. Your place are totaly replaceable. Make them unique! Create a story for you place and tell us the story with wrecks, boxes, barrels, fire, dirt, garbage, overgrown structrers, dirt tracks from vehicles and and and.

Why there no soilders in the militray camps? Because the camps was overrun by zombies. Show this with brocken fortifications and stuff.

Thats not a offensive post its only constructiv criticism :)
 

AVendettaForYou

Well-Known Member
I do appreciate the input, the only reason why I don't add in a lot of details is because each object you put in is more the server has to load as well as zombies that will spawn for each one, I do basic adding and not as much detail to help keep the server fps up.

Balota airfield itself has plenty of room to land/take off in an airplane that's why I keep everything centralized on the airfield, yes I understand that an airplane couldn't necessarily get out of the hangar but we all know they have a hard enough time getting out of it in the first place :p.

Some of the abandoned camps themselves have a few added details added in here and there such as crates/wrecks/etc.

I would be more then glad to add in a lot of small details because I absolutely love to do that, and I'm all about story telling but 90% of the people don't give a crap about details or a story behind it, they just want the buildings and that's it.

As you can see there have been only been a handful enjoying the work and a few issues here and there, but comparing the amount of people who have actually used my work versus the people that actually provide feedback is a very large difference.

/endexplanationrant?
 
AvendettaForYou,

I really like the maps you provided for Epoch. But, I sure would like some of the ones you made for regular DayZ/Overwatch. Any chance those could be modified to work on Epoch?
 
Thank you AVendettaForYou. This is the first, out of all of the map editing guides and and articles i have read or watched i have actually got to work on my dayz.st epoch server. a BIG thumbs up for u, cheers m8
 
I installed your addon on my OW server and removed the main.sqf from the buildings folder like you instructed but I still get buildings spawning on each other... any ideas why? I'm a little new at this.


Ok i have a correction. All but the buildings that where added in for the OW map have gone away.
 
The three bases are running very nicely on our server. Thanks for a nice addition. I am thinking of having Sarge AI patrol the Balotta base which has alot of military loot relative to the rest of the map. the idea is defeat the bots and gain access to a nice prize.
 
I have been using this addition on my Dayz.st Epoch server for a few weeks now. It's a great addition, but the buildings with doors seem to spawn double doors. In order to enter the barracks for example, you need to open 2 doors after a restart. Is there a way to fix this? Or have I done something wrong?
 
Last edited:
Top