Sahrani Server Setup

Oh I see sorry. Well hopefully i'll be able to host one soon.
Sahrani on HFB is possible through the custom mod option in your CP. I have spoken to HFB and it is doable but any custom DLL's have to be installed by HFB themselves. You would have to attach the DLL's to a ticket and they would do the rest as far as installing them. I haven't tried it yet but will this weekend I reckon. Hope this helps.
 
Hi.
I'm having problem with server installation. After copying all files from arma folders and sahrani zips to my server folder, i'm creating a database(dayzsahrani). I'm using navicat for this. There is dayz user. When i run database.sql file i got 2 errors:
[Err] 1064 - You have an error in your SQL syntax;
[Err] 1231 - Variable 'foreign_key_checks' can't be set to the value of 'NULL'
But 37 of 39 queries is ok, and in db i got all tables.
After editing config_xxx and hiveext.ini, i'm making startup.bat file.
And when i run it, console is saying that server is online, dedicated host created and host identity created. But when i try to join, there is this oac_core error. I'm using DayzComm on my machine and can play on any public server.
And i got this dayz black/white picture on loading before error. Shouldn't it be this green sahrani mountain?
There is some kind of problem with @dayz and @dayz_sahrani folders?
 
Well, i tried with and without @dayz folder, but this changes nothing. So in my 'Arma 2' folder on server i have files from Arma2 and Arma2:OA folders, and @dayz_sahrani, @hive-Sara and dayz_1.sara.
I cannot find step where i'm making something wrong..
 
I just found out, that my start file
c:\program files.......\mysql.exe ......... --execute="call pMain()"
start expansion......

is returning:
'error 1305 (42000) at line 1:procedure dayz_sara.pMain does not exist'
just before console starts.
Any thoughts?
 

Seven

Moderator
Staff member
You will need to use Mysql Workbench or some other program to run the SQL file. The SQL file is a standard SQL you get with DayZ so there is nothing different except for the vehicle locations. Navicat clearly doesn't like it. Or your SQL server is setup incorrectly.
 
Well, Mysql Workbench fails too:
1064. You have an error in sql syntax. Check manual[...]right syntax to use near Create Definer = 'root'@'localhost' procedure pCleanup()

And still after run: procedure dayz_sara.pMain does not exist.
 
Ok, mismatch in db name was responsible for pMain() does not exist, and now is starting without errors, but still this 'oac_core deleted' error wont let me play..
 
Ex as in first post:
C:\Program Files\MySQL\MySQL Server 5.5\bin\mysql.exe --user=dayz --password=CHANGEME --host=localhost --port=3306 --database=hivemind --execute="call pMain()"
start Expansion\beta\arma2oaserver.exe "-mod=Expansion\beta;Expansion\beta\Expansion" "-nosplash" "-cpuCount=1" "-name=Sara" "-profiles=dayz_1.sara" "-cfg=dayz_1.sara\basic.cfg" "-config=dayz_1.sara\config_1234567.cfg" "-mod=@DayZ_Sahrani;@Hive-Sara" "-world=sara" "-port=2402"

Used my names of coz.
I'm using dayzcommander on my machine to play, and when i changed -mod=@dayz to -mod=@dayz_sahrani, this oac_core error is gone. But right now next problem is retrying authenication-requesting authentication. And i'm able to play with -mod=@dayz switch on public server, no problem. So this is strange, that i have to change this to play on my server, right?
 

Seven

Moderator
Staff member
Wait. You don't need to change any command lines for commander, Commander detects Sahrani no problem. @DayZ has nothing to do with Sahrani, you will only cause problems using this. There is no "retrying Authentication" in our build since this is a feature of 1.7.7 code, We run 1.7.5 base code.
 
When i wont change @dayz to @dayz_sahrani in commander, i get this oac_core error. I do not understand this last sentence about retrying auth. You mean i should use/install older version of sahrani? Or dayz? But dayz is not required for server to work properly, right?
And i got an error which says:
picture \z\addons\dayz_code\gui\sahrani.paa not found
But i click Continue and get to the authentication problem.
 
My server folders structure looks like that, if that helps:
C:\Arma 2\ (about 20GB)
@DayZ_Sahrani
@Hive-Sara
_DZC_CACHE
AddOns
ARMA2_OA_Build_98220.zip_extracted
BEsetup
Common
dayz_1.sara
DirectX
dll
Dta
Expansion
Keys
Missions
MPMissioins
SQL
 
Yes, but only with this server i have problems. Any other public servers(sahrani) are ok and i do not have any problems connecting. So i think i made a mistake somewhere installing server.
 
So, any help? What about this switches:
-name
-world
Is -name=sara correct? This should not be folder dayz_1.sahrani? I'm shooting blind here..
Still retrying authentication, and this picture '\z\addons\dayz_code\gui\sahrani.paa not found' before that(what is wrong here?).
I did copied every files as in post #1, and still nothing.
 
Anything i change in start.bat, doesn't have any effect(world=mikimause fo example, no error), so i assume there is a mistake in this starting line. Can You explain to me switches from command line(like this world or name)?
 
Update. When i have 1.7.7 dayz, there is auth problem. When i downgrade i got 'you running incorrect version of dayz_code(1.7.6.1 and server is running 0.2.1-20130520).
Why he compares sahrani with dayz? Guys, if you do not want to help, just say so, i stop writing here..
 

Nonov Urbizniz

OpenDayZ Rockstar!
Staff member
Start a separate thread for your problem. Clearly outline what the exact problem is.

As seven stated earlier you are launching the game wrong, it is a client side problem not a server setup problem.
 
Top