[Support] DZMS DayZ Mission System

Tang0

Well-Known Member
I seem to be having a problem with the mission timings, though i have set the minor missions to start between 20 - 30 mins and major to start between 45 and 1 hour i have seen them start in the first 5mins of a server restart, any ideas (was fine before last DZMS update) - this is the part of my DZMSConfig that has the settings

// The Minumum time in seconds before a major mission will run.
// At least this much time will pass between major missions. Default = 650 (10.8 Minutes)
DZMSMajorMin = 2700;

// Maximum time in seconds before a major mission will run.
// A major mission will always run before this much time has passed. Default = 2000 (33.33 Minutes)
DZMSMajorMax = 3601;

// Time in seconds before a minor mission will run.
// At least this much time will pass between minor missions. Default = 600 (10 Minutes)
DZMSMinorMin = 1200;

// Maximum time in seconds before a minor mission will run.
// A minor mission will always run before this much time has passed. Default = 990 (16.5 Minutes)
DZMSMinorMax = 1800;
 

Tang0

Well-Known Member
In that rpt the first mission ran at 21.15, 15mins after server restart when the min time is to 20mins in the config, one of the server restarts earlier had 1 mission start 5mins after restart,im just wondering what the problem could be (its not a hugh problem)
 
Hi there

Thanks for that great script, runs smoother than every other AIscript!

We thought about setting the AI up for our sector on the LHD carrier, since Sarge isnt capable of walking on it properly.
So, we already have set one up with Sarge, but failed to add a permanent mission to an fixed spawnpoint with the DZMS.

This is my carrier.sqf

Code:
/*
    Ship Mission
*/
private ["_missName","_coords",];

//Name of the Mission
_missName = "USS Deathbringer";

//DZMSFindPos loops BIS_fnc_findSafePos until it gets a valid result
_coords = [14026.588, 1291.88, 15.1];

[nil,nil,rTitleText,"Bandits has captured The USS Tarawa!", "PLAIN",10] call RE;

//DZMSAISpawn spawns AI to the mission.
//Usage: [_coords, count, skillLevel, unitArray]
[_cords,6,1,"DZMSUnitsMajor"] call DZMSAISpawn;
It runs at last in the DZMSInit, after a sleeptimer. Maybe the _coords cant be set to the coordinate in here, maybe i have to add the z-axis value in addition. I dont know. Plese give us a hint ob how to setup an Mission at restart, on a fixed place, wich despawns and clear itself till next restart.

Much Thanks!
 

Vampire

OpenDayZ Rockstar!
Hi there

Thanks for that great script, runs smoother than every other AIscript!

We thought about setting the AI up for our sector on the LHD carrier, since Sarge isnt capable of walking on it properly.
So, we already have set one up with Sarge, but failed to add a permanent mission to an fixed spawnpoint with the DZMS.

This is my carrier.sqf

Code:
/*
    Ship Mission
*/
private ["_missName","_coords",];

//Name of the Mission
_missName = "USS Deathbringer";

//DZMSFindPos loops BIS_fnc_findSafePos until it gets a valid result
_coords = [14026.588, 1291.88, 15.1];

[nil,nil,rTitleText,"Bandits has captured The USS Tarawa!", "PLAIN",10] call RE;

//DZMSAISpawn spawns AI to the mission.
//Usage: [_coords, count, skillLevel, unitArray]
[_cords,6,1,"DZMSUnitsMajor"] call DZMSAISpawn;
It runs at last in the DZMSInit, after a sleeptimer. Maybe the _coords cant be set to the coordinate in here, maybe i have to add the z-axis value in addition. I dont know. Plese give us a hint ob how to setup an Mission at restart, on a fixed place, wich despawns and clear itself till next restart.

Much Thanks!
You spelt coords wrong in the AI Array. You also need to change DZMSUnitsMajor to something different, and then pre-define that array in DZMSMarkerLoop. You also need to add the marker in a different file. Otherwise it should work fine, but the AI will not keep respawning like SargeAI or DZAI will.
 
You spelt coords wrong in the AI Array. You also need to change DZMSUnitsMajor to something different, and then pre-define that array in DZMSMarkerLoop. You also need to add the marker in a different file. Otherwise it should work fine, but the AI will not keep respawning like SargeAI or DZAI will.

Thanks!

There is no need to mark the mission, the players have to find it (Intro Video). So DZMSUnitsMajor2 will do the job? Thought i have to arange another array for Unitsmajor2 with new the weapons and so.
 

Vampire

OpenDayZ Rockstar!
Thanks!

There is no need to mark the mission, the players have to find it (Intro Video). So DZMSUnitsMajor2 will do the job? Thought i have to arange another array for Unitsmajor2 with new the weapons and so.
Whatever you put as the array has to be predefined which is done in DZMSMarkerLoop.
The whole point of the array is to check if all the units are dead before the mission is completed, and then to clean the dead up.
It has nothing to do with what weapons and such they get.
 
Whatever you put as the array has to be predefined which is done in DZMSMarkerLoop.
The whole point of the array is to check if all the units are dead before the mission is completed, and then to clean the dead up.
It has nothing to do with what weapons and such they get.
Ok, now i do understand your construct. I dont have to predefine the array, because i want no marker, so i also dont have to set a arker in a different file.
This ist my Script;

Code:
/*
    Ship Mission
*/
private ["_missName","_coords"];

//Name of the Mission
_missName = "USS Deathbringer";

//DZMSFindPos loops BIS_fnc_findSafePos until it gets a valid result
_coords = [14026.588, 1291.88, 15.1];

[nil,nil,rTitleText,"Bandits has captured The USS Tarawa!", "PLAIN",10] call RE;

//DZMSAISpawn spawns AI to the mission.
//Usage: [_coords, count, skillLevel, unitArray]
[_coords,6,1,"DZMSUnitsMajor1"] call DZMSAISpawn;
So it call that script in DZMSInit, last position. It should only spawn my Units on that position on start, but it doesent do it. And there is no rpt entry. Should i setup a waittimer? Or add it in the Minormarker, to spawn with them?
 
Hey Vampire and whoever else may be able to answer my question...

Trying to add some more variability to the vehicles that spawn into the missions and I was wondering if it is possible for the mission to spawn a random selection of vehicles to the mission based on a list of possible vehicles. I have the option checked that saves vehicle to the database, but after having the missions up for awhile and having players tackle them, I just see BAF Offroad, HMMWV, BAF Offroad, HMMWV, UAF, UAF, UAF, etc, etc. in my database. To solve this I just put a more random list of vehicles into the missions, however, it occurred to me the best thing would probably be for the mission to randomly select 1-2 vehicles from a predefined list, that way there is a random possibility you may receive a Ural, or maybe you only walk away with a motorcycle or hatchback (for example). Is there any way to integrate this into the vehicle spawning sections of my mission files? I noticed that in the Bandit Helicopter Landing mission there is a line in there that basically says randomly pick between the helicopters in this list (by default I believe it was MH6J and Mi17, but I changed it to MH6J and UH1H_DZ), so my guess is its possible, however I don't feel confident enough to try and copy that into all the missions and have them actually work.

Also, Vampire I am still having the issue where only one vehicle is saving to the database--any updates on this? It's not that big of a deal just would be nice to fix if you happen to have a quick and easy solution.

And one more question--anybody have a custom mission that defines mission locations within the major cities or would be willing to assist me in making one? After having DZMS on my server for a bit we all have noticed it likes to spawn missions in roughly the same areas over and over and it would be nice to have some more variety. It can even be as simple as copying one of the existing missions into the possibility of missions that would occur, but that forces it into one of the major cities. Tried some test missions out awhile back after you guys helped me but I don't think I was doing it right and I am still a bit confused.

Thanks guys
 

Vampire

OpenDayZ Rockstar!
Hey Vampire and whoever else may be able to answer my question...

Trying to add some more variability to the vehicles that spawn into the missions and I was wondering if it is possible for the mission to spawn a random selection of vehicles to the mission based on a list of possible vehicles. I have the option checked that saves vehicle to the database, but after having the missions up for awhile and having players tackle them, I just see BAF Offroad, HMMWV, BAF Offroad, HMMWV, UAF, UAF, UAF, etc, etc. in my database. To solve this I just put a more random list of vehicles into the missions, however, it occurred to me the best thing would probably be for the mission to randomly select 1-2 vehicles from a predefined list, that way there is a random possibility you may receive a Ural, or maybe you only walk away with a motorcycle or hatchback (for example). Is there any way to integrate this into the vehicle spawning sections of my mission files? I noticed that in the Bandit Helicopter Landing mission there is a line in there that basically says randomly pick between the helicopters in this list (by default I believe it was MH6J and Mi17, but I changed it to MH6J and UH1H_DZ), so my guess is its possible, however I don't feel confident enough to try and copy that into all the missions and have them actually work.

Thanks guys
If you use the newest version this is already included with arrays in the config file.
 
In that rpt the first mission ran at 21.15, 15mins after server restart when the min time is to 20mins in the config, one of the server restarts earlier had 1 mission start 5mins after restart,im just wondering what the problem could be (its not a hugh problem)
I have pretty much the same problem as you. No errors in the log. No changes to my server files and then suddenly I see the mission times drop from 10-30 minute delay down to a constant 3 or 4 minute delay.
 

Vampire

OpenDayZ Rockstar!
I have pretty much the same problem as you. No errors in the log. No changes to my server files and then suddenly I see the mission times drop from 10-30 minute delay down to a constant 3 or 4 minute delay.
Are you talking about the initial startup, or the time in-between missions?
Both should be the same, but I'm starting to thing that a recent update changed it.
 
hi. im a new server owner and would love to test these missions. im just having problem with my mission.pbo with almost every script i want to add for example my mission.pbo doesnt have system folder in it. there is only ATPExclusion folder that has antihack.sqf in it and init.sqf/server_traders.sqf in the root and description.ext and mission.sqm thats all the files it has am i missing some basic customization step? server provider is dayz.st, thanks in advance.

EDIT: should i use different mission.pbo than default downloaded from dayz.st control panel?
 
Last edited:

Tang0

Well-Known Member
Are you talking about the initial startup, or the time in-between missions?
Both should be the same, but I'm starting to thing that a recent update changed it.
Its the actual time the 1st mission starts actually in game, mine is set between 20-30mins but last night the 1st minor mission actually started 9mins after the server restart ie server restarted at 9pm and when i was in game the 1st mission ran at 9.09pm
 

Tang0

Well-Known Member
hi. im a new server owner and would love to test these missions. im just having problem with my mission.pbo with almost every script i want to add for example my mission.pbo doesnt have system folder in it. there is only ATPExclusion folder that has antihack.sqf in it and init.sqf/server_traders.sqf in the root and description.ext and mission.sqm thats all the files it has am i missing some basic customization step? server provider is dayz.st, thanks in advance.

EDIT: should i use different mission.pbo than default downloaded from dayz.st control panel?
It has to be installed in your Server.pbo not the mission.pbo, in the dayz.st control panel Enable Advanced Settings and then at the bottom you will see Server.pbo, you should be able to download it from the server to your pc and change it then.
 
Top