Vehicles not spawning

Hi Everyone,

I am using the Pwnoz0r private hive dayz mod server files, which are excellent.
We have been having a great time on the server and the files make most things easy to do thanks to the guide.
However i have come across a problem and wondered whether you could help, basically the server is not spawning any vehicles at all, they appear in the phpmyadmin tables as having world locations, but they dont actually appear in game at all.

I have googled this issue else where but cant find any solution, people talk about the vehicles script but i cant find such a script.

Running 1.8.7 Dayz Private hive vanilla Chernarus.

Any and all help is greatly appreciated.
 
The SQL file was updated about 11 days ago at this point. Make sure to grab the latest version of the SQL file here.

Commit changes
Ok so i have removed the old database and remade it using the new sql file you kindly provided me, but the same problem still persists, also tents do not save after server restart i have just found out.

Update : The tents and vehicles appear to be writing to the db, i.e the vehicles have world locations and the tents show as being written on the db, but the vehicles dont show at all and if you stop and start the server the tents are no longer there (even though they still show on the db) they dont appear in game after restart, so it seems to be writing the data correctly but not reading the data correctly ?
 
Last edited:
Pwnozor,
First ace job on DayZ mod dude. Still way better than SA.

Ash and I have been getting nowhere all day with this.

We have completely rebuilt both the DB and server a few times and followed your guide to the letter.

We are stumped!

Please help. We are losing all our hair!
 
So we managed to get the tents to stay after restart, i changed the instance name from 1337 to the server name (thinking it was the water mark section....yes im stupid), however the vehicles are still not spawning even after running the new sql file.
 

Pwn

Administrator
Staff member
Execute
Code:
CALL `pMain`('i');
and
Code:
CALL `pSpawnVehicles`('i');
on your MySQL database (where i = instance). This should spawn vehicles for your instance. If your server is running when this executes, a restart will be required for the changes to take place.
 
Thanks for getting back to us dude.
I'm afraid we are way down the level of knowledge!☹️
Where are those to be executed and how do we execute them.

I notice in the 187.sql that pMain has an instance of (1337) as per the allocated instance.

Sorry for being noobz
 
Execute
Code:
CALL `pMain`('i');
and
Code:
CALL `pSpawnVehicles`('i');
on your MySQL database (where i = instance). This should spawn vehicles for your instance. If your server is running when this executes, a restart will be required for the changes to take place.
Excellent thank you very much for the help, but yeah what PCSheepy said :)
 
Ok so I think! I know what you mean! :-/

In the init file our server instance is set as 1337.

I can see pMain ('I') and pSpawnVehicles ('I') in the 187.sql file.

Am I right that I need to change the ('i') in both those to ('1337') then execute the 187.sql file again.

Sorry for being such a douche!
 
So we tried changing the ('i') in both and then re executed the 187.sql but yet vehicles still don't seem to appear in game.

-- Dumping structure for procedure hivemind.pMain
DELIMITER //
CREATE DEFINER=`dayzhivemind`@`%` PROCEDURE `pMain`(IN `1337` INT)
MODIFIES SQL DATA
BEGIN
# Server instance ID.
#-----------------------------------------------
DECLARE sInstance VARCHAR(8) DEFAULT i;
#-----------------------------------------------
#Last Ran
update event_scheduler set LastRun = NOW() where System = "pMain";
#Starts Cleanup
CALL pCleanupBase(); #comment out to disable base decay
CALL pCleanup();

CALL pSpawnVehicles(sInstance);
END//
DELIMITER ;

-- Dumping structure for procedure hivemind.pSpawnVehicles
DELIMITER //
CREATE DEFINER=`dayzhivemind`@`%` PROCEDURE `pSpawnVehicles`(IN `1337` int)
 

Pwn

Administrator
Staff member
Ok so I think! I know what you mean! :-/

In the init file our server instance is set as 1337.

I can see pMain ('I') and pSpawnVehicles ('I') in the 187.sql file.

Am I right that I need to change the ('i') in both those to ('1337') then execute the 187.sql file again.

Sorry for being such a douche!
So we tried changing the ('i') in both and then re executed the 187.sql but yet vehicles still don't seem to appear in game.
Since the default instance is 1337, execute
Code:
CALL `pMain`('1337');
on to your MySQL database.
You don't need to worry about what is in the 187.sql file as that is that does nothing after it is executed on the database.
 

Pwn

Administrator
Staff member
dayzhivemind

I'm on TS if that's easier ts.iruclan.com
Delete your database and execute the 187.sql file I just updated. Then run the following on your server:
Code:
CREATE USER 'dayzhivemind'@'%' IDENTIFIED BY 'password';
GRANT ALL PRIVILEGES ON hivemind.* TO 'dayzhivemind'@'%' WITH GRANT OPTION;
FLUSH PRIVILEGES;
Make sure to change password to a strong password.

After this you should be able to run the pMain function.
 
Top