DayZ Chenarus Auto Refuel! All stations!

Seems the bug with vehicles driving away is fixed but still not getting any messages to pop up saying what is going on. my channels are "disableChannels[]={0,2,6};". Any ideas?

I don't particularly care about the messages i'm just trying to prevent any butt hurt from players not knowing their engine is about to turn off haha. thanks again.
 
Mattz just a thought, looking at the script it seems the messages will be showing up via vehicle chat correct? I'm curious if your testing this by yourself or if other players are on the server in the vehicle with you? From my experience in the past if you are trying to send any type of message without another player to receive it, it won't actually display, could this possibly be the case?
 

axeman

OpenDayZ Rockstar!
Mattz, great work, am adding this straight on my server along with your heli script, many thanks.

I also am testing on my own on a server, will try it with people on the server.
 
I landed with my chopper on a fuel station. and i got message ''refuel script bla bla not found. and engine on or off it will not refuel. i just copy paste what u gave us on page 2. maby i am to lazy and i need to do more :) pleas explain what i did wrong.
 
Hi Five

You need to put the fouler in your MPMissions/*MissionNameHere/


Axeman
Please let me know how it goes

Tempestrip

I am not 100% sure....
 

axeman

OpenDayZ Rockstar!
Mattz, I'm afraid I am still not seeing the text. I have made sure the correct channels are on (disableChannels[]={0,1,2,6};). I had somebody join the server (not in the car). Everything else works a treat.. Very strange, personally am not too fussed but am happy to test it for you to try and get it working.
 
hi MAttz.

thanks found the file idd. but u want me to paste is somewhere right? or is this a total new file i just got to save as .sqf?

Bec i also got debug already running so got the file.
 
yeh shib, i find that there is no consistency with what goes wrong with adding scripts, when i first added it, i was getting kicked for #40 not 44 or 43

i guess such is the nature of beta software and using battleye

but my server is capable of running without kick now, i just want to add specific functionality b4 i upload everything to my colo'd server in dallas
 

axeman

OpenDayZ Rockstar!
Had to remove this from my server.. caused mass BE Script #44/43 kicks

You should be able to add:
Code:
 !"scriptsMZ\MZ_reload.sqf"
to each line in <mod directory(dayz_1.chernarus>\BattlEye\scripts.txt on the end of the corresponding line to filter out this .sqf from that process in BE. You will see the process name at the start of the line in scripts.txt, eg. 5 setFuel.

Have read that the lines are one number out, am assuming they start at zero ? Personally, I deleted the line from my scripts.txt (needs fixing). Not sure if the numbers changed as I deleted lines, from my scripts.txt, as the line number (after the deleted line) is then different, I have a feeling it did.. So look for the function that caused the ban in the scripts.log file in the same directory. NB. restarter.exe moves them to a dated backup directory...
 
Mattz, I'm afraid I am still not seeing the text. I have made sure the correct channels are on (disableChannels[]={0,1,2,6};). I had somebody join the server (not in the car). Everything else works a treat.. Very strange, personally am not too fussed but am happy to test it for you to try and get it working.
Unpack your mission.pbo
Open up init.sqf
look for this line:
enableRadio false; // Disable global chat radio messages

Change it to:
//enableRadio false; // Disable global chat radio messages
 
You should be able to add:
Code:
 !"scriptsMZ\MZ_reload.sqf"
to each line in <mod directory(dayz_1.chernarus>\BattlEye\scripts.txt on the end of the corresponding line to filter out this .sqf from that process in BE. You will see the process name at the start of the line in scripts.txt, eg. 5 setFuel.

Have read that the lines are one number out, am assuming they start at zero ? Personally, I deleted the line from my scripts.txt (needs fixing). Not sure if the numbers changed as I deleted lines, from my scripts.txt, as the line number (after the deleted line) is then different, I have a feeling it did.. So look for the function that caused the ban in the scripts.log file in the same directory. NB. restarter.exe moves them to a dated backup directory...
Ya I know but I fixed the 44 and then everyone got kicked for 43. And mass kicks when you have 25 people on is bad for business haha. But getting a local server setup to bug test on is something I plan on doing and I'll figure this out on there
 
Okay there is another problem:

1. Car stops at Fuel station
2. Refueling starts.
3. Car leaves while refueling.
4. Still refueling while driving


Any ideas how to fix it?
 
Top