[Support] ESS

Ebay, this is SideFX on Blur's site. A few weeks ago, you helps me install an action menu. In the instructions, I edited the same line in "cleanup.fsm" as I did in this script's instructions. Unfortunitly they are not the same edit and giving me huge erros in the RPT. Funny thing is, the script works fine with the exception of slow loading times and the occasional stuck in debug..

Here is the errors in RPT. I would appreciate any insight on what could be going on, or how to fix.

Code:
2:22:04 Error in expression <ustom\variables.sqf"
DayZ_SafeObjects = DayZ_SafeObjects+["ParachuteC"];

donorL>
2:22:04 Error position: <DayZ_SafeObjects+["ParachuteC"];

donorL>
2:22:04 Error Undefined variable in expression: dayz_safeobjects
2:22:04 File mpmissions\__cur_mp.chernarus\custom\variables.sqf, line 1
2:22:05 Error in expression <;
_recompile = (count _this) > 0;


if (BIS_fnc_init && !_recompile) exitwith {t>
2:22:05 Error position: <BIS_fnc_init && !_recompile) exitwith {t>
2:22:05 Error Undefined variable in expression: bis_fnc_init
You will notice the RPT shows the line edited with ParachuteC added.. I've tried adding both script's parachuteC edits below one another, and I tried adding them together. It seems that I get the same error regardless. Also the very first code, the "c" is not missing from the file name. I don't see why that cut it off.


This is the instructions on the blur site
http://blurgaming.com/community/threads/ebay-are-you-still-around.1840/

I sure appreciate the help you provide us, and the wicked scripts! A+ in my book!
 
Hi,
i have this error in my RPT :

Code:
ErrorMessage: File mpmissions\__cur_mp.chernarus\spawn\halo.hpp, line 60: /halo_dialog/Controls.halo_picground: Undefined base class 'RscPicture'
 
OK im getting desperate to get this working as it looks like a killer script but I still cant get it working.
I installed it for epoch down to the exact instructions only thing i did was remove some select-able classes (yes i removed the very end comma at the last class after i took others out).
Heres my RPT now all it does is put me back into the lobby because of a timeout, heres my RPT log from start till i stop the server after ive been dced.
RPT: pastebin.com/NgK2WSF1
Server Functions.sqf: http://pastebin.com/XDpmt8kN
Server Monitor.sqf: http://pastebin.com/RN8mNDhH

any help to fixing this will be greatfully appreciated because im out of hair to pull over this thanks
 

js2k6

New Member
As per my previous post,
I tried a few different things to try and get the loadout selector pulling from the database.
Unfortunately I had no luck.
I also encountered some bugs with the halo drop. When the server fps started dropping off, the epoch anti-tp script was causing mayhem, players were stuck in freefall animation on the ground and my rpt was full of "teleport reverted" entries.

I dont use infi, i use an edited version of blue phoenix and gcam for spectating. only seemed to happen once we hit 25-30 players and the server fps dropped to 2-3 and below.

So i'm thinking halo plus the desync caused the game to think these legit players were teleporting.
Got around it by disabling the default epoch anti-tp script.

Not really something I expect support for, just posting this so if any other server admins notice this happening, they'll know what the cause is.

Thanks guys.
 
Got a slight issue.

When I select a class I get an error stating "bad vehicle type".

Does anyone know the cause of this? I have been combing the code looking for what is causing it, but I am not finding anything.
 
Hi, on 1803 in variables.sqf instead of this:
Code (Text):
DayZ_SafeObjects = DayZ_SafeObjects+["ParachuteC"];
It should be this:
Code (Text):
SafeObjects = SafeObjects+["ParachuteC"];

We are running on 1.8.1..

Also, have you had any reports of player's humanity not saving after a server restarts, when using this script,
and players spawning in the spot they logged out at, without any gear?

Thanks ebay!
 
Interesting, I had no indications of a broken server_cleanup.. I did notice that after the patch there is a cleanup.sqf and a cleanup.fsm... Not sure if that has anything to do with it.

Thanks again for your help bud!
 

Fr1nk

Valued Member!
Everything works great. I don't use donor bases on my server though...is there a way to remove the "Your Base" spawn option on the selection map?
 

js2k6

New Member
Got a slight issue.

When I select a class I get an error stating "bad vehicle type".

Does anyone know the cause of this? I have been combing the code looking for what is causing it, but I am not finding anything.
I have a bunch of different classes set up
two of them cause this issue, both are related to the backpack. or in the case of these two classes, the lack of backpack. the support class has an lmg that takes up his backpack slot, and the engineer has a carl gustav in its place.
all of my other classes have backpacks, and they all function without that error.
running overpoch. (epoch 1.0.4.2 + overwatch 0.2.5)

Code:
["* Level 3 Engineer *","gsc_military_helmet_wdl_AT",["ItemBandage","ItemBandage","ItemMorphine","ItemBloodbag","vil_20Rnd_9x18_aps","vil_20Rnd_9x18_aps","20Rnd_762x51_DMR","Vil_CG_HEAT"],["ItemKnife","ItemHatchet_DZE","Binocular","vil_APS","RH_sc2eot","vil_CG84T"],"",[],[],3,0],
["* Level 3 Support *","gsc_military_helmet_wdlSNP",["ItemBandage","ItemBandage","ItemMorphine","ItemBloodbag","RH_32Rnd_9x19_Muzi","RH_32Rnd_9x19_Muzi","200Rnd_556x45_L110A1","200Rnd_556x45_L110A1","HandGrenade_West"],["ItemKnife","ItemHatchet_DZE","Binocular","RH_muzi","BAF_L110A1_Aim"],"",[],[],3,0],
 

Fr1nk

Valued Member!
Everything works great. I don't use donor bases on my server though...is there a way to remove the "Your Base" spawn option on the selection map?
Figured it out, just need to comment out or remove the following classes from spawn.hpp:

Code:
class btnDono: RscButtone
        {
            idc = 1616;
            text = "Base";
            x = 0.6 * safezoneW + safezoneX;
            y = 0.241 * safezoneH + safezoneY;
            w = 0.0422917 * safezoneW;
            h = 0.0188889 * safezoneH;
            action = "spawnSelect = 40;";
        };
Code:
class lblMap2: RscText
        {
            idc = 1001;
            text = "Click here to spawn at your base:";
            x = 0.43 * safezoneW + safezoneX;
            y = 0.24 * safezoneH + safezoneY;
            w = 0.239687 * safezoneW;
            h = 0.0290741 * safezoneH;
        };
Thanks ebay for the great work, as usual.
 
ebay, the strangest thing just happened to me with this script. I died in game, was loading in and picking my class and I can hear someone shooting me. So after spawning in, I use admin to tele to debug and there are 2 AI's shooting players as they log in.. We don't have AI on our server and it was for sure AI as their movements where synced, no tags, and after I killed them, the AI message ( something like "blue on blue, man down") popped up.. Very strange no?


Also, is there a way to keep the class select and ground/halo spawn, but remove the options of picking spawn and make that default? We like the heavy concentrated pvp stuff and this is spreading players out.

Thanks
 
Top