Base Building DayZ 1.2 Released

ALKINDA

Valued Member!
i dont think the server_functions is working correctly. the if statement isnt working.

Code:
//server_functions.sqf snippet
diag_log format ["DEBUG: Checking if Object: %1 is allowed published by %2", _object, _playername];
if ((typeOf _object) in _allowedObjects || (typeOf _object) in allbuildables_class) then {
        diag_log format ["DEBUG: Object: %1 published by %2 is Safe",_object, _playername];
        _allowed = true;
    };
Code:
//server log rpt snippet
2:50:55 "DELETE: Deleted by UID: 0"
2:51:08 Server: Object 4:159 not found (message 94)
2:51:30 "DEBUG: Checking if Object: 288f8100# 1056713: cncblock.p3d REMOTE is allowed published by Server"
2:53:08 "DEBUG FPS : 47.9042
 
Like I said I'm a rookie . Read your post looks like you followed the 1.7.6 instructions.
Not sure but try the 1.7.4 stuff. That's what I do..I read all read me stuff, read all forum threads I can find and just go for it.
The instructions are a bit confusing. Hell look at this thread we are all having problems. Did you add all the items to your Database? have you checked the logs for errors ? Most likely that would point you to your problem.
Del
I was looking for 4 days for a solution. Then I regestriert me here and I hope to help me. in other forums I do not even get an answer to my question :-( But here, the people care for someone! I despair.
 
I think i found the problem! But i dont know to fix it.

For Server restart he remove objects withe the UID !
After restart he remved objects with ID and not with UID!

Any solutions ?

Mfg
 
No... we are trying and trying for weeks now without any result, it just hangs on requesting authentication and then getting to something went wrong.

Version 1.1 worked pretty good, only thing there not working were panels and the write to database, so when server restarts all is gone again. Version 1.2 does not work at all.
 
Also wrote to Daimyo about it but as i get no answer from him, I know he's busy but sent him 5 weeks ago, he just does not know how to get it working on the modified bliss for CC, that leaves about 70% of all servers not having BaseBuilding in it.
 

Fox

Well-Known Member
ouch ... so we fucked up by using the damn CC ... sry i'm running this software too but it has too much bugs and development is closed since v. 5.9.2.0
 
ouch ... so we fucked up by using the damn CC ... sry i'm running this software too but it has too much bugs and development is closed since v. 5.9.2.0
Ah don't feel bad man ...I'm running 1.7.4 on Taviana and I get my ass handed to me by one thing or another daily. If its not a control panel ,,or a wall that moved...or simply players having probs building. Don't get me wrong IT WORKS..just a real handfull to get going.
@ Gary ...that scripts.txt didn't go well last night..so no luck on the # 40 kick ..dam I hacked up that file // everywhere lol.
 
I installed BB1.2 onto my server and everything works fine, except for gate panels disappearing after build and objects shifting into the ground and not conforming to slopes on server restart. I'm using DayzCC 5.9.2.0 on Chernarus. I've also attached my server_monitor.sqf. If anyone wants to help me out, it would be appreciated.
 

Attachments

ALKINDA

Valued Member!
Also wrote to Daimyo about it but as i get no answer from him, I know he's busy but sent him 5 weeks ago, he just does not know how to get it working on the modified bliss for CC, that leaves about 70% of all servers not having BaseBuilding in it.
hey man im using reality and fully updated everything. im still in the hole with this mod only able to create and not save to database.
 
I have been trying to add the base building script to my server i have Dayz st server but when i get to my sql thats where i get confused can anyone lend a hand and point me in the right direction i would greatly appreciate the help
 
is there any way to get this to save a players GUID as owner id ?

its absolutely pissing us off that when you die you cant work on your base bits again, we want the base objects to follow a player not the single life. its such a stupid thing
 
I installed BB1.2 onto my server and everything works fine, except for gate panels disappearing after build and objects shifting into the ground and not conforming to slopes on server restart. I'm using DayzCC 5.9.2.0 on Chernarus. I've also attached my server_monitor.sqf. If anyone wants to help me out, it would be appreciated.
I am working with the exact same setup as you, though I can not get past the requesting authentication, could you send me your discription.ext, mission.sqm, init.sqf and the server.pbo please, so I can compare to what I have done.

I am using rMod also though.

Thanks in advance
 

Sarge

OpenDayZ Guru!
Staff member
is there any way to get this to save a players GUID as owner id ?

its absolutely pissing us off that when you die you cant work on your base bits again, we want the base objects to follow a player not the single life. its such a stupid thing
The db structure would need to be extended. I wrote an extension to R3F a couple of months ago, that allows full basebuilding, and owner storage. Realizing there is no way to store special values in the db schema, i suggested to the Server package developers to add either a custom table, or a custom field to the relevant tables to allow this.

Haven't seen that one yet.

cheers, Sarge
 
Top