Base Building DayZ 1.2 Released

seaweeduk

OpenDayZ Rockstar!
if a players dies a number of times within that hour tho will your script catch all that ?

Having to wait for a restart is better than having to ask an admin to edit the database manually. or being stuck not being able to work on your base.

we need some code. and a walk through how to install :)
Yup the last time I run it is after I shut the server down and right before it starts up again, so the most recent ID will always be inserted if they have a new character already. Otherwise it will be left the same until they get a new living survivor.
 
can you share this code ? cos at the moment when the players who build bases on our server dies we are having to update the database manually with their new id's which as im sure you can imagine is a pain in the ass, so having this done automatically every hour would be a bloody god send.
 

seaweeduk

OpenDayZ Rockstar!
can you share this code ? cos at the moment when the players who build bases on our server dies we are having to update the database manually with their new id's which as im sure you can imagine is a pain in the ass, so having this done automatically every hour would be a bloody god send.
Nope too many people on this forum expect everything handed to them on a plate maybe someone else will help you out with it
 
well thanks for the help, if I had been scripting with arma for years I would probably know exactly what to do, but iv only just started so guess I will need to wait till some one with more experience comes along that are more helpful
 
When ever i try to join my server after adding the script, im getting kicked even before entering the map.
I come to lobby pressing ok and after that it just freezes for 5-10 sec and gives me a battle eye script restriction #8.
Anyone knows why that might happen or even have a fix for it.
I have allready added the lines in the battle eye files but no luck
 
I have looked through this thread twice at every post and cannot find a way to fix my issue. I am running a DayZ.st Chernarus server with Salvaging, Auto-Refuel and a few other things and I am continually getting stuck on "Wait for Host", even when I included the 'fix' on Page 1 of this thread. I really am at a loss, as this is the 6th time I've tried to install the mod. Would somebody please have a look at my .pbo's and help me out. I would be incredibly grateful :)
 

Attachments

can you share this code ? cos at the moment when the players who build bases on our server dies we are having to update the database manually with their new id's which as im sure you can imagine is a pain in the ass, so having this done automatically every hour would be a bloody god send.

Its simple just make a script or batch file that updates the db or do it manual like this .

UPDATE instance_deployable d LEFT JOIN (
SELECT DISTINCT d.owner_id, s.unique_id
FROM instance_deployable d
LEFT JOIN survivor s ON s.id = d.owner_id
WHERE s.is_dead =1
) AS dead ON dead.owner_id = d.owner_id
LEFT JOIN survivor live ON live.unique_id = dead.unique_id
SET d.owner_id = live.id WHERE live.is_dead =0
 
Ok, I've tried for a week and a half now to get this to work on my Tavi 2.0 server and I cannot seem to get it to work. I've painstakenly gone over the instructions with the Github numerous times and yet after I repack and upload my pbo files, I have no luck. I am able to get other scripts to work properly with the map, and I know this works on Tavi, so what am I doing wrong?

Basically, is there anyone who was able to get this to work willing to work with me this weekend to get this on my server?
 
anyone havin issues with base building ill do my best to help ya, it works flawless on my server just PM me for my mumble,skype and ill fix ya up,also i just switched server hosts and man i love my new one if anyone wants the businesses website i can confirm they are one of the best PM me for their info as well. Also can assist with: Auto-Refuel,Working street and house lights,full moon nights etc if anyone needs them as well
 

Gagi2

Valued Member!
i have issues with the codes after respawn and or serverrestart
and also with built objects that move around slightly on every server resart...
so after a few restarts your base has open gaps...
has someone else this problem with the movement or am i the only one?
 

seaweeduk

OpenDayZ Rockstar!
i have issues with the codes after respawn and or serverrestart
and also with built objects that move around slightly on every server resart...
so after a few restarts your base has open gaps...
has someone else this problem with the movement or am i the only one?
Thats just the ARMA engine vehicles have the same issue, build on a flatter surface or overlap your objects.
 
Dunoe if anyone else has noticed this issue, sems like the uniq id has issues might be something else on my server causeing the issue still looking into it. What happends is when server loads up it assigns in this instance an tent unix id: 3951181802207. I can se this in the RPT log and this is the one from database, when i go into the tent remove an item, i se it update in the RPT but it says its uniq id: 3951181800207. You se it changed one of the 2 to a 0. Think this is happening the building objects aswell makeing it imposible to remove them even if you have the code.

Update: have been able to track down the issues to server_monitor.sqf so looking into that now, as the orginal server_monitor.sqf whitout any of the basebuilding codes things work just fine. So something in there makes stuff go haywire as far as tens and probely other objects updateing.
 
I might be wrong but think the issue is dayz_objectUID2 and the use of it. What happends in thing shift, tents buildebols etc. So what happends is that dayz_objectUID2 and the uid that are in the database wont match up anymore due to things shifting around. Can anyone else confirm this?
 
has anyone really played with the graves ? mine seem to work, but they do not survive past a restart, the grave remains but the bomb effect goes away..

I was thinking, would it not make sense that to arm a grave you would just open it, drop in a grenade and then crawl away ? with the opening only working when its not armmed. ?

or is there a fix for this so they remain after a restart still work, and remove when they blow up ?
 
Thanks for the Great Work!!!!

I followed the instruction but in Game when i klick "build recipes" in the ScrollMenu
the Window what pops up isimmediately disapperd. How to fix that?!
Hope someone can Help.

Running on Chernarus Map with rMod.
Using DayzCC with Pwnoz0r Server Files.
Thanks alot!

Greetz Ace
 

J3T

Valued Member!
God stucked at requesting Authentications... can't find the freaking error...

*edit* Got it working but we don't have the Bulding Script scroll menue. Just looking how to get it fixed.
 
Top