[Support] DZGM

DY357LX

New Member
Yeah, DZGM works fine now Plot Management has been removed.
Normally I enjoy hunting down little problems like this... but this one has me genuinely stuck.
Anyway...
I have emailed the download link to you, ShootingBlanks.
 

DY357LX

New Member
On our test server we use the standard Survivor2_dz skin whilst testing things.
I'll run your code to test side in the next day or two when I'm not working.

I noticed that even when I'm the sole player on the server, if DZGM is working, I can click my own name to make the "Invite" button appear. No additional players on needed on the server. I simply can't invite myself.
When Plot Management is added the "Invite" button will not appear.

Thanks for taking the time to help.
 

ShootingBlanks

OpenDayZ Guru!

NO !!!!! Not 1.06 when we have almost everything working on 1.0.5.1 LOL ..

back to the topic. I dont KNOW but it would seem to me that the invite button would exist regardless of the player sides of other players. Actually joining them could be an issue, but the button should be there. If the button disappears as soon as plot management is installed, there must be a conflicted IDC or something like that that. It cant be a classname directly as that would result in the "member already defined".

@DY357LX
As for no errors in the rpt. Have we looked in the CLIENT rpt log?

I am just rather curious on why a button would suddenly not display. I may take a default mission, install dzgm then install plot management and see if its just those two.
 

Inkko

OpenDayZ Rockstar!
As @ShootingBlanks said it is hard to debug this mod alone since it requires 2+ players. Side shouldn't be an issue on stock 1.8.6.1 or Epoch since all the _DZ skin configs (even bandit) use the Survivor_DZ base class' side which is West. However, it is probably a problem if you are using a mod like ESSV2 which uses non _DZ skins. Some of those may make you East or Guerilla (like Farmer, Worker, TK_Soldier_INS), even though player_switchModel attempts to join you into a West group. I haven't tested, but the easy way to check is go in game, choose one of those skins at spawn class selection, then run:
Code:
systemChat format["My side is: %1",side player];
If it is not returning West then we may have found the problem. Overwatch defined their _DZ skins as side=1; in their cfgVehicles (1=west), however many servers use the non _DZ skins Overwatch unlocks, so that could also be a problem.

I am planning to do an overhaul of dzgm. Right now I'm working on making Epoch 1.0.6 happen but after that I will return to this and have time to test.

Well I am using ESSV2 but I don't use the loadout section part, I just use the spawn selection part of it. I do however have additional non _DZ skin that players can use that are additional options on clothing parcels. I'll test it out and see what the side is returning since people do use the non _DZ skins a lot.
 

Hux

New Member
After installing DZGM I've had some problems with commanding my AI (I have AI Recruit installed).

I am now unable to divide my AI into groups. When I select a unit and then select "team" the menu disappears.

Second problem is I'm unable to use TacticalView using the "." key on numpad.

Is there some way to fix this?

Thank you.
 

Hux

New Member
@Hux - Most people don't want those accessible, so I disabled them by default. To enable remove this from icons.sqf:
Code:
if (commandingMenu in ["RscTeam","#User:BIS_Menu_GroupCommunication"]) then {showCommandingMenu "";};

And remove from dayz_spaceInterrupt:
Code:
if (_dikCode in actionKeys "TacticalView") then {_handled = true;};

Thank you ebay. That did the trick...
 

Hux

New Member
BTW, I was looking in the init.sqf and thought these lines might have something to do with my issue:

//#include "\ca\editor\Data\Scripts\dikCodes.h"
//keyboard_keys set [DIK_LWIN,{if (tagName) then {tagName = false;titleText ["\n\nGroup name tags OFF","PLAIN DOWN"];titleFadeOut 4;} else {tagName = true;titleText ["\n\nGroup name tags ON","PLAIN DOWN"];titleFadeOut 4;};_handled = true;}];
//keyboard_keys set [(actionKeys "TacticalView") select 0,{_handled = true;}];
//keyboard_keys set [DIK_RWIN,{if (dialog) then {closeDialog 0;groupManagementActive = false;} else {execVM "dzgm\loadGroupManagement.sqf";};_handled = true;}];

I was curious why they are commented out.

What are they for?
 

Hux

New Member
I get name tag hovering over my character when I'm not even using DZGM (not part of a group).

I can turn off the name part but I still have the little green dot over me.

Is there a way to disable this?

Thank you.
 

Dztancem8

New Member
Have a problem with the plugin, my server keeps spamming that theres an error in Defines.hpp

I have Ploy management installed which also adds to this file.

To keep everything nice, I took the defines.hpp file merged it with my STANDARD one with Plot management added to it and now its fucked. Help?
 

Dztancem8

New Member
ErrorMessage: File mpmissions\DayZ_Epoch_11.Chernarus\dzgm\icons.hpp, line 14: /RscTitles/DZGMHud_Rsc/controls.Icons: Undefined base class 'W_RscStructuredText'
 

ShootingBlanks

OpenDayZ Guru!
each class must be defined once and ONLY once. but it MUST be defined, that one is not.
when you #include a file,,its the same as copy/pasting that file in that spot.
so the class W_RscStructuredText, must be defined in some included file before icons.hpp is included because a control in icons.hpp is a child of it.
i know classes are confusing at first. google base classes and class inheritance for c++ to understand all the class errors .. they are common

find the W_RscStructuredText class and add it to your defines.hpp,
and then you probably didnt add in the other custom base classes either such as w_rsctext...,just guessing ... but check
 
Last edited:

Dztancem8

New Member
Well we have a fix but, now once we have 2 admins connect they can connect and invite other admins to a group

EXCEPT, if two normal players join, they get invited to a group, click accept and it says the group invite does not exist. Also, the players cannot see any other players in the left column where other peoples in the server should appear instead they only see their own name? Anyone else having this problem?

EDIT:
Thought it was a diolog problem at first so hunted through all the files and added the the infistars exceptions, STILL NOT WORKING. Only admins still being able to add players to a group and normal players cannot not. DAFUQ?

https://gyazo.com/0cb1c0ecf436ed1856f63cef937ef21b

There is more than 1 player on the server and only 1 shows?
 
Last edited:
Top